x264 0.155.2893 (very recent changes)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

x264 0.155.2893 (very recent changes)

Reindl Harald
FYI:

ffmpeg 3.4.1
src/libavcodec/libx264.c: In function 'X264_init_static':
src/libavcodec/libx264.c:892:9: error: 'x264_bit_depth' undeclared
(first use in this function); did you mean 'x264_picture_t'?
  if (x264_bit_depth == 8)
  ^~~~~~~~~~~~~~
  x264_picture_t
make: ***
[/home/builduser/rpmbuild/BUILD/ffmpeg-20171212/ffbuild/common.mak:60:
libavcodec/libx264.o] Error 1
make: *** Waiting for unfinis
_____________________________

fresh snapshot from git

[builduser@buildserver:/rpmbuild/SPECS]$ rpmbuild -bb ffmpeg-latest.spec
Ausführung(%prep): /bin/sh -e /var/tmp/rpm-tmp.IXDZ1x
+ umask 022
+ cd /home/builduser/rpmbuild/BUILD
+ cd /home/builduser/rpmbuild/BUILD
+ rm -rf ffmpeg-20171225
+ /usr/bin/xz -dc /home/builduser/rpmbuild/SOURCES/ffmpeg-20171225.tar.xz
+ /usr/bin/tar -xof -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd ffmpeg-20171225
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Ausführung(%build): /bin/sh -e /var/tmp/rpm-tmp.3J4UGz
+ umask 022
+ cd /home/builduser/rpmbuild/BUILD
+ cd ffmpeg-20171225
+ mkdir generic
+ pushd generic
~/rpmbuild/BUILD/ffmpeg-20171225/generic ~/rpmbuild/BUILD/ffmpeg-20171225
+ ../configure --prefix=/usr/local --bindir=/usr/local/bin
--mandir=/usr/local/man '--extra-cflags=-I/usr/local/x264 -m64 -O2 -g0
-mfpmath=sse -mavx -msse2avx -march=sandybridge -mtune=sandybridge
-fopenmp -pipe -fno-strict-aliasing -fomit-frame-pointer -fexceptions
-fstack-protector-strong --param=ssp-buffer-size=6 -D_FORTIFY_SOURCE=2
-Wstack-protector -Wformat -Werror=format-security -Ofast -ffast-math
-funsafe-math-optimizations -Wno-pointer-sign -minline-all-stringops
-fno-strict-aliasing -fuse-ld=gold -fuse-linker-plugin
-Wa,--noexecstack' '--extra-ldflags=-I/usr/local/x264 -L/usr/local/x264
-ldl -Wl,--as-needed -Wl,-z,now -Wl,-z,relro -Wl,-z,noexecstack -m64 -O2
-g0 -mfpmath=sse -mavx -msse2avx -march=sandybridge -mtune=sandybridge
-fopenmp -pipe -fno-strict-aliasing -fomit-frame-pointer -fexceptions
-fstack-protector-strong --param=ssp-buffer-size=6 -D_FORTIFY_SOURCE=2
-Wstack-protector -Wformat -Werror=format-security -Ofast -ffast-math
-funsafe-math-optimizations -Wno-pointer-sign -minline-all-stringops
-fno-strict-aliasing -pie -fPIE -fuse-ld=gold -fuse-linker-plugin
-Wa,--noexecstack' --ar=gcc-ar --ranlib=true --enable-nonfree
--enable-gpl --enable-pic --enable-version3 --enable-libmp3lame
--enable-libtheora --enable-libx264 --enable-libx265 --enable-libvpx
--enable-openssl --enable-static --enable-runtime-cpudetect
--disable-amd3dnow --disable-amd3dnowext --disable-avdevice
--disable-debug --disable-devices --disable-ffplay --disable-ffprobe
--disable-ffserver --disable-htmlpages --disable-hwaccels
--disable-iconv --disable-libdc1394 --disable-libfreetype
--disable-libgsm --disable-libopencore-amrnb --disable-libopencore-amrwb
--disable-libopencv --disable-libopenjpeg --disable-libopus
--disable-librtmp --disable-libspeex --disable-libvorbis
--disable-libxvid --disable-podpages --disable-postproc
--disable-protocol=gopher --disable-shared --disable-txtpages
ERROR: libx264 not found

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
[hidden email] mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "ffbuild/config.log" produced by configure as this
will help
solve the problem.
Fehler: Fehler-Status beim Beenden von /var/tmp/rpm-tmp.3J4UGz (%build)

[builduser@buildserver:/rpmbuild/BUILD/ffmpeg-20171225/ffbuild]$ ls
insgesamt 28K
-rw-r--r-- 1 builduser builduser  829 2017-12-25 22:17 arch.mak
-rw-r--r-- 1 builduser builduser 5,0K 2017-12-25 22:17 common.mak
-rw-r--r-- 1 builduser builduser 3,7K 2017-12-25 22:17 library.mak
-rwxr-xr-x 1 builduser builduser  478 2017-12-25 22:17 libversion.sh
-rwxr-xr-x 1 builduser builduser 1,5K 2017-12-25 22:17 pkgconfig_generate.sh
-rwxr-xr-x 1 builduser builduser 1,9K 2017-12-25 22:17 version.sh
____________________________

[builduser@testserver:/rpmbuild/SOURCES]$ ./ffmpeg-snapshot-latest.sh
/tmp/tmp.rvMGzIfP04
Klone nach 'ffmpeg' ...
remote: Counting objects: 536649, done.
remote: Compressing objects: 100% (113806/113806), done.
remote: Total 536649 (delta 430087), reused 526982 (delta 421777)
Empfange Objekte: 100% (536649/536649), 93.44 MiB | 302.00 KiB/s, Fertig.
Löse Unterschiede auf: 100% (430087/430087), Fertig.
/tmp/tmp.rvMGzIfP04/ffmpeg-20171225/libswscale
/tmp/tmp.rvMGzIfP04/ffmpeg-20171225
/tmp/tmp.rvMGzIfP04/ffmpeg-20171225
[builduser@testserver:/rpmbuild/SOURCES]$ ls | grep ffmpeg | grep tar
-rw-r----- 1 builduser builduser 8,2M 2017-10-16 12:00
ffmpeg-20171016.tar.xz
-rw-r----- 1 builduser builduser 8,3M 2017-12-25 22:17
ffmpeg-20171225.tar.xz
-rw-r----- 1 builduser builduser 7,9M 2017-10-26 21:25 ffmpeg-3.3.5.tar.xz


[builduser@buildserver:/rpmbuild/BUILD/ffmpeg-20171225/ffbuild]$ cat
/rpmbuild/SOURCES/ffmpeg-snapshot-latest.sh
#!/usr/bin/bash

set -e

tmp=$(mktemp -d)

trap cleanup EXIT
cleanup() {
     set +e
     [ -z "$tmp" -o ! -d "$tmp" ] || rm -rf "$tmp"
}

unset CDPATH
pwd=$(pwd)
date=$(date +%Y%m%d)
echo "$tmp"
cd "$tmp"

git clone git://git.videolan.org/ffmpeg.git
mv ffmpeg ffmpeg-$date
cd ffmpeg-$date
pushd libswscale
popd
find . -type d -name .git -print0 | xargs -0r rm -rf
cd ..
tar Jcf "$pwd"/ffmpeg-$date.tar.xz ffmpeg-$date
cd - >/dev/null
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: x264 0.155.2893 (very recent changes)

Reindl Harald
still the same with current ffmpeg snapshot

x264 itself works for sure because it's built with
profile-guided-optimization and that process works for each file (make
fprofiled VIDS="%{SOURCE2} %{SOURCE3} %{SOURCE4}" %{?_smp_mflags})

[builduser@testserver:/rpmbuild/SPECS]$ rpm -q x264-latest
x264-latest-0.155.2893-1.fc26.20180111.rh.x86_64

[builduser@testserver:/rpmbuild/SPECS]$ rpm -q --filesbypkg x264-latest
x264-latest               /usr/local/x264/libx264.a
x264-latest               /usr/local/x264/x264.h
x264-latest               /usr/local/x264/x264_config.h

[builduser@testserver:/rpmbuild/SPECS]$ rpmbuild -bb ffmpeg-latest.spec
Ausführung(%prep): /bin/sh -e /var/tmp/rpm-tmp.NiSVTr
+ umask 022
+ cd /home/builduser/rpmbuild/BUILD
+ cd /home/builduser/rpmbuild/BUILD
+ rm -rf ffmpeg-20180111
+ /usr/bin/xz -dc /home/builduser/rpmbuild/SOURCES/ffmpeg-20180111.tar.xz
+ /usr/bin/tar -xof -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd ffmpeg-20180111
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Ausführung(%build): /bin/sh -e /var/tmp/rpm-tmp.j1JjON
+ umask 022
+ cd /home/builduser/rpmbuild/BUILD
+ cd ffmpeg-20180111
+ mkdir generic
+ pushd generic
~/rpmbuild/BUILD/ffmpeg-20180111/generic ~/rpmbuild/BUILD/ffmpeg-20180111
+ ../configure --prefix=/usr/local --bindir=/usr/local/bin
--mandir=/usr/local/man '--extra-cflags=-I/usr/local/x264 -m64 -O2 -g0
-mfpmath=sse -mavx -msse2avx -march=sandybridge -mtune=sandybridge
-fopenmp -pipe -fno-strict-aliasing -fomit-frame-pointer -fexceptions
-fstack-protector-strong --param=ssp-buffer-size=6 -D_FORTIFY_SOURCE=2
-Wstack-protector -Wformat -Werror=format-security -Ofast -ffast-math
-funsafe-math-optimizations -Wno-pointer-sign -minline-all-stringops
-fno-strict-aliasing -fuse-ld=gold -fuse-linker-plugin
-Wa,--noexecstack' '--extra-ldflags=-I/usr/local/x264 -L/usr/local/x264
-ldl -Wl,--as-needed -Wl,-z,now -Wl,-z,relro -Wl,-z,noexecstack -m64 -O2
-g0 -mfpmath=sse -mavx -msse2avx -march=sandybridge -mtune=sandybridge
-fopenmp -pipe -fno-strict-aliasing -fomit-frame-pointer -fexceptions
-fstack-protector-strong --param=ssp-buffer-size=6 -D_FORTIFY_SOURCE=2
-Wstack-protector -Wformat -Werror=format-security -Ofast -ffast-math
-funsafe-math-optimizations -Wno-pointer-sign -minline-all-stringops
-fno-strict-aliasing -pie -fPIE -fuse-ld=gold -fuse-linker-plugin
-Wa,--noexecstack' --ar=gcc-ar --ranlib=true --enable-nonfree
--enable-gpl --enable-pic --enable-version3 --enable-libmp3lame
--enable-libtheora --enable-libx264 --enable-libx265 --enable-libvpx
--enable-openssl --enable-static --enable-runtime-cpudetect
--disable-amd3dnow --disable-amd3dnowext --disable-avdevice
--disable-debug --disable-devices --disable-ffplay --disable-ffprobe
--disable-htmlpages --disable-hwaccels --disable-iconv
--disable-libdc1394 --disable-libfreetype --disable-libgsm
--disable-libopencore-amrnb --disable-libopencore-amrwb
--disable-libopencv --disable-libopenjpeg --disable-libopus
--disable-librtmp --disable-libspeex --disable-libvorbis
--disable-libxvid --disable-podpages --disable-postproc
--disable-protocol=gopher --disable-shared --disable-txtpages
ERROR: libx264 not found

Am 25.12.2017 um 22:24 schrieb Reindl Harald:

> FYI:
>
> ffmpeg 3.4.1
> src/libavcodec/libx264.c: In function 'X264_init_static':
> src/libavcodec/libx264.c:892:9: error: 'x264_bit_depth' undeclared
> (first use in this function); did you mean 'x264_picture_t'?
>   if (x264_bit_depth == 8)
>   ^~~~~~~~~~~~~~
>   x264_picture_t
> make: ***
> [/home/builduser/rpmbuild/BUILD/ffmpeg-20171212/ffbuild/common.mak:60:
> libavcodec/libx264.o] Error 1
> make: *** Waiting for unfinis
> _____________________________
>
> fresh snapshot from git
>
> [builduser@buildserver:/rpmbuild/SPECS]$ rpmbuild -bb ffmpeg-latest.spec
> Ausführung(%prep): /bin/sh -e /var/tmp/rpm-tmp.IXDZ1x
> + umask 022
> + cd /home/builduser/rpmbuild/BUILD
> + cd /home/builduser/rpmbuild/BUILD
> + rm -rf ffmpeg-20171225
> + /usr/bin/xz -dc /home/builduser/rpmbuild/SOURCES/ffmpeg-20171225.tar.xz
> + /usr/bin/tar -xof -
> + STATUS=0
> + '[' 0 -ne 0 ']'
> + cd ffmpeg-20171225
> + /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
> + exit 0
> Ausführung(%build): /bin/sh -e /var/tmp/rpm-tmp.3J4UGz
> + umask 022
> + cd /home/builduser/rpmbuild/BUILD
> + cd ffmpeg-20171225
> + mkdir generic
> + pushd generic
> ~/rpmbuild/BUILD/ffmpeg-20171225/generic ~/rpmbuild/BUILD/ffmpeg-20171225
> + ../configure --prefix=/usr/local --bindir=/usr/local/bin
> --mandir=/usr/local/man '--extra-cflags=-I/usr/local/x264 -m64 -O2 -g0
> -mfpmath=sse -mavx -msse2avx -march=sandybridge -mtune=sandybridge
> -fopenmp -pipe -fno-strict-aliasing -fomit-frame-pointer -fexceptions
> -fstack-protector-strong --param=ssp-buffer-size=6 -D_FORTIFY_SOURCE=2
> -Wstack-protector -Wformat -Werror=format-security -Ofast -ffast-math
> -funsafe-math-optimizations -Wno-pointer-sign -minline-all-stringops
> -fno-strict-aliasing -fuse-ld=gold -fuse-linker-plugin
> -Wa,--noexecstack' '--extra-ldflags=-I/usr/local/x264 -L/usr/local/x264
> -ldl -Wl,--as-needed -Wl,-z,now -Wl,-z,relro -Wl,-z,noexecstack -m64 -O2
> -g0 -mfpmath=sse -mavx -msse2avx -march=sandybridge -mtune=sandybridge
> -fopenmp -pipe -fno-strict-aliasing -fomit-frame-pointer -fexceptions
> -fstack-protector-strong --param=ssp-buffer-size=6 -D_FORTIFY_SOURCE=2
> -Wstack-protector -Wformat -Werror=format-security -Ofast -ffast-math
> -funsafe-math-optimizations -Wno-pointer-sign -minline-all-stringops
> -fno-strict-aliasing -pie -fPIE -fuse-ld=gold -fuse-linker-plugin
> -Wa,--noexecstack' --ar=gcc-ar --ranlib=true --enable-nonfree
> --enable-gpl --enable-pic --enable-version3 --enable-libmp3lame
> --enable-libtheora --enable-libx264 --enable-libx265 --enable-libvpx
> --enable-openssl --enable-static --enable-runtime-cpudetect
> --disable-amd3dnow --disable-amd3dnowext --disable-avdevice
> --disable-debug --disable-devices --disable-ffplay --disable-ffprobe
> --disable-ffserver --disable-htmlpages --disable-hwaccels
> --disable-iconv --disable-libdc1394 --disable-libfreetype
> --disable-libgsm --disable-libopencore-amrnb --disable-libopencore-amrwb
> --disable-libopencv --disable-libopenjpeg --disable-libopus
> --disable-librtmp --disable-libspeex --disable-libvorbis
> --disable-libxvid --disable-podpages --disable-postproc
> --disable-protocol=gopher --disable-shared --disable-txtpages
> ERROR: libx264 not found
>
> If you think configure made a mistake, make sure you are using the latest
> version from Git.  If the latest version fails, report the problem to the
> [hidden email] mailing list or IRC #ffmpeg on irc.freenode.net.
> Include the log file "ffbuild/config.log" produced by configure as this
> will help
> solve the problem.
> Fehler: Fehler-Status beim Beenden von /var/tmp/rpm-tmp.3J4UGz (%build)
>
> [builduser@buildserver:/rpmbuild/BUILD/ffmpeg-20171225/ffbuild]$ ls
> insgesamt 28K
> -rw-r--r-- 1 builduser builduser  829 2017-12-25 22:17 arch.mak
> -rw-r--r-- 1 builduser builduser 5,0K 2017-12-25 22:17 common.mak
> -rw-r--r-- 1 builduser builduser 3,7K 2017-12-25 22:17 library.mak
> -rwxr-xr-x 1 builduser builduser  478 2017-12-25 22:17 libversion.sh
> -rwxr-xr-x 1 builduser builduser 1,5K 2017-12-25 22:17
> pkgconfig_generate.sh
> -rwxr-xr-x 1 builduser builduser 1,9K 2017-12-25 22:17 version.sh
> ____________________________
>
> [builduser@testserver:/rpmbuild/SOURCES]$ ./ffmpeg-snapshot-latest.sh
> /tmp/tmp.rvMGzIfP04
> Klone nach 'ffmpeg' ...
> remote: Counting objects: 536649, done.
> remote: Compressing objects: 100% (113806/113806), done.
> remote: Total 536649 (delta 430087), reused 526982 (delta 421777)
> Empfange Objekte: 100% (536649/536649), 93.44 MiB | 302.00 KiB/s, Fertig.
> Löse Unterschiede auf: 100% (430087/430087), Fertig.
> /tmp/tmp.rvMGzIfP04/ffmpeg-20171225/libswscale
> /tmp/tmp.rvMGzIfP04/ffmpeg-20171225
> /tmp/tmp.rvMGzIfP04/ffmpeg-20171225
> [builduser@testserver:/rpmbuild/SOURCES]$ ls | grep ffmpeg | grep tar
> -rw-r----- 1 builduser builduser 8,2M 2017-10-16 12:00
> ffmpeg-20171016.tar.xz
> -rw-r----- 1 builduser builduser 8,3M 2017-12-25 22:17
> ffmpeg-20171225.tar.xz
> -rw-r----- 1 builduser builduser 7,9M 2017-10-26 21:25 ffmpeg-3.3.5.tar.xz
>
>
> [builduser@buildserver:/rpmbuild/BUILD/ffmpeg-20171225/ffbuild]$ cat
> /rpmbuild/SOURCES/ffmpeg-snapshot-latest.sh
> #!/usr/bin/bash
>
> set -e
>
> tmp=$(mktemp -d)
>
> trap cleanup EXIT
> cleanup() {
>      set +e
>      [ -z "$tmp" -o ! -d "$tmp" ] || rm -rf "$tmp"
> }
>
> unset CDPATH
> pwd=$(pwd)
> date=$(date +%Y%m%d)
> echo "$tmp"
> cd "$tmp"
>
> git clone git://git.videolan.org/ffmpeg.git
> mv ffmpeg ffmpeg-$date
> cd ffmpeg-$date
> pushd libswscale
> popd
> find . -type d -name .git -print0 | xargs -0r rm -rf
> cd ..
> tar Jcf "$pwd"/ffmpeg-$date.tar.xz ffmpeg-$date
> cd - >/dev/null
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: x264 0.155.2893 (very recent changes)

Carl Eugen Hoyos-2
In reply to this post by Reindl Harald
2017-12-25 22:24 GMT+01:00 Reindl Harald <[hidden email]>:
> ERROR: libx264 not found
>
> If you think configure made a mistake, make sure you are using the latest
> version from Git.  If the latest version fails, report the problem to the
> [hidden email] mailing list or IRC #ffmpeg on irc.freenode.net.

> Include the log file "ffbuild/config.log" produced by configure as this will
> help solve the problem.

Did you do this?

Max be fixed, Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: x264 0.155.2893 (very recent changes)

Reindl Harald


Am 11.01.2018 um 11:16 schrieb Carl Eugen Hoyos:

> 2017-12-25 22:24 GMT+01:00 Reindl Harald <[hidden email]>:
>> ERROR: libx264 not found
>>
>> If you think configure made a mistake, make sure you are using the latest
>> version from Git.  If the latest version fails, report the problem to the
>> [hidden email] mailing list or IRC #ffmpeg on irc.freenode.net.
>
>> Include the log file "ffbuild/config.log" produced by configure as this will
>> help solve the problem.
>
> Did you do this?

did you *really* read the initial mail?
i can't include something which don't exist at all

[builduser@buildserver:/rpmbuild/BUILD/ffmpeg-20171225/ffbuild]$ ls
insgesamt 28K
-rw-r--r-- 1 builduser builduser  829 2017-12-25 22:17 arch.mak
-rw-r--r-- 1 builduser builduser 5,0K 2017-12-25 22:17 common.mak
-rw-r--r-- 1 builduser builduser 3,7K 2017-12-25 22:17 library.mak
-rwxr-xr-x 1 builduser builduser  478 2017-12-25 22:17 libversion.sh
-rwxr-xr-x 1 builduser builduser 1,5K 2017-12-25 22:17 pkgconfig_generate.sh
-rwxr-xr-x 1 builduser builduser 1,9K 2017-12-25 22:17 version.sh
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: x264 0.155.2893 (very recent changes)

Carl Eugen Hoyos-2
2018-01-11 11:32 GMT+01:00 Reindl Harald <[hidden email]>:

>
> Am 11.01.2018 um 11:16 schrieb Carl Eugen Hoyos:
>>
>> 2017-12-25 22:24 GMT+01:00 Reindl Harald <[hidden email]>:
>>>
>>> ERROR: libx264 not found
>>>
>>> If you think configure made a mistake, make sure you are using the latest
>>> version from Git.  If the latest version fails, report the problem to the
>>> [hidden email] mailing list or IRC #ffmpeg on irc.freenode.net.
>>
>>> Include the log file "ffbuild/config.log" produced by configure as this
>>> will help solve the problem.
>>
>> Did you do this?
>
> did you *really* read the initial mail?
> i can't include something which don't exist at all
>
> [builduser@buildserver:/rpmbuild/BUILD/ffmpeg-20171225/ffbuild]$ ls
> insgesamt 28K
> -rw-r--r-- 1 builduser builduser  829 2017-12-25 22:17 arch.mak
> -rw-r--r-- 1 builduser builduser 5,0K 2017-12-25 22:17 common.mak
> -rw-r--r-- 1 builduser builduser 3,7K 2017-12-25 22:17 library.mak
> -rwxr-xr-x 1 builduser builduser  478 2017-12-25 22:17 libversion.sh
> -rwxr-xr-x 1 builduser builduser 1,5K 2017-12-25 22:17 pkgconfig_generate.sh
> -rwxr-xr-x 1 builduser builduser 1,9K 2017-12-25 22:17 version.sh

This sounds like a serious bug (your original issue is easy to work-around):
How can I reproduce this?

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: x264 0.155.2893 (very recent changes)

Reindl Harald


Am 11.01.2018 um 11:44 schrieb Carl Eugen Hoyos:

>>>> Include the log file "ffbuild/config.log" produced by configure as this
>>>> will help solve the problem.
>>>
>>> Did you do this?
>>
>> did you *really* read the initial mail?
>> i can't include something which don't exist at all
>>
>> [builduser@buildserver:/rpmbuild/BUILD/ffmpeg-20171225/ffbuild]$ ls
>> insgesamt 28K
>> -rw-r--r-- 1 builduser builduser  829 2017-12-25 22:17 arch.mak
>> -rw-r--r-- 1 builduser builduser 5,0K 2017-12-25 22:17 common.mak
>> -rw-r--r-- 1 builduser builduser 3,7K 2017-12-25 22:17 library.mak
>> -rwxr-xr-x 1 builduser builduser  478 2017-12-25 22:17 libversion.sh
>> -rwxr-xr-x 1 builduser builduser 1,5K 2017-12-25 22:17 pkgconfig_generate.sh
>> -rwxr-xr-x 1 builduser builduser 1,9K 2017-12-25 22:17 version.sh
>
> This sounds like a serious bug (your original issue is easy to work-around):
> How can I reproduce this?
likely by just build last recent x264 to a non defualt location and try
to link it static to ffmpeg

see rpm-specs and scripts how the snaphots get downloaded attached


[builduser@testserver:/rpmbuild/SPECS]$ rpmbuild -bb ffmpeg-latest.spec
Ausführung(%prep): /bin/sh -e /var/tmp/rpm-tmp.z9KjMe
+ umask 022
+ cd /home/builduser/rpmbuild/BUILD
+ cd /home/builduser/rpmbuild/BUILD
+ rm -rf ffmpeg-20180111
+ /usr/bin/xz -dc /home/builduser/rpmbuild/SOURCES/ffmpeg-20180111.tar.xz
+ /usr/bin/tar -xof -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd ffmpeg-20180111
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Ausführung(%build): /bin/sh -e /var/tmp/rpm-tmp.Wzc66h
+ umask 022
+ cd /home/builduser/rpmbuild/BUILD
+ cd ffmpeg-20180111
+ mkdir generic
+ pushd generic
~/rpmbuild/BUILD/ffmpeg-20180111/generic ~/rpmbuild/BUILD/ffmpeg-20180111
+ ../configure --prefix=/usr/local --bindir=/usr/local/bin
--mandir=/usr/local/man '--extra-cflags=-I/usr/local/x264 -m64 -O2 -g0
-mfpmath=sse -mavx -msse2avx -march=sandybridge -mtune=sandybridge
-fopenmp -pipe -fno-strict-aliasing -fomit-frame-pointer -fexceptions
-fstack-protector-strong --param=ssp-buffer-size=6 -D_FORTIFY_SOURCE=2
-Wstack-protector -Wformat -Werror=format-security -Ofast -ffast-math
-funsafe-math-optimizations -Wno-pointer-sign -minline-all-stringops
-fno-strict-aliasing -fuse-ld=gold -fuse-linker-plugin
-Wa,--noexecstack' '--extra-ldflags=-I/usr/local/x264 -L/usr/local/x264
-ldl -Wl,--as-needed -Wl,-z,now -Wl,-z,relro -Wl,-z,noexecstack -m64 -O2
-g0 -mfpmath=sse -mavx -msse2avx -march=sandybridge -mtune=sandybridge
-fopenmp -pipe -fno-strict-aliasing -fomit-frame-pointer -fexceptions
-fstack-protector-strong --param=ssp-buffer-size=6 -D_FORTIFY_SOURCE=2
-Wstack-protector -Wformat -Werror=format-security -Ofast -ffast-math
-funsafe-math-optimizations -Wno-pointer-sign -minline-all-stringops
-fno-strict-aliasing -pie -fPIE -fuse-ld=gold -fuse-linker-plugin
-Wa,--noexecstack' --ar=gcc-ar --ranlib=true --enable-nonfree
--enable-gpl --enable-pic --enable-version3 --enable-libmp3lame
--enable-libtheora --enable-libx264 --enable-libx265 --enable-libvpx
--enable-openssl --enable-static --enable-runtime-cpudetect
--disable-amd3dnow --disable-amd3dnowext --disable-avdevice
--disable-debug --disable-devices --disable-ffplay --disable-ffprobe
--disable-htmlpages --disable-hwaccels --disable-iconv
--disable-libdc1394 --disable-libfreetype --disable-libgsm
--disable-libopencore-amrnb --disable-libopencore-amrwb
--disable-libopencv --disable-libopenjpeg --disable-libopus
--disable-librtmp --disable-libspeex --disable-libvorbis
--disable-libxvid --disable-podpages --disable-postproc
--disable-protocol=gopher --disable-shared --disable-txtpages
ERROR: libx264 not found


If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
[hidden email] mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "ffbuild/config.log" produced by configure as this
will help
solve the problem.
Fehler: Fehler-Status beim Beenden von /var/tmp/rpm-tmp.Wzc66h (%build)


[builduser@testserver:/rpmbuild/SPECS]$ ls
/rpmbuild/BUILD/ffmpeg-20180111/ffbuild/
insgesamt 28K
-rw-r--r-- 1 builduser builduser  829 2018-01-11 10:13 arch.mak
-rw-r--r-- 1 builduser builduser 5,0K 2018-01-11 10:13 common.mak
-rw-r--r-- 1 builduser builduser 3,7K 2018-01-11 10:13 library.mak
-rwxr-xr-x 1 builduser builduser  478 2018-01-11 10:13 libversion.sh
-rwxr-xr-x 1 builduser builduser 1,5K 2018-01-11 10:13 pkgconfig_generate.sh
-rwxr-xr-x 1 builduser builduser 1,9K 2018-01-11 10:13 version.sh

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".

ffmpeg-latest.spec (9K) Download Attachment
ffmpeg-snapshot-latest-sh.txt (596 bytes) Download Attachment
x264-latest.spec (5K) Download Attachment
x264-snapshot-latest-sh.txt (542 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: x264 0.155.2893 (very recent changes)

Carl Eugen Hoyos-2
2018-01-11 11:51 GMT+01:00 Reindl Harald <[hidden email]>:

>
> Am 11.01.2018 um 11:44 schrieb Carl Eugen Hoyos:
>>>>>
>>>>> Include the log file "ffbuild/config.log" produced by configure as this
>>>>> will help solve the problem.
>>>>
>>>> Did you do this?
>>>
>>> did you *really* read the initial mail?
>>> i can't include something which don't exist at all
>>>
>>> [builduser@buildserver:/rpmbuild/BUILD/ffmpeg-20171225/ffbuild]$ ls
>>> insgesamt 28K
>>> -rw-r--r-- 1 builduser builduser  829 2017-12-25 22:17 arch.mak
>>> -rw-r--r-- 1 builduser builduser 5,0K 2017-12-25 22:17 common.mak
>>> -rw-r--r-- 1 builduser builduser 3,7K 2017-12-25 22:17 library.mak
>>> -rwxr-xr-x 1 builduser builduser  478 2017-12-25 22:17 libversion.sh
>>> -rwxr-xr-x 1 builduser builduser 1,5K 2017-12-25 22:17
>>> pkgconfig_generate.sh
>>> -rwxr-xr-x 1 builduser builduser 1,9K 2017-12-25 22:17 version.sh
>>
>> This sounds like a serious bug (your original issue is easy to
>> work-around):
>> How can I reproduce this?
>
> likely by just build last recent x264 to a non defualt location and try to
> link it static to ffmpeg

You claim that there is no config.log file in your FFmpeg build directory
(or its subdirectory ffbuild): How can I reproduce this?

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: x264 0.155.2893 (very recent changes)

Reindl Harald

Am 11.01.2018 um 11:54 schrieb Carl Eugen Hoyos:

> 2018-01-11 11:51 GMT+01:00 Reindl Harald <[hidden email]>:
>>
>> Am 11.01.2018 um 11:44 schrieb Carl Eugen Hoyos:
>>>>>>
>>>>>> Include the log file "ffbuild/config.log" produced by configure as this
>>>>>> will help solve the problem.
>>>>>
>>>>> Did you do this?
>>>>
>>>> did you *really* read the initial mail?
>>>> i can't include something which don't exist at all
>>>>
>>>> [builduser@buildserver:/rpmbuild/BUILD/ffmpeg-20171225/ffbuild]$ ls
>>>> insgesamt 28K
>>>> -rw-r--r-- 1 builduser builduser  829 2017-12-25 22:17 arch.mak
>>>> -rw-r--r-- 1 builduser builduser 5,0K 2017-12-25 22:17 common.mak
>>>> -rw-r--r-- 1 builduser builduser 3,7K 2017-12-25 22:17 library.mak
>>>> -rwxr-xr-x 1 builduser builduser  478 2017-12-25 22:17 libversion.sh
>>>> -rwxr-xr-x 1 builduser builduser 1,5K 2017-12-25 22:17
>>>> pkgconfig_generate.sh
>>>> -rwxr-xr-x 1 builduser builduser 1,9K 2017-12-25 22:17 version.sh
>>>
>>> This sounds like a serious bug (your original issue is easy to
>>> work-around):
>>> How can I reproduce this?
>>
>> likely by just build last recent x264 to a non defualt location and try to
>> link it static to ffmpeg
>
> You claim that there is no config.log file in your FFmpeg build directory
> (or its subdirectory ffbuild): How can I reproduce this?

by doing the same as i did?
guess why i attached the files
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: x264 0.155.2893 (very recent changes)

Carl Eugen Hoyos-2
2018-01-11 13:05 GMT+01:00 Reindl Harald <[hidden email]>:
>
> Am 11.01.2018 um 11:54 schrieb Carl Eugen Hoyos:

>> You claim that there is no config.log file in your FFmpeg build
>> directory (or its subdirectory ffbuild): How can I reproduce this?
>
> by doing the same as i did?

The moment I start configure, config.log is created, no matter if
configure succeeds or not, the file config.log exists and shows
some information.
This appears unrelated to the options I pass to configure.

I also have a system where the configure scripts runs for more
than 150 minutes, on that system, I also watch config.log to
see the progress.

So while this sounds like an important issue, I have no idea
how to reproduce.

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".