undefined symbol: av_get_bits_per_sample_format

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

undefined symbol: av_get_bits_per_sample_format

code-7
hello,

i got latest cvs version of ffmpeg, configured with:
./configure --enable-shared --enable-gpl --enable-libmp3lame
--enable-libamr-nb --enable-libamr-wb --enable-libvorbis
--enable-libtheora --enable-libfaad

in /usr/lib i have :
-rw-r--r-- 1 root root 4641684 2007-12-22 20:24 /usr/lib/libavformat.a
lrwxrwxrwx 1 root root 21 2007-12-22 20:24 /usr/lib/libavformat.so ->
libavformat.so.52.3.0
lrwxrwxrwx 1 root root 25 2007-08-02 13:47 /usr/lib/libavformat.so.1d ->
libavformat.so.1d.51.10.0
-rw-r--r-- 1 root root 548020 2007-06-23 16:33
/usr/lib/libavformat.so.1d.51.10.0
lrwxrwxrwx 1 root root 22 2007-11-13 13:57 /usr/lib/libavformat.so.51 ->
libavformat
.so.51.19.0
-rwxr-xr-x 1 root root 610428 2007-10-18 15:52
/usr/lib/libavformat.so.51.12.1
-rwxr-xr-x 1 root root 657740 2007-10-22 16:18
/usr/lib/libavformat.so.51.15.0
-rw-r--r-- 1 root root 627136 2007-11-12 15:31
/usr/lib/libavformat.so.51.19.0
lrwxrwxrwx 1 root root 21 2007-12-22 20:24 /usr/lib/libavformat.so.52 ->
libavformat.so.52.3.0
-rw-r--r-- 1 root root 596992 2007-12-07 10:05
/usr/lib/libavformat.so.52.1.0
-rwxr-xr-x 1
root root 615448 2007-12-22 20:24 /usr/lib/libavformat.so.52.3.0

if i run ffmpeg i get :
./ffmpeg: symbol lookup error: /usr/lib/libavformat.so.52: undefined
symbol: av_get_bits_per_sample_format

on other PC i have completely the same setup, only few days older
version of ffmpeg and it works.
i did not find anything on google nor in ffmpeg archives, please can you
help ?

thanks
Co.De.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: undefined symbol: av_get_bits_per_sample_format

Benoit Fouet
code wrote:
> hello,
>
> i got latest cvs version of ffmpeg, configured with:
> ./configure --enable-shared --enable-gpl --enable-libmp3lame
> --enable-libamr-nb --enable-libamr-wb --enable-libvorbis
> --enable-libtheora --enable-libfaad
>
>  

./configure --help
[...]
Standard options:
[...]
  --prefix=PREFIX          install in PREFIX [/usr/local]
  --libdir=DIR             install libs in DIR [PREFIX/lib]
[...]

if you have something in /usr/lib/, it's from a previous installation of
ffmpeg...
make sure you uninstall it before using the new one

> in /usr/lib i have :
> -rw-r--r-- 1 root root 4641684 2007-12-22 20:24 /usr/lib/libavformat.a
> lrwxrwxrwx 1 root root 21 2007-12-22 20:24 /usr/lib/libavformat.so ->
> libavformat.so.52.3.0
> lrwxrwxrwx 1 root root 25 2007-08-02 13:47 /usr/lib/libavformat.so.1d ->
> libavformat.so.1d.51.10.0
> -rw-r--r-- 1 root root 548020 2007-06-23 16:33
> /usr/lib/libavformat.so.1d.51.10.0
> lrwxrwxrwx 1 root root 22 2007-11-13 13:57 /usr/lib/libavformat.so.51 ->
> libavformat
> .so.51.19.0
> -rwxr-xr-x 1 root root 610428 2007-10-18 15:52
> /usr/lib/libavformat.so.51.12.1
> -rwxr-xr-x 1 root root 657740 2007-10-22 16:18
> /usr/lib/libavformat.so.51.15.0
> -rw-r--r-- 1 root root 627136 2007-11-12 15:31
> /usr/lib/libavformat.so.51.19.0
> lrwxrwxrwx 1 root root 21 2007-12-22 20:24 /usr/lib/libavformat.so.52 ->
> libavformat.so.52.3.0
> -rw-r--r-- 1 root root 596992 2007-12-07 10:05
> /usr/lib/libavformat.so.52.1.0
> -rwxr-xr-x 1
> root root 615448 2007-12-22 20:24 /usr/lib/libavformat.so.52.3.0
>
> if i run ffmpeg i get :
> ./ffmpeg: symbol lookup error: /usr/lib/libavformat.so.52: undefined
> symbol: av_get_bits_per_sample_format
>
> on other PC i have completely the same setup, only few days older
> version of ffmpeg and it works.
> i did not find anything on google nor in ffmpeg archives, please can you
> help ?
>
>  

--
Ben
Purple Labs S.A.
www.purplelabs.com
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user