udp restreaming not working properly

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

udp restreaming not working properly

Matthew Reus
Hello i need to stream the udp url , all i have is about 20-30 url
multicast stream .
i m using ffmpeg 4.1 static build to stream the url to my media server .
the ffmpeg script runs for 1 hrs sometimes for 30 minutes and stop working
please could you guys help me to solve this problem . Here is my ffmpeg
script and log file by


*ffmpeg -timeout 2000 -i 'udp://@239.1.5.75:8002?ttl=5
<http://239.1.5.75:8002?ttl=5>' -pix_fmt yuv420p -c:v libx264 -s 1280:720
-b:v 900k  -c:a aac -strict -2  -max_muxing_queue_size 1024 -f flv
'rtmp://admin:admin@192.168.2.200:1935/live/wtvASIANETNEWS.stream
<http://admin:admin@192.168.2.200:1935/live/wtvASIANETNEWS.stream>' *

f
*fmpeg version 4.1-static https://johnvansickle.com/ffmpeg/
<https://johnvansickle.com/ffmpeg/>  Copyright (c) 2000-2018 the FFmpeg
developers  built with gcc 6.3.0 (Debian 6.3.0-18+deb9u1) 20170516*
  configuration: --enable-gpl --enable-version3 --enable-static
--disable-debug --disable-ffplay --disable-indev=sndio
--disable-outdev=sndio --cc=gcc-6 --enable-fontconfig --enable-frei0r
--enable-gnutls --enable-gray --enable-libaom --enable-libfribidi
--enable-libass --enable-libvmaf --enable-libfreetype --enable-libmp3lame
--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg
--enable-librubberband --enable-libsoxr --enable-libspeex
--enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab
--enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264
--enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzimg
  libavutil      56. 22.100 / 56. 22.100
  libavcodec     58. 35.100 / 58. 35.100
  libavformat    58. 20.100 / 58. 20.100
  libavdevice    58.  5.100 / 58.  5.100
  libavfilter     7. 40.101 /  7. 40.101
  libswscale      5.  3.100 /  5.  3.100
  libswresample   3.  3.100 /  3.  3.100
  libpostproc    55.  3.100 / 55.  3.100
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] SPS unavailable in decode_picture_timing
[h264 @ 0x695be80] non-existing PPS 0 referenced
[h264 @ 0x695be80] decode_slice_header error
[h264 @ 0x695be80] no frame!
[h264 @ 0x695be80] mmco: unref short failure
    Last message repeated 1 times
[h264 @ 0x695be80] number of reference frames (0+4) exceeds max (3;
probably corrupt input), discarding one
Input #0, mpegts, from 'udp://@239.1.5.75:8002?ttl=5':
  Duration: N/A, start: 56575.896889, bitrate: N/A
  Program 32
    Stream #0:0[0x21]: Video: h264 (Main) ([27][0][0][0] / 0x001B),
yuv420p(tv, bt470bg, top first), 720x576 [SAR 12:11 DAR 15:11], 25 fps, 50
tbr, 90k tbn, 50 tbc
    Stream #0:1[0x22](eng): Audio: mp2 ([4][0][0][0] / 0x0004), 48000 Hz,
stereo, s16p, 128 kb/s
[rtmp @ 0x6a5e040] Ignoring unsupported var reason
Stream mapping:
  Stream #0:0 -> #0:0 (h264 (native) -> h264 (libx264))
  Stream #0:1 -> #0:1 (mp2 (native) -> aac (native))
Press [q] to stop, [?] for help
[h264 @ 0x6b63f40] reference picture missing during reorder
[h264 @ 0x6b63f40] Missing reference picture, default is 65480
[h264 @ 0x6a57f80] reference picture missing during reorder
[h264 @ 0x6a57f80] Missing reference picture, default is 65481
[libx264 @ 0x698c980] using SAR=135/176
[libx264 @ 0x698c980] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
AVX FMA3 BMI2 AVX2
[libx264 @ 0x698c980] profile High, level 3.1, 4:2:0, 8-bit
[libx264 @ 0x698c980] 264 - core 157 r2935 545de2f - H.264/MPEG-4 AVC codec
- Copyleft 2003-2018 - http://www.videolan.org/x264.html - options: cabac=1
ref=3 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=7 psy=1 psy_rd=1.00:0.00
mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11
fast_pskip=1 chroma_qp_offset=-2 threads=22 lookahead_threads=3
sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0
constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1
weightb=1 open_gop=0 weightp=2 keyint=250 keyint_min=25 scenecut=40
intra_refresh=0 rc_lookahead=40 rc=abr mbtree=1 bitrate=900 ratetol=1.0
qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
Output #0, flv, to 'rtmp://
admin:admin@192.168.2.200:1935/live/wtvASIANETNEWS.stream':
  Metadata:
    encoder         : Lavf58.20.100
    Stream #0:0: Video: h264 (libx264) ([7][0][0][0] / 0x0007), yuv420p,
1280x720 [SAR 135:176 DAR 15:11], q=-1--1, 900 kb/s, 25 fps, 1k tbn, 25 tbc
    Metadata:
      encoder         : Lavc58.35.100 libx264
    Side data:
      cpb: bitrate max/min/avg: 0/0/900000 buffer size: 0 vbv_delay: -1
    Stream #0:1(eng): Audio: aac (LC) ([10][0][0][0] / 0x000A), 48000 Hz,
stereo, fltp, 128 kb/s
    Metadata:
      encoder         : Lavc58.35.100 aac
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: udp restreaming not working properly

Moritz Barsnick
On Wed, Nov 28, 2018 at 12:13:54 +0545, Matthew Reus wrote:
> the ffmpeg script runs for 1 hrs sometimes for 30 minutes and stop working
> please could you guys help me to solve this problem . Here is my ffmpeg
> script and log file by
[...]

> Output #0, flv, to 'rtmp://
> admin:admin@192.168.2.200:1935/live/wtvASIANETNEWS.stream':
>   Metadata:
>     encoder         : Lavf58.20.100
>     Stream #0:0: Video: h264 (libx264) ([7][0][0][0] / 0x0007), yuv420p,
> 1280x720 [SAR 135:176 DAR 15:11], q=-1--1, 900 kb/s, 25 fps, 1k tbn, 25 tbc
>     Metadata:
>       encoder         : Lavc58.35.100 libx264
>     Side data:
>       cpb: bitrate max/min/avg: 0/0/900000 buffer size: 0 vbv_delay: -1
>     Stream #0:1(eng): Audio: aac (LC) ([10][0][0][0] / 0x000A), 48000 Hz,
> stereo, fltp, 128 kb/s
>     Metadata:
>       encoder         : Lavc58.35.100 aac

This shouldn't be the end of your console output. There's definitely
something missing: the part, where ffmpeg processes, and the part where
ffmpeg terminates.

Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".