question about fps filter

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

question about fps filter

Andy Sheimo
I am using the command line seen here but the fps filter is being ignored.

ffmpeg.exe -loglevel debug -stats -hwaccel cuda -hwaccel_output_format cuda
-i "Evanescence - Anywhere but Home.mkv" -map 0:0 -filter:v
yadif_cuda=deint=interlaced,fps=24000/1001 -c:v h264_nvenc -b:v 2000k
-maxrate:v 6000k -rc:v vbr_hq -spatial-aq:v 1 -temporal-aq:v 1 -profile:v
high -color_primaries:v smpte170m -color_trc:v bt709 -colorspace:v
smpte170m -metadata:s:v title= -disposition:v default -map 0:1 -c:a:0 eac3
-b:a:0 256k -metadata:s:a:0 title= -disposition:a:0 default -map 0:2 -c:a:1
copy -metadata:s:a:1 title= -disposition:a:1 0 -sn -metadata:g title=
"Evanescence - Anywhere but Home 2.mkv"

I found this in the debug output and am not sure why it sees what was
passed by the command line but then is ignored in the filter graph can
someone help me understand please? The complete debug output is available
but too big to include here.

[Parsed_yadif_cuda_0 @ 00000220ac5561c0] Setting 'deint' to value
'interlaced'
[Parsed_fps_1 @ 00000220ac74a500] Setting 'fps' to value '24000/1001'
[Parsed_fps_1 @ 00000220ac74a500] fps=24000/1001
[graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'video_size' to
value '720x480'
[graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pix_fmt' to
value '119'
[graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'time_base' to
value '1/1000'
[graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pixel_aspect'
to value '186/157'
[graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'frame_rate' to
value '30000/1001'
[graph 0 input from stream 0:0 @ 00000220ac749f40] w:720 h:480 pixfmt:cuda
tb:1/1000 fr:30000/1001 sar:186/157
[format @ 00000220ac74bac0] Setting 'pix_fmts' to value
'yuv420p|nv12|p010le|yuv444p|p016le|yuv444p16le|bgr0|rgb0|cuda|d3d11'
[AVFilterGraph @ 00000220ac511d80] query_formats: 5 queried, 4 merged, 0
already done, 0 delayed
[h264_nvenc @ 00000220ac561540] Using input frames context (format cuda)
with h264_nvenc encoder.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: question about fps filter

Brainiarc7
On Sat, 23 May 2020 at 01:07, Andy Sheimo <[hidden email]> wrote:

> I am using the command line seen here but the fps filter is being ignored.
>
> ffmpeg.exe -loglevel debug -stats -hwaccel cuda -hwaccel_output_format cuda
> -i "Evanescence - Anywhere but Home.mkv" -map 0:0 -filter:v
> yadif_cuda=deint=interlaced,fps=24000/1001 -c:v h264_nvenc -b:v 2000k
> -maxrate:v 6000k -rc:v vbr_hq -spatial-aq:v 1 -temporal-aq:v 1 -profile:v
> high -color_primaries:v smpte170m -color_trc:v bt709 -colorspace:v
> smpte170m -metadata:s:v title= -disposition:v default -map 0:1 -c:a:0 eac3
> -b:a:0 256k -metadata:s:a:0 title= -disposition:a:0 default -map 0:2 -c:a:1
> copy -metadata:s:a:1 title= -disposition:a:1 0 -sn -metadata:g title=
> "Evanescence - Anywhere but Home 2.mkv"
>
> I found this in the debug output and am not sure why it sees what was
> passed by the command line but then is ignored in the filter graph can
> someone help me understand please? The complete debug output is available
> but too big to include here.
>
> [Parsed_yadif_cuda_0 @ 00000220ac5561c0] Setting 'deint' to value
> 'interlaced'
> [Parsed_fps_1 @ 00000220ac74a500] Setting 'fps' to value '24000/1001'
> [Parsed_fps_1 @ 00000220ac74a500] fps=24000/1001
> [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'video_size' to
> value '720x480'
> [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pix_fmt' to
> value '119'
> [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'time_base' to
> value '1/1000'
> [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pixel_aspect'
> to value '186/157'
> [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'frame_rate' to
> value '30000/1001'
> [graph 0 input from stream 0:0 @ 00000220ac749f40] w:720 h:480 pixfmt:cuda
> tb:1/1000 fr:30000/1001 sar:186/157
> [format @ 00000220ac74bac0] Setting 'pix_fmts' to value
> 'yuv420p|nv12|p010le|yuv444p|p016le|yuv444p16le|bgr0|rgb0|cuda|d3d11'
> [AVFilterGraph @ 00000220ac511d80] query_formats: 5 queried, 4 merged, 0
> already done, 0 delayed
> [h264_nvenc @ 00000220ac561540] Using input frames context (format cuda)
> with h264_nvenc encoder.
> _______________________________________________
>

What version of ffmpeg are you using?
There have been recent updates to the NVENC encoder's implementation in
ffmpeg that better handle frame rate, such as this commit:
https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/b18fd2b95b2fea10f0b5381333a1b4c032f010bc
Use the latest build and retest.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: question about fps filter

Andy Sheimo
using this version created today using
https://github.com/rdp/ffmpeg-windows-build-helpers

ffmpeg.exe -version
ffmpeg version N-97877-g1e8ed181e3-ffmpeg-windows-build-helpers Copyright
(c) 2000-2020 the FFmpeg developers
built with gcc 8.3.0 (GCC)
configuration: --pkg-config=pkg-config --pkg-config-flags=--static
--extra-version=ffmpeg-windows-build-helpers --enable-version3
--disable-debug --disable-w32threads --arch=x86_64 --target-os=mingw32
--cross-prefix=/home/asheimo/ffmpeg-windows-build-helpers/sandbox/cross_compilers/mingw-w64-x86_64/bin/x86_64-w64-mingw32-
--enable-libcaca --enable-gray --enable-libtesseract --enable-fontconfig
--enable-gmp --enable-gnutls --enable-libass --enable-libbluray
--enable-libbs2b --enable-libflite --enable-libfreetype --enable-libfribidi
--enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug
--enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb
--enable-libopus --enable-libsnappy --enable-libsoxr --enable-libspeex
--enable-libtheora --enable-libtwolame --enable-libvo-amrwbenc
--enable-libvorbis --enable-libwebp --enable-libzimg --enable-libzvbi
--enable-libmysofa --enable-libopenjpeg --enable-libopenh264
--enable-liblensfun --enable-libvmaf --enable-libsrt --enable-demuxer=dash
--enable-libxml2 --enable-opengl --enable-libdav1d --enable-cuda-llvm
--enable-libsvthevc --enable-libaom --enable-libvpx --enable-nvenc
--enable-nvdec --extra-libs=-lharfbuzz --extra-libs=-lm
--extra-libs=-lpthread --extra-cflags=-DLIBTWOLAME_STATIC
--extra-cflags=-DMODPLUG_STATIC --extra-cflags=-DCACA_STATIC --enable-amf
--enable-libmfx --enable-gpl --enable-frei0r --enable-filter=frei0r
--enable-librubberband --enable-libvidstab --enable-libx264
--enable-libx265 --enable-libxvid --enable-libxavs --enable-avresample
--extra-cflags='-mtune=generic' --extra-cflags=-O3 --enable-static
--disable-shared
--prefix=/home/asheimo/ffmpeg-windows-build-helpers/sandbox/cross_compilers/mingw-w64-x86_64/x86_64-w64-mingw32
libavutil      56. 46.100 / 56. 46.100
libavcodec     58. 87.100 / 58. 87.100
libavformat    58. 43.100 / 58. 43.100
libavdevice    58.  9.103 / 58.  9.103
libavfilter     7. 82.100 /  7. 82.100
libavresample   4.  0.  0 /  4.  0.  0
libswscale      5.  6.101 /  5.  6.101
libswresample   3.  6.100 /  3.  6.100
libpostproc    55.  6.100 / 55.  6.100

On Fri, May 22, 2020 at 6:24 PM Dennis Mungai <[hidden email]> wrote:

> On Sat, 23 May 2020 at 01:07, Andy Sheimo <[hidden email]> wrote:
>
> > I am using the command line seen here but the fps filter is being
> ignored.
> >
> > ffmpeg.exe -loglevel debug -stats -hwaccel cuda -hwaccel_output_format
> cuda
> > -i "Evanescence - Anywhere but Home.mkv" -map 0:0 -filter:v
> > yadif_cuda=deint=interlaced,fps=24000/1001 -c:v h264_nvenc -b:v 2000k
> > -maxrate:v 6000k -rc:v vbr_hq -spatial-aq:v 1 -temporal-aq:v 1 -profile:v
> > high -color_primaries:v smpte170m -color_trc:v bt709 -colorspace:v
> > smpte170m -metadata:s:v title= -disposition:v default -map 0:1 -c:a:0
> eac3
> > -b:a:0 256k -metadata:s:a:0 title= -disposition:a:0 default -map 0:2
> -c:a:1
> > copy -metadata:s:a:1 title= -disposition:a:1 0 -sn -metadata:g title=
> > "Evanescence - Anywhere but Home 2.mkv"
> >
> > I found this in the debug output and am not sure why it sees what was
> > passed by the command line but then is ignored in the filter graph can
> > someone help me understand please? The complete debug output is available
> > but too big to include here.
> >
> > [Parsed_yadif_cuda_0 @ 00000220ac5561c0] Setting 'deint' to value
> > 'interlaced'
> > [Parsed_fps_1 @ 00000220ac74a500] Setting 'fps' to value '24000/1001'
> > [Parsed_fps_1 @ 00000220ac74a500] fps=24000/1001
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'video_size'
> to
> > value '720x480'
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pix_fmt' to
> > value '119'
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'time_base' to
> > value '1/1000'
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pixel_aspect'
> > to value '186/157'
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'frame_rate'
> to
> > value '30000/1001'
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] w:720 h:480
> pixfmt:cuda
> > tb:1/1000 fr:30000/1001 sar:186/157
> > [format @ 00000220ac74bac0] Setting 'pix_fmts' to value
> > 'yuv420p|nv12|p010le|yuv444p|p016le|yuv444p16le|bgr0|rgb0|cuda|d3d11'
> > [AVFilterGraph @ 00000220ac511d80] query_formats: 5 queried, 4 merged, 0
> > already done, 0 delayed
> > [h264_nvenc @ 00000220ac561540] Using input frames context (format cuda)
> > with h264_nvenc encoder.
> > _______________________________________________
> >
>
> What version of ffmpeg are you using?
> There have been recent updates to the NVENC encoder's implementation in
> ffmpeg that better handle frame rate, such as this commit:
>
> https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/b18fd2b95b2fea10f0b5381333a1b4c032f010bc
> Use the latest build and retest.
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> https://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: question about fps filter

Andy Sheimo
How can I check if this version contains the changes you reference?

On Fri, May 22, 2020 at 9:07 PM Andy Sheimo <[hidden email]> wrote:

> using this version created today using
> https://github.com/rdp/ffmpeg-windows-build-helpers
>
> ffmpeg.exe -version
> ffmpeg version N-97877-g1e8ed181e3-ffmpeg-windows-build-helpers Copyright
> (c) 2000-2020 the FFmpeg developers
> built with gcc 8.3.0 (GCC)
> configuration: --pkg-config=pkg-config --pkg-config-flags=--static
> --extra-version=ffmpeg-windows-build-helpers --enable-version3
> --disable-debug --disable-w32threads --arch=x86_64 --target-os=mingw32
> --cross-prefix=/home/asheimo/ffmpeg-windows-build-helpers/sandbox/cross_compilers/mingw-w64-x86_64/bin/x86_64-w64-mingw32-
> --enable-libcaca --enable-gray --enable-libtesseract --enable-fontconfig
> --enable-gmp --enable-gnutls --enable-libass --enable-libbluray
> --enable-libbs2b --enable-libflite --enable-libfreetype --enable-libfribidi
> --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug
> --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb
> --enable-libopus --enable-libsnappy --enable-libsoxr --enable-libspeex
> --enable-libtheora --enable-libtwolame --enable-libvo-amrwbenc
> --enable-libvorbis --enable-libwebp --enable-libzimg --enable-libzvbi
> --enable-libmysofa --enable-libopenjpeg --enable-libopenh264
> --enable-liblensfun --enable-libvmaf --enable-libsrt --enable-demuxer=dash
> --enable-libxml2 --enable-opengl --enable-libdav1d --enable-cuda-llvm
> --enable-libsvthevc --enable-libaom --enable-libvpx --enable-nvenc
> --enable-nvdec --extra-libs=-lharfbuzz --extra-libs=-lm
> --extra-libs=-lpthread --extra-cflags=-DLIBTWOLAME_STATIC
> --extra-cflags=-DMODPLUG_STATIC --extra-cflags=-DCACA_STATIC --enable-amf
> --enable-libmfx --enable-gpl --enable-frei0r --enable-filter=frei0r
> --enable-librubberband --enable-libvidstab --enable-libx264
> --enable-libx265 --enable-libxvid --enable-libxavs --enable-avresample
> --extra-cflags='-mtune=generic' --extra-cflags=-O3 --enable-static
> --disable-shared
> --prefix=/home/asheimo/ffmpeg-windows-build-helpers/sandbox/cross_compilers/mingw-w64-x86_64/x86_64-w64-mingw32
> libavutil      56. 46.100 / 56. 46.100
> libavcodec     58. 87.100 / 58. 87.100
> libavformat    58. 43.100 / 58. 43.100
> libavdevice    58.  9.103 / 58.  9.103
> libavfilter     7. 82.100 /  7. 82.100
> libavresample   4.  0.  0 /  4.  0.  0
> libswscale      5.  6.101 /  5.  6.101
> libswresample   3.  6.100 /  3.  6.100
> libpostproc    55.  6.100 / 55.  6.100
>
> On Fri, May 22, 2020 at 6:24 PM Dennis Mungai <[hidden email]> wrote:
>
>> On Sat, 23 May 2020 at 01:07, Andy Sheimo <[hidden email]> wrote:
>>
>> > I am using the command line seen here but the fps filter is being
>> ignored.
>> >
>> > ffmpeg.exe -loglevel debug -stats -hwaccel cuda -hwaccel_output_format
>> cuda
>> > -i "Evanescence - Anywhere but Home.mkv" -map 0:0 -filter:v
>> > yadif_cuda=deint=interlaced,fps=24000/1001 -c:v h264_nvenc -b:v 2000k
>> > -maxrate:v 6000k -rc:v vbr_hq -spatial-aq:v 1 -temporal-aq:v 1
>> -profile:v
>> > high -color_primaries:v smpte170m -color_trc:v bt709 -colorspace:v
>> > smpte170m -metadata:s:v title= -disposition:v default -map 0:1 -c:a:0
>> eac3
>> > -b:a:0 256k -metadata:s:a:0 title= -disposition:a:0 default -map 0:2
>> -c:a:1
>> > copy -metadata:s:a:1 title= -disposition:a:1 0 -sn -metadata:g title=
>> > "Evanescence - Anywhere but Home 2.mkv"
>> >
>> > I found this in the debug output and am not sure why it sees what was
>> > passed by the command line but then is ignored in the filter graph can
>> > someone help me understand please? The complete debug output is
>> available
>> > but too big to include here.
>> >
>> > [Parsed_yadif_cuda_0 @ 00000220ac5561c0] Setting 'deint' to value
>> > 'interlaced'
>> > [Parsed_fps_1 @ 00000220ac74a500] Setting 'fps' to value '24000/1001'
>> > [Parsed_fps_1 @ 00000220ac74a500] fps=24000/1001
>> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'video_size'
>> to
>> > value '720x480'
>> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pix_fmt' to
>> > value '119'
>> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'time_base'
>> to
>> > value '1/1000'
>> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting
>> 'pixel_aspect'
>> > to value '186/157'
>> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'frame_rate'
>> to
>> > value '30000/1001'
>> > [graph 0 input from stream 0:0 @ 00000220ac749f40] w:720 h:480
>> pixfmt:cuda
>> > tb:1/1000 fr:30000/1001 sar:186/157
>> > [format @ 00000220ac74bac0] Setting 'pix_fmts' to value
>> > 'yuv420p|nv12|p010le|yuv444p|p016le|yuv444p16le|bgr0|rgb0|cuda|d3d11'
>> > [AVFilterGraph @ 00000220ac511d80] query_formats: 5 queried, 4 merged, 0
>> > already done, 0 delayed
>> > [h264_nvenc @ 00000220ac561540] Using input frames context (format cuda)
>> > with h264_nvenc encoder.
>> > _______________________________________________
>> >
>>
>> What version of ffmpeg are you using?
>> There have been recent updates to the NVENC encoder's implementation in
>> ffmpeg that better handle frame rate, such as this commit:
>>
>> https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/b18fd2b95b2fea10f0b5381333a1b4c032f010bc
>> Use the latest build and retest.
>> _______________________________________________
>> ffmpeg-user mailing list
>> [hidden email]
>> https://ffmpeg.org/mailman/listinfo/ffmpeg-user
>>
>> To unsubscribe, visit link above, or email
>> [hidden email] with subject "unsubscribe".
>
>
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: question about fps filter

Moritz Barsnick
Hi Andy,

On Mon, May 25, 2020 at 20:43:03 -0400, Andy Sheimo wrote:
> How can I check if this version contains the changes you reference?
> > ffmpeg.exe -version
> > ffmpeg version N-97877-g1e8ed181e3-ffmpeg-windows-build-helpers Copyright (c) 2000-2020 the FFmpeg developers

Simply speaking, by checking which git commit that version was built
from. The so-called hash of the git commit is the hexadecimal part
after the 'g' in the version:
1e8ed181e3
(or rather, a shortened version of the hash - but it doesn't matter
here).

> >> What version of ffmpeg are you using?
> >> There have been recent updates to the NVENC encoder's implementation in
> >> ffmpeg that better handle frame rate, such as this commit:
> >>
> >> https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/b18fd2b95b2fea10f0b5381333a1b4c032f010bc
> >> Use the latest build and retest.

If you replace the base part of this URL with said hash, as such:
https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/1e8ed181e3
you will see the corresponding commit, and that you are using a build
which includes something committed on Fri, 22 May 2020, while Dennis's
link referenced a change made on Fri, 15 May 2020. So what you are
using includes what Dennis pointed out.

(In reality, it may be more complicated, because git isn't guaranteed
to be linear, but this method suffices for checking how current a build
is.)

Cheers,
Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: question about fps filter

Andy Sheimo
Thanks for the info Moritz that is helpful to me. I'll keep looking at
things and see if my issue goes away in the next couple weeks.

-Andy

On Tue, May 26, 2020 at 2:27 AM Moritz Barsnick <[hidden email]> wrote:

> Hi Andy,
>
> On Mon, May 25, 2020 at 20:43:03 -0400, Andy Sheimo wrote:
> > How can I check if this version contains the changes you reference?
> > > ffmpeg.exe -version
> > > ffmpeg version N-97877-g1e8ed181e3-ffmpeg-windows-build-helpers
> Copyright (c) 2000-2020 the FFmpeg developers
>
> Simply speaking, by checking which git commit that version was built
> from. The so-called hash of the git commit is the hexadecimal part
> after the 'g' in the version:
> 1e8ed181e3
> (or rather, a shortened version of the hash - but it doesn't matter
> here).
>
> > >> What version of ffmpeg are you using?
> > >> There have been recent updates to the NVENC encoder's implementation
> in
> > >> ffmpeg that better handle frame rate, such as this commit:
> > >>
> > >>
> https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/b18fd2b95b2fea10f0b5381333a1b4c032f010bc
> > >> Use the latest build and retest.
>
> If you replace the base part of this URL with said hash, as such:
> https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/1e8ed181e3
> you will see the corresponding commit, and that you are using a build
> which includes something committed on Fri, 22 May 2020, while Dennis's
> link referenced a change made on Fri, 15 May 2020. So what you are
> using includes what Dennis pointed out.
>
> (In reality, it may be more complicated, because git isn't guaranteed
> to be linear, but this method suffices for checking how current a build
> is.)
>
> Cheers,
> Moritz
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> https://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: question about fps filter

kumowoon1025
In reply to this post by Andy Sheimo
Hi,

> I found this in the debug output and am not sure why it sees what was
> passed by the command line but then is ignored in the filter graph can
> someone help me understand please? The complete debug output is available
> but too big to include here.
>
> [Parsed_yadif_cuda_0 @ 00000220ac5561c0] Setting 'deint' to value
> 'interlaced'
> [Parsed_fps_1 @ 00000220ac74a500] Setting 'fps' to value '24000/1001'
> [Parsed_fps_1 @ 00000220ac74a500] fps=24000/1001
> [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'video_size' to
> value '720x480'
> [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pix_fmt' to
> value '119'
> [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'time_base' to
> value '1/1000'
> [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pixel_aspect'
> to value '186/157'
> [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'frame_rate' to
> value '30000/1001'
> [graph 0 input from stream 0:0 @ 00000220ac749f40] w:720 h:480 pixfmt:cuda
> tb:1/1000 fr:30000/1001 sar:186/157

This doesn't necessarily mean the fps was ignored, it just means the input has that frame rate. As you've said it looks like the argument to the fps filter was parsed correctly, the message being logged before doesn't mean anything (it wasn't later overridden to 30000/1001 or anything). Is the output file 30000/1001 fps?

Regards,
Ted Park

_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: question about fps filter

Andy Sheimo
The output file is how I noticed the issue it was reporting original frame
rate as 24000/1001 and current frame rate as 30000/1001.

On Wed, May 27, 2020 at 1:43 AM Edward Park <[hidden email]> wrote:

> Hi,
> > I found this in the debug output and am not sure why it sees what was
> > passed by the command line but then is ignored in the filter graph can
> > someone help me understand please? The complete debug output is available
> > but too big to include here.
> >
> > [Parsed_yadif_cuda_0 @ 00000220ac5561c0] Setting 'deint' to value
> > 'interlaced'
> > [Parsed_fps_1 @ 00000220ac74a500] Setting 'fps' to value '24000/1001'
> > [Parsed_fps_1 @ 00000220ac74a500] fps=24000/1001
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'video_size'
> to
> > value '720x480'
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pix_fmt' to
> > value '119'
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'time_base' to
> > value '1/1000'
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'pixel_aspect'
> > to value '186/157'
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] Setting 'frame_rate'
> to
> > value '30000/1001'
> > [graph 0 input from stream 0:0 @ 00000220ac749f40] w:720 h:480
> pixfmt:cuda
> > tb:1/1000 fr:30000/1001 sar:186/157
>
> This doesn't necessarily mean the fps was ignored, it just means the input
> has that frame rate. As you've said it looks like the argument to the fps
> filter was parsed correctly, the message being logged before doesn't mean
> anything (it wasn't later overridden to 30000/1001 or anything). Is the
> output file 30000/1001 fps?
>
> Regards,
> Ted Park
>
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> https://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: question about fps filter

kumowoon1025
Hi,
> The output file is how I noticed the issue it was reporting original frame
> rate as 24000/1001 and current frame rate as 30000/1001.

I see, that's weird. This only happens with yadif_cuda, not yadif right? Is there a change if you hwdownload before fps filter (other than time)?

Regards,
Ted Park

_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".