libsmbclient support for ffmpeg

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

libsmbclient support for ffmpeg

WANG Haojiao
hi i'm trying to add smb support for my ffmpeg. I added "--enable-libsmbclient" in the configuration and tried to compile. but i always get the a "ERROR: smbclient not found" error. I've attached my config.log in this mail. will be great if can get some help in detail. thx.

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".

config.log (482K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: libsmbclient support for ffmpeg

Reindl Harald


Am 11.04.2017 um 19:08 schrieb WANG Haojiao:
> hi i'm trying to add smb support for my ffmpeg. I added "--enable-libsmbclient" in the configuration and tried to compile. but i always get the a "ERROR: smbclient not found" error. I've attached my config.log in this mail. will be great if can get some help in detail. thx.

and why can't you provide any useful information?
http://www.catb.org/esr/faqs/smart-questions.html#beprecise

google -> ffmpeg "ERROR: smbclient not found"

https://lists.slackbuilds.org/pipermail/slackbuilds-users/2015-June/014443.html

did you install the damned devel package on the operating system you
didn't mention - on Redhat it would be "libsmbclient-devel"

with every day i get older i become more tired of people asking others
to helpf where 1 minute of google would solve the issue and if not THAN
http://www.catb.org/esr/faqs/smart-questions.html#beprecise

Be precise and informative about your problem

     Describe the symptoms of your problem or bug carefully and clearly.

     Describe the environment in which it occurs (machine, OS,
application, whatever). Provide your vendor's distribution and release
level (e.g.: ?Fedora Core 7?, ?Slackware 9.1?, etc.).

     Describe the research you did to try and understand the problem
before you asked the question.

     Describe the diagnostic steps you took to try and pin down the
problem yourself before you asked the question.

     Describe any possibly relevant recent changes in your computer or
software configuration.

     If at all possible, provide a way to reproduce the problem in a
controlled environment.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: libsmbclient support for ffmpeg

Moritz Barsnick
On Tue, Apr 11, 2017 at 19:58:29 +0200, Reindl Harald wrote:
> did you install the damned devel package on the operating system you
> didn't mention - on Redhat it would be "libsmbclient-devel"

It's a cross-compile on Mac OS, for the target iOS on ARM. But I agree,
Haojiao should have said so.

Haojiao, just like with all the other external libraries you are using
(are you even using any?), you need to cross-compile libsmbclient
first, before your ffmpeg build can use it.

You probably found a guide for cross-compiling for your target. Check
out how the other libraries are built and installed. There are also
several cross-compilation guides linked from here:
https://trac.ffmpeg.org/wiki/CompilationGuide

Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Loading...