iPod Videos won't work after ffmpeg update

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

iPod Videos won't work after ffmpeg update

Tobias Brockamp
Hi,

i convert several video files for my ipod in 640x480 resolution. My  
command line looks like this:

ffmpeg -y -i INPUT.avi -acodec libfaac -ab 80k -s 640x480 -vcodec  
libx264 -b 1000k -flags +loop -cmp +chroma -partitions +parti4x4
+partp4x4+partp8x8+partb8x8 -me hex -subq 3 -trellis 1 -refs 1 -coder  
0 -me_range 16 -g 300 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71  
-maxrate 10M -bufsize 10M -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -
qmin 10 -qmax 32 -qdiff 4 -level 30 -aspect 4:3 OUTPUT.mp4

These files worked perfectly but i have updated my ffmpeg  
installation a several days ago to "FFmpeg version SVN-r11075" and  
from now on i can't transfer these files on my ipod.

Anybody an idea? Are there any default values changed in the new svn?

Kind regards,

Tobias Brockamp
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Baptiste Coudurier
Hi

Tobias Brockamp wrote:

> Hi,
>
> i convert several video files for my ipod in 640x480 resolution. My  
> command line looks like this:
>
> ffmpeg -y -i INPUT.avi -acodec libfaac -ab 80k -s 640x480 -vcodec  
> libx264 -b 1000k -flags +loop -cmp +chroma -partitions +parti4x4
> +partp4x4+partp8x8+partb8x8 -me hex -subq 3 -trellis 1 -refs 1 -coder  
> 0 -me_range 16 -g 300 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71  
> -maxrate 10M -bufsize 10M -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -
> qmin 10 -qmax 32 -qdiff 4 -level 30 -aspect 4:3 OUTPUT.mp4
>
> These files worked perfectly but i have updated my ffmpeg  
> installation a several days ago to "FFmpeg version SVN-r11075" and  
> from now on i can't transfer these files on my ipod.
>
> Anybody an idea? Are there any default values changed in the new svn?
>

Maybe, can you try SVN r10757 ?

--
Baptiste COUDURIER                              GnuPG Key Id: 0x5C1ABAAA
SMARTJOG S.A.                                    http://www.smartjog.com
Key fingerprint                 8D77134D20CC9220201FC5DB0AC9325C5C1ABAAA
Phone: +33 1 49966312
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Tobias Brockamp

Am 13.12.2007 um 22:17 schrieb Baptiste Coudurier:

> Hi
>
> Tobias Brockamp wrote:
>> Hi,
>>
>> i convert several video files for my ipod in 640x480 resolution. My
>> command line looks like this:
>>
>> ffmpeg -y -i INPUT.avi -acodec libfaac -ab 80k -s 640x480 -vcodec
>> libx264 -b 1000k -flags +loop -cmp +chroma -partitions +parti4x4
>> +partp4x4+partp8x8+partb8x8 -me hex -subq 3 -trellis 1 -refs 1 -coder
>> 0 -me_range 16 -g 300 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71
>> -maxrate 10M -bufsize 10M -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -
>> qmin 10 -qmax 32 -qdiff 4 -level 30 -aspect 4:3 OUTPUT.mp4
>>
>> These files worked perfectly but i have updated my ffmpeg
>> installation a several days ago to "FFmpeg version SVN-r11075" and
>> from now on i can't transfer these files on my ipod.
>>
>> Anybody an idea? Are there any default values changed in the new svn?
>>
>
> Maybe, can you try SVN r10757 ?

what's wrong with my svn? actually i don't want to downgrade.

>
> --  
> Baptiste COUDURIER                              GnuPG Key Id:  
> 0x5C1ABAAA
> SMARTJOG S.A.                                    http://
> www.smartjog.com
> Key fingerprint                  
> 8D77134D20CC9220201FC5DB0AC9325C5C1ABAAA
> Phone: +33 1 49966312
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Baptiste Coudurier
Tobias Brockamp wrote:

> Am 13.12.2007 um 22:17 schrieb Baptiste Coudurier:
>
>
>>Hi
>>
>>Tobias Brockamp wrote:
>>
>>>Hi,
>>>
>>>i convert several video files for my ipod in 640x480 resolution. My
>>>command line looks like this:
>>>
>>>ffmpeg -y -i INPUT.avi -acodec libfaac -ab 80k -s 640x480 -vcodec
>>>libx264 -b 1000k -flags +loop -cmp +chroma -partitions +parti4x4
>>>+partp4x4+partp8x8+partb8x8 -me hex -subq 3 -trellis 1 -refs 1 -coder
>>>0 -me_range 16 -g 300 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71
>>>-maxrate 10M -bufsize 10M -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -
>>>qmin 10 -qmax 32 -qdiff 4 -level 30 -aspect 4:3 OUTPUT.mp4
>>>
>>>These files worked perfectly but i have updated my ffmpeg
>>>installation a several days ago to "FFmpeg version SVN-r11075" and
>>>from now on i can't transfer these files on my ipod.
>>>
>>>Anybody an idea? Are there any default values changed in the new svn?
>>>
>>
>>Maybe, can you try SVN r10757 ?
>
>
> what's wrong with my svn? actually i don't want to downgrade.
>

I mean FFmpeg svn r10757. It's a guess based on latest modifications in
mp4 muxer. I don't have any ipod myself so I can't check.

--
Baptiste COUDURIER                              GnuPG Key Id: 0x5C1ABAAA
SMARTJOG S.A.                                    http://www.smartjog.com
Key fingerprint                 8D77134D20CC9220201FC5DB0AC9325C5C1ABAAA
Phone: +33 1 49966312
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Tobias Brockamp

Am 13.12.2007 um 22:34 schrieb Baptiste Coudurier:

> Tobias Brockamp wrote:
>> Am 13.12.2007 um 22:17 schrieb Baptiste Coudurier:
>>
>>
>>> Hi
>>>
>>> Tobias Brockamp wrote:
>>>
>>>> Hi,
>>>>
>>>> i convert several video files for my ipod in 640x480 resolution. My
>>>> command line looks like this:
>>>>
>>>> ffmpeg -y -i INPUT.avi -acodec libfaac -ab 80k -s 640x480 -vcodec
>>>> libx264 -b 1000k -flags +loop -cmp +chroma -partitions +parti4x4
>>>> +partp4x4+partp8x8+partb8x8 -me hex -subq 3 -trellis 1 -refs 1 -
>>>> coder
>>>> 0 -me_range 16 -g 300 -keyint_min 25 -sc_threshold 40 -i_qfactor  
>>>> 0.71
>>>> -maxrate 10M -bufsize 10M -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -
>>>> qmin 10 -qmax 32 -qdiff 4 -level 30 -aspect 4:3 OUTPUT.mp4
>>>>
>>>> These files worked perfectly but i have updated my ffmpeg
>>>> installation a several days ago to "FFmpeg version SVN-r11075" and
>>>>> from now on i can't transfer these files on my ipod.
>>>>
>>>> Anybody an idea? Are there any default values changed in the new  
>>>> svn?
>>>>
>>>
>>> Maybe, can you try SVN r10757 ?
>>
>>
>> what's wrong with my svn? actually i don't want to downgrade.
>>
>
> I mean FFmpeg svn r10757. It's a guess based on latest  
> modifications in
> mp4 muxer. I don't have any ipod myself so I can't check.

hmm, i also encode files in 320x240 for the iPod (big ones are for  
ipod touch, appleTV)  which transfers without any problem.
so i guess the problem shouldn't be the mp4 muxer.

>
> --
> Baptiste COUDURIER                              GnuPG Key Id:  
> 0x5C1ABAAA
> SMARTJOG S.A.                                    http://
> www.smartjog.com
> Key fingerprint                  
> 8D77134D20CC9220201FC5DB0AC9325C5C1ABAAA
> Phone: +33 1 49966312
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Tom Bilan
In reply to this post by Tobias Brockamp
>> Hi

>>

>> Tobias Brockamp wrote:

>>> Hi,

>>>

>>> i convert several video files for my ipod in 640x480 resolution. My

>>> command line looks like this:

>>>

>>> ffmpeg -y -i INPUT.avi -acodec libfaac -ab 80k -s 640x480 -vcodec

>>> libx264 -b 1000k -flags +loop -cmp +chroma -partitions +parti4x4

>>> +partp4x4+partp8x8+partb8x8 -me hex -subq 3 -trellis 1 -refs 1
-coder

>>> 0 -me_range 16 -g 300 -keyint_min 25 -sc_threshold 40 -i_qfactor
0.71

>>> -maxrate 10M -bufsize 10M -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -

>>> qmin 10 -qmax 32 -qdiff 4 -level 30 -aspect 4:3 OUTPUT.mp4

>>>

>>> These files worked perfectly but i have updated my ffmpeg

>>> installation a several days ago to "FFmpeg version SVN-r11075" and

>>> from now on i can't transfer these files on my ipod.

>>>

>>> Anybody an idea? Are there any default values changed in the new
svn?

>>>

>>

>> Maybe, can you try SVN r10757 ?

>

>what's wrong with my svn? actually i don't want to downgrade.

 

I have about a dozen versions of FFmpeg that I have compiled myself and
have downloaded from others.  Every time I do a svn update and recompile
it's like hitting a pinata to see what falls out.  Somewhere around
SVN11160 conversion from VOBs to x264 broke.  Also, recently someone
added a timebase error message that warns that quicktime won't play
certain videos and to specify a different rate, which I do, but then it
doesn't work anyway with libx264 but works if I use mpeg4.  This isn't
really a complaint, it's just an observation.  I love ffmpeg because
it's such an active project.  I always keep my old versions of ffmpeg
and label them appropriately (i.e. ffmpeg-10968.exe) so I can try an
older version if needed.

 

As far as your iPod issue, I know you insisted a while back that you
don't need the special atom but I run the latest iTunes (7.5.0.20) and
various versions of ffmpeg and if I encode in x264 and I don't use
nicmp4box then iTunes hates it.  You may have did an svn update the day
that someone posted a patch to help iTunes but I don't have that one but
nicmp4box just makes all the pain go away and takes only seconds so I
use it and go on with my life.  

 

Also, for the list experts out there.  How can you respond to a specific
message when you receive the list in digest form?  I'm just cut/pasting
this into an e-mail using the same subject heading so if you're
obsessive/compulsive about list stuff then that's why this may not show
up in the right thread etc.

 

Have a great day!

 

-TB

 

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Tobias Brockamp

Am 13.12.2007 um 22:55 schrieb Tom Bilan:

>>> Hi
>
>>>
>
>>> Tobias Brockamp wrote:
>
>>>> Hi,
>
>>>>
>
>>>> i convert several video files for my ipod in 640x480 resolution. My
>
>>>> command line looks like this:
>
>>>>
>
>>>> ffmpeg -y -i INPUT.avi -acodec libfaac -ab 80k -s 640x480 -vcodec
>
>>>> libx264 -b 1000k -flags +loop -cmp +chroma -partitions +parti4x4
>
>>>> +partp4x4+partp8x8+partb8x8 -me hex -subq 3 -trellis 1 -refs 1
> -coder
>
>>>> 0 -me_range 16 -g 300 -keyint_min 25 -sc_threshold 40 -i_qfactor
> 0.71
>
>>>> -maxrate 10M -bufsize 10M -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -
>
>>>> qmin 10 -qmax 32 -qdiff 4 -level 30 -aspect 4:3 OUTPUT.mp4
>
>>>>
>
>>>> These files worked perfectly but i have updated my ffmpeg
>
>>>> installation a several days ago to "FFmpeg version SVN-r11075" and
>
>>>> from now on i can't transfer these files on my ipod.
>
>>>>
>
>>>> Anybody an idea? Are there any default values changed in the new
> svn?
>
>>>>
>
>>>
>
>>> Maybe, can you try SVN r10757 ?
>
>>
>
>> what's wrong with my svn? actually i don't want to downgrade.
>
>
>
> I have about a dozen versions of FFmpeg that I have compiled myself  
> and
> have downloaded from others.  Every time I do a svn update and  
> recompile
> it's like hitting a pinata to see what falls out.

you're saying it

> Somewhere around
> SVN11160 conversion from VOBs to x264 broke.  Also, recently someone
> added a timebase error message that warns that quicktime won't play
> certain videos and to specify a different rate, which I do, but  
> then it
> doesn't work anyway with libx264 but works if I use mpeg4.  This isn't
> really a complaint, it's just an observation.  I love ffmpeg because
> it's such an active project.  I always keep my old versions of ffmpeg
> and label them appropriately (i.e. ffmpeg-10968.exe) so I can try an
> older version if needed.
>
>
>
> As far as your iPod issue, I know you insisted a while back that you
> don't need the special atom but I run the latest iTunes (7.5.0.20) and
> various versions of ffmpeg and if I encode in x264 and I don't use
> nicmp4box then iTunes hates it.

I have 7.4.2 and it works (with old ffmpeg-svn)

> You may have did an svn update the day
> that someone posted a patch to help iTunes but I don't have that  
> one but
> nicmp4box just makes all the pain go away and takes only seconds so I
> use it and go on with my life.
>
>
>
> Also, for the list experts out there.  How can you respond to a  
> specific
> message when you receive the list in digest form?  I'm just cut/
> pasting
> this into an e-mail using the same subject heading so if you're
> obsessive/compulsive about list stuff then that's why this may not  
> show
> up in the right thread etc.
>
>
>
> Have a great day!
>
>
>
> -TB
>
>
>
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Stefano Sabatini
In reply to this post by Tom Bilan
On date Thursday 2007-12-13 16:55:42 -0500, Tom Bilan encoded:
[...]
> Also, for the list experts out there.  How can you respond to a specific
> message when you receive the list in digest form?  I'm just cut/pasting
> this into an e-mail using the same subject heading so if you're
> obsessive/compulsive about list stuff then that's why this may not show
> up in the right thread etc.

Indeed digest mode is evil, you should try to avoid it especially when
you want to *participate* to discussion, filtering mails using
procmail/dropmail or webmail filters and delivering them in
corresponding inboxes should make your way easier.

Regards.
--
ffmpeg-user random tip #10
One minute of pure noise with ffmpeg:
ffmpeg -ar 48000 -t 60 -f s16le -acodec pcm_s16le -i /dev/urandom  \
    -ab 64K -f mp2 -acodec mp2 -y noise.mp2
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Benoit Fouet
In reply to this post by Tom Bilan
Tom Bilan wrote:
> Also, for the list experts out there.  How can you respond to a specific
> message when you receive the list in digest form?  I'm just cut/pasting
> this into an e-mail using the same subject heading so if you're
> obsessive/compulsive about list stuff then that's why this may not show
> up in the right thread etc.
>
>  

i'm not a list expert, but i guess the easiest way if you keep on using
digest mode is:
1: visit http://lists.mplayerhq.hu/pipermail/ffmpeg-user/
2: find the message you want to reply to there
3: once you're in the page showing the message, click on the link next
to the name of the poster.

that should do.

--
Ben
Purple Labs S.A.
www.purplelabs.com
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Tobias Brockamp
In reply to this post by Tobias Brockamp
Am 13.12.2007 um 22:07 schrieb Tobias Brockamp:

> Hi,
>
> i convert several video files for my ipod in 640x480 resolution. My
> command line looks like this:
>
> ffmpeg -y -i INPUT.avi -acodec libfaac -ab 80k -s 640x480 -vcodec
> libx264 -b 1000k -flags +loop -cmp +chroma -partitions +parti4x4
> +partp4x4+partp8x8+partb8x8 -me hex -subq 3 -trellis 1 -refs 1 -coder
> 0 -me_range 16 -g 300 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71
> -maxrate 10M -bufsize 10M -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -
> qmin 10 -qmax 32 -qdiff 4 -level 30 -aspect 4:3 OUTPUT.mp4
>
> These files worked perfectly but i have updated my ffmpeg
> installation a several days ago to "FFmpeg version SVN-r11075" and
>> from now on i can't transfer these files on my ipod.
>
> Anybody an idea? Are there any default values changed in the new svn?

back to the primal question. how can i get this work with newer svn?

> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Hervé-4
Tobias Brockamp a écrit :

> Am 13.12.2007 um 22:07 schrieb Tobias Brockamp:
>
>> Hi,
>>
>> i convert several video files for my ipod in 640x480 resolution. My
>> command line looks like this:
>>
>> ffmpeg -y -i INPUT.avi -acodec libfaac -ab 80k -s 640x480 -vcodec
>> libx264 -b 1000k -flags +loop -cmp +chroma -partitions +parti4x4
>> +partp4x4+partp8x8+partb8x8 -me hex -subq 3 -trellis 1 -refs 1 -coder
>> 0 -me_range 16 -g 300 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71
>> -maxrate 10M -bufsize 10M -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -
>> qmin 10 -qmax 32 -qdiff 4 -level 30 -aspect 4:3 OUTPUT.mp4
>>
>> These files worked perfectly but i have updated my ffmpeg
>> installation a several days ago to "FFmpeg version SVN-r11075" and
>>> from now on i can't transfer these files on my ipod.
>> Anybody an idea? Are there any default values changed in the new svn?
>
> back to the primal question. how can i get this work with newer svn?

forget "-acodec libfaac"
at home:
with => "QuickTime cannot open file due a non-valid sequence" (this is
my own stupid translation for the french alert)
without => OK (like with older versions)

aac is the default codec for .mp4
so the audio will be converted in aac

wih an aac file and a h264 video:
ffmpeg -i input.aac -acodec copy -i input.h264 -vcodec copy...
=> a mp4 with a "tagged audio" as raw (and not "mp4a")
if I force the -atag to mp4a, no more result

so forget to define the acode and all will be ok ;)
PS: I use the latest version of faac (1.26), maybe the problem comes
from this version/or its integration and not ffmpeg.

bye

Hervé
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: iPod Videos won't work after ffmpeg update

Tobias Brockamp
...

Am 14.12.2007 um 13:08 schrieb Andrea Barbieri:

>
>
> can you provide the error code QT reports?
>
> I have noticed a weird behaviuor with ffmpeg as well.
>
> I am generating 3gp content in a .mp4 file format using libxvid as  
> video
> codec (the libxvid header and library havent changed during this time)
> and whenever I specify a flag argument the resulting .mp4 won't  
> open in
> QuickTime Player (7.3 and 7.2) with error -8971 but the same .mp4 clip
> plays happily with VLC or ffplay.
>
> now in my case when I use ffmpeg I built from SVN revision 11061
> QuickTime Player has no problems opening the generated .mp4 file.
>
> my successive ffmpeg build was from SVN revision 11149 and the same
> command line presents the QuickTime Player error.
>
> removed the flag options for libxvid (I was using -flags +trell)  
> and the
> newer ffmpeg build generates a .mp4 clip playable by QuickTime Player.
>
> so a simple test would be to remove any flag options and see how your
> current ffmpeg binary behaves.

my files are playable with quicktime, my problem is the transfer via  
iTunes on the iPod.
I already made a testfile without any flag options but this also  
didn't work.

>
> could it just be that the generated .mp4 bitstreams are not fully
> compliant and both VLC and ffplay are more tolerant than
> QuickTimePlayer?
>
> cheers
> andrea
> --
> Andrea Barbieri
> Moving Image Research http://www.movingimageresearch.com/
> The Workshop, Hampton Lane, Bristol, BS6 6LE, UK
> Tel: +44 117 9732200  FAX: +44 117 9732210
> PGP ID=0x034DFD5A  
> KeyFingerprint=C168EA9A7189538D214F1281A7529F32034DFD5A_______________
> ________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user