how to compile ffmpeg with more core support and particular setting

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

how to compile ffmpeg with more core support and particular setting

Pierpaolo Gullˆa
Hi guys , I've a trouble :
I'm using the ffmpeg installed from lenny repository , and I notice that
I doesn't have the mmx supporto (I write ffmpeg -version and later all
the libray I have --disable-mmx)

Now , I create a direcotry under /usr/src and dowownload ffmpef svn
with  svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg

Now i have the svn and I mus to compile with this option :


./configure --prefix=/usr --enable-libamr-nb --enable-libamr-wb --enable-libdc1394 --enable-libfaac --enable-libfaad ---libfaadbin --enable-libgsm --enable-libmp3lame --enable-libnut --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-liba52  --enable-liba52bin --enable-mmx


but I have this error:
FAAD test failed --->I remove always from the option with faad and I
have this error:
./configure --prefix=/usr --enable-libamr-nb --enable-libamr-wb
--enable-libdc1394 --enable-libfaac  --enable-libgsm --enable-libmp3lame
--enable-libnut --enable-libtheora --enable-libvorbis --enable-libx264
--enable-libxvid --enable-liba52  --enable-liba52bin --enable-mmx

liba52 is under GPL and --enable-gpl is not specified.

How I can solve my problems?

I want to add the support of 2 cpu (it's an amd 64bit x2 3600) and i
have read that I must to use this option when I compile

--enable-pthreads


And maybe --cpu=prescott or even --cpu=core2 or other cpu type?(if supported by your gcc)

and --enable-static --disable-shared



aAll this of increase speed encoding.

I'm Right?

Thanks a lor


BR

Pierpaolo



_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-user