frag_duration ignored when segmentation is used

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

frag_duration ignored when segmentation is used

André Hänsel
Hi list,

this successfully generates a fragmented MP4:
ffmpeg -i rtsp://192.168.1.202:554/ch01.264 -map 0:0 -c:v copy
-frag_duration 4000000 out.mp4

But this doesn't, it generates a normal MP4 (ftyp-free-mdat-moov):
ffmpeg -i rtsp://192.168.1.202:554/ch01.264 -map 0:0 -c:v copy
-frag_duration 4000000 -f segment -segment_time 12 -segment_format mp4
out-%03d.mp4

Am I using the wrong command or is ffmpeg unabled to fragment and segment at
the same time?

Regards,
André

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: frag_duration ignored when segmentation is used

Gyan Doshi
On Fri, Oct 5, 2018 at 12:05 AM André Hänsel <[hidden email]> wrote:

>
> But this doesn't, it generates a normal MP4 (ftyp-free-mdat-moov):
> ffmpeg -i rtsp://192.168.1.202:554/ch01.264 -map 0:0 -c:v copy
> -frag_duration 4000000 -f segment -segment_time 12 -segment_format mp4
> out-%03d.mp4
>

Options for the child muxer have to be relayed using segment_format_options
i.e.

-segment_format_options frag_duration=4000000

Gyan
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".