ffmpeg NVENC won't run

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ffmpeg NVENC won't run

lealpa
Hello everyone,

I've installed Cuda toolkit, Nvidia driver and compiled ffmpeg,
installation went smoothly. all seems to be loaded but trying to run it
starts and stucks, no error messages but won't go any further, even on a
very basic command w/o NVENC. What can be wrong?

lealpa@cuda7:~$ sudo /home/lealpa/bin/ffmpeg -i udp://230.8.0.7:10008
teste.mp4
ffmpeg version N-98962-g0271098 Copyright (c) 2000-2020 the FFmpeg
developers
  built with gcc 7 (Ubuntu 7.5.0-3ubuntu1~18.04)
  configuration: --prefix=/home/lealpa/ffmpeg_build
--pkg-config-flags=--static
--extra-cflags=-I/home/lealpa/ffmpeg_build/include
--extra-ldflags=-L/home/lealpa/ffmpeg_build/lib --extra-libs='-lpthread
-lm' --bindir=/home/lealpa/bin --enable-gpl --enable-gnutls --enable-libass
--enable-libfdk-aac --enable-libfreetype --enable-libmp3lame
--enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264
--enable-libx265 --enable-nonfree
  libavutil      56. 58.100 / 56. 58.100
  libavcodec     58.101.101 / 58.101.101
  libavformat    58. 51.101 / 58. 51.101
  libavdevice    58. 11.101 / 58. 11.101
  libavfilter     7. 87.100 /  7. 87.100
  libswscale      5.  8.100 /  5.  8.100
  libswresample   3.  8.100 /  3.  8.100
  libpostproc    55.  8.100 / 55.  8.100
lealpa@cuda7:~$ nvcc -V
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2017 NVIDIA Corporation
Built on Fri_Nov__3_21:07:56_CDT_2017
Cuda compilation tools, release 9.1, V9.1.85

Wed Sep  2 15:57:19 2020
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.64.00    Driver Version: 440.64.00    CUDA Version: 10.2
  |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr.
ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute
M. |
|===============================+======================+======================|
|   0  GeForce GTX 105...  Off  | 00000000:01:00.0 Off |
 N/A |
| 36%   34C    P0    N/A /  75W |      0MiB /  4038MiB |      1%
 Default |
+-------------------------------+----------------------+----------------------+ffmpeg
version N-98962-g0271098 Copyright (c) 2000-2020 the FFmpeg developers
  built with gcc 7 (Ubuntu 7.5.0-3ubuntu1~18.04)
  configuration: --prefix=/home/lealpa/ffmpeg_build
--pkg-config-flags=--static
--extra-cflags=-I/home/lealpa/ffmpeg_build/include
--extra-ldflags=-L/home/lealpa/ffmpeg_build/lib --extra-libs='-lpthread
-lm' --bindir=/home/lealpa/bin --enable-gpl --enable-gnutls --enable-libass
--enable-libfdk-aac --enable-libfreetype --enable-libmp3lame
--enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264
--enable-libx265 --enable-nonfree
  libavutil      56. 58.100 / 56. 58.100
  libavcodec     58.101.101 / 58.101.101
  libavformat    58. 51.101 / 58. 51.101
  libavdevice    58. 11.101 / 58. 11.101
  libavfilter     7. 87.100 /  7. 87.100
  libswscale      5.  8.100 /  5.  8.100
  libswresample   3.  8.100 /  3.  8.100
  libpostproc    55.  8.100 / 55.  8.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options]
outfile}...

Thanks!

LP
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: ffmpeg NVENC won't run

Moritz Barsnick
On Wed, Sep 02, 2020 at 13:04:40 -0300, Leonardo Pagotto wrote:
> starts and stucks, no error messages but won't go any further, even on a
> very basic command w/o NVENC. What can be wrong?
>
> lealpa@cuda7:~$ sudo /home/lealpa/bin/ffmpeg -i udp://230.8.0.7:10008 teste.mp4

Firstly: Do you really need sudo? You shouldn't give ffmpeg (or any
other tool) priviledges it doesn't need.

To your issue:
Are you sure something is sending to that UDP address/port? If nothing
arrives at all, ffmpeg does get stuck there.

Cheers,
Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: ffmpeg NVENC won't run

lealpa
Hi Moritz,

It was a  UDP address/port misconfig, thanks a lot for helping.

Cheers!

LP

On Fri, Sep 4, 2020 at 7:19 AM Moritz Barsnick <[hidden email]> wrote:

> On Wed, Sep 02, 2020 at 13:04:40 -0300, Leonardo Pagotto wrote:
> > starts and stucks, no error messages but won't go any further, even on a
> > very basic command w/o NVENC. What can be wrong?
> >
> > lealpa@cuda7:~$ sudo /home/lealpa/bin/ffmpeg -i udp://230.8.0.7:10008
> teste.mp4
>
> Firstly: Do you really need sudo? You shouldn't give ffmpeg (or any
> other tool) priviledges it doesn't need.
>
> To your issue:
> Are you sure something is sending to that UDP address/port? If nothing
> arrives at all, ffmpeg does get stuck there.
>
> Cheers,
> Moritz
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> https://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".