build error at libavformat/udp.o

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
17 messages Options
Reply | Threaded
Open this post in threaded view
|

build error at libavformat/udp.o

FFmpeg-users mailing list

Hi,

   I am a newbie about FFmpeg.
   I just need it for using Alexa AVS 1.18.0.

  While I try to build the FFmpeg for Android, I got a build error like

          src/libavformat/udp.c:290:28: error: member reference base type '__be32' (aka 'unsigned int') is not a structure or union
             mreqs.imr_multiaddr.s_add = ((structure sockaddr_in *)addr)...........

  The above problem has happened for FFmpeg 4.3.1 and 4.2.1 and 4.1.6.

   Does anybody have any idea about this? Any help will be appreciated.

Thanks.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

FFmpeg-users mailing list
Hi,
   Could anybody answer my question in the below email? It looks to have something to do with my compiler (cxx, cmake 3.6.4..., r16 (ndk)) and the udp.c source though.
Thanks.Hyoung-Taik Kim

Sent from Yahoo Mail on Android
 
  On Fri, Aug 28, 2020 at 12:38 PM, Hyoung Kim via ffmpeg-user<[hidden email]> wrote:  
Hi,

  I am a newbie about FFmpeg.
  I just need it for using Alexa AVS 1.18.0.

  While I try to build the FFmpeg for Android, I got a build error like

          src/libavformat/udp.c:290:28: error: member reference base type '__be32' (aka 'unsigned int') is not a structure or union
            mreqs.imr_multiaddr.s_add = ((structure sockaddr_in *)addr)...........

  The above problem has happened for FFmpeg 4.3.1 and 4.2.1 and 4.1.6.

  Does anybody have any idea about this? Any help will be appreciated.

Thanks.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".  
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

Carl Eugen Hoyos-2
In reply to this post by FFmpeg-users mailing list
Am Fr., 28. Aug. 2020 um 18:38 Uhr schrieb Hyoung Kim via ffmpeg-user
<[hidden email]>:

>    I am a newbie about FFmpeg.
>    I just need it for using Alexa AVS 1.18.0.
>
>   While I try to build the FFmpeg for Android, I got a build error like
>
>           src/libavformat/udp.c:290:28: error: member reference base type '__be32' (aka 'unsigned int') is not a structure or union
>              mreqs.imr_multiaddr.s_add = ((structure sockaddr_in *)addr)...........
>
>   The above problem has happened for FFmpeg 4.3.1 and 4.2.1 and 4.1.6.

Please test current FFmpeg git head and provide the configure line you tested.
Other build scripts than our configure script are not supported here.

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

FFmpeg-users mailing list
 
Hi,

 Thank you very much for your response.
 
 Upon your suggestion, I have done git clone the current git head, but I have faced different problem.
 I will try to explain one step at a time.

 1. my build environment :
 a. Target Android OS : 7.1.2
 b. Alexa AVS version : 1.18.0
 c. cmake version : 3.6.4111459
 d. Android NDK version : r16
 e. Android Library : 6.0 (Api level 23)
 f. CXX : android-ndk-r16/toolchain-armeabi-v7a/android-23/bin/arm-linux-androideabi-clang++
 g. Build environment OS : ubuntu 18.0.1 under VirtualBox (host machine is Windows 10)

 2. build error message, when I have used FFmpeg 4.3.1 :


src/libavformat/udp.c:296:28: error: member reference base type
 '__be32' (aka 'unsigned int') is not a structure or union
 mreqs.imr_multiaddr.s_addr = ((struct sockaddr_in *)add...
 ~~~~~~~~~~~~~~~~~~~^~~~~~~
src/libavformat/udp.c:298:32: error: assigning to '__be32'
 (aka 'unsigned int') from incompatible type 'struct in_addr'
 ...= ((struct sockaddr_in *)local_addr)->sin_addr;
 ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
src/libavformat/udp.c:300:32: error: member reference base type
 '__be32' (aka 'unsigned int') is not a structure or union
 mreqs.imr_interface.s_addr= INADDR_ANY;
 ~~~~~~~~~~~~~~~~~~~^~~~~~~
src/libavformat/udp.c:301:29: error: member reference base type
 '__be32' (aka 'unsigned int') is not a structure or union
 mreqs.imr_sourceaddr.s_addr = ((struct sockaddr_in *)&s...
 ~~~~~~~~~~~~~~~~~~~~^~~~~~~
4 errors generated.


 3. build error message, when I have used git head :


 /ffmpeg/configure: /bin/sh^M: bad interpreter: No such file or directory



Thank you very much in any case.


     On Monday, August 31, 2020, 05:31:28 PM EDT, Carl Eugen Hoyos <[hidden email]> wrote:  
 
 Am Fr., 28. Aug. 2020 um 18:38 Uhr schrieb Hyoung Kim via ffmpeg-user
<[hidden email]>:

>    I am a newbie about FFmpeg.
>    I just need it for using Alexa AVS 1.18.0.
>
>  While I try to build the FFmpeg for Android, I got a build error like
>
>          src/libavformat/udp.c:290:28: error: member reference base type '__be32' (aka 'unsigned int') is not a structure or union
>              mreqs.imr_multiaddr.s_add = ((structure sockaddr_in *)addr)...........
>
>  The above problem has happened for FFmpeg 4.3.1 and 4.2.1 and 4.1.6.

Please test current FFmpeg git head and provide the configure line you tested.
Other build scripts than our configure script are not supported here.

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".  
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

kumowoon1025
Hi,

 I will try to explain one step at a time.


Can you explain one step at a time, as in explain the steps you took (one
command line at a time)? Maybe it’s because I’ve never cross compiled
ffmpeg but your mentioning cmake makes me think you are messing up the
build system. Like there’s no info about your c environment.

 3. build error message, when I have used git head :
>
>
>
>
>
>  /ffmpeg/configure: /bin/sh^M: bad interpreter: No such file or directory


Did you do anything after checking out the repository before running
configure (except cd’ing into the directory)? That carriage return I think
I’ve seen when a super long list of arguments were given but probably the
issue is something else.

Regards,
Ted
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

FFmpeg-users mailing list
 Hi,

Thanks for your response.

1. You are right.
The error message with the git head in my previous email looked like
an encoding issue. So I have done git clone at ubuntu 18.01 again and I got the same error message I had
for FFmpeg 4.3.1 like followings :

src/libavformat/udp.c:296:28: error: member reference base type
'__be32' (aka 'unsigned int') is not a structure or union
mreqs.imr_multiaddr.s_addr = ((struct sockaddr_in *)add...
~~~~~~~~~~~~~~~~~~~^~~~~~~
src/libavformat/udp.c:298:32: error: assigning to '__be32'
(aka 'unsigned int') from incompatible type 'struct in_addr'
...= ((struct sockaddr_in *)local_addr)->sin_addr;
^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
src/libavformat/udp.c:300:32: error: member reference base type
'__be32' (aka 'unsigned int') is not a structure or union
mreqs.imr_interface.s_addr= INADDR_ANY;
~~~~~~~~~~~~~~~~~~~^~~~~~~
src/libavformat/udp.c:301:29: error: member reference base type
'__be32' (aka 'unsigned int') is not a structure or union
mreqs.imr_sourceaddr.s_addr = ((struct sockaddr_in *)&s...
~~~~~~~~~~~~~~~~~~~~^~~~~~~
4 errors generated.



2. I have attached the first part of log, when I have tried to build the FFmpeg at the end of this email.

3. When I tried to use FFmpeg 4.0.6, I do not have any problem to build it. I have even done simple smoke test successfully for our final product.



Thanks in any case.
     On Monday, August 31, 2020, 09:28:21 PM EDT, Ted Park <[hidden email]> wrote:  
 
 Hi,

 I will try to explain one step at a time.


Can you explain one step at a time, as in explain the steps you took (one
command line at a time)? Maybe it’s because I’ve never cross compiled
ffmpeg but your mentioning cmake makes me think you are messing up the
build system. Like there’s no info about your c environment.

 3. build error message, when I have used git head :
>
>
>
>
>
>  /ffmpeg/configure: /bin/sh^M: bad interpreter: No such file or directory


Did you do anything after checking out the repository before running
configure (except cd’ing into the directory)? That carriage return I think
I’ve seen when a super long list of arguments were given but probably the
issue is something else.

Regards,
Ted
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".  
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".

hk89.txt (22K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

kumowoon1025
Hi,

> 3. When I tried to use FFmpeg 4.0.6, I do not have any problem to build it. I have even done simple smoke test successfully for our final product.

Are you saying with older source, following the same steps gives you functional output? I thought you were trying to configure the build without a toolchain for cross compiling for whatever android device but i dont know now... Hopefully someone better informed will help you out but I think it's weird it doesn't look like you're using an sdk for developing for android for the tools, usually they have extended names that are arch specific to distinguish them (if you tell clang to cross compile for arm and it uses its as, ld, ar, c library, etc I don't think you can do that for android)

Regards,
Ted Park

_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

Moritz Barsnick
In reply to this post by FFmpeg-users mailing list
On Mon, Aug 31, 2020 at 23:14:33 +0000, Hyoung Kim via ffmpeg-user wrote:
>  3. build error message, when I have used git head :
>  /ffmpeg/configure: /bin/sh^M: bad interpreter: No such file or directory

This looks like you cloned under Windows, and it automatically adjusted
the line endings to DOS/Windows style (CR/LF). There's a git
configuration for that. If you can't adjust that, just clone from
within the Linux VM, that should simply work.

Cheers,
Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

FFmpeg-users mailing list
Hi,      Thanks.    You were right.     So I have replied about it.
Thanks again.
 
Sent from Yahoo Mail on Android
 
  On Tue, Sep 1, 2020 at 6:20 AM, Moritz Barsnick<[hidden email]> wrote:   On Mon, Aug 31, 2020 at 23:14:33 +0000, Hyoung Kim via ffmpeg-user wrote:
>  3. build error message, when I have used git head :
>  /ffmpeg/configure: /bin/sh^M: bad interpreter: No such file or directory

This looks like you cloned under Windows, and it automatically adjusted
the line endings to DOS/Windows style (CR/LF). There's a git
configuration for that. If you can't adjust that, just clone from
within the Linux VM, that should simply work.

Cheers,
Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".  
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

FFmpeg-users mailing list
In reply to this post by kumowoon1025
Hi,    Thanks for your response.
    Yes, older source works fine, but newer sources (4.1.6, 4.2.1, 4.3.1 and git head) has build problem. So I have compared the source of udp.c between 4.0.6 and 4.3.1. There is a difference, but even the 4.0.6 has same statements which caused syntax error. So there could be 3 possibilities.
1. Define difference between older source and newer source.2. The primitive type has been converted to struct or union in older source somewhere while newer source does not.3. The build environment could have been changed in newer source.
Any idea about this?
Thanks anyway.

Sent from Yahoo Mail on Android
 
  On Tue, Sep 1, 2020 at 2:34 AM, Edward Park<[hidden email]> wrote:   Hi,

> 3. When I tried to use FFmpeg 4.0.6, I do not have any problem to build it. I have even done simple smoke test successfully for our final product.

Are you saying with older source, following the same steps gives you functional output? I thought you were trying to configure the build without a toolchain for cross compiling for whatever android device but i dont know now... Hopefully someone better informed will help you out but I think it's weird it doesn't look like you're using an sdk for developing for android for the tools, usually they have extended names that are arch specific to distinguish them (if you tell clang to cross compile for arm and it uses its as, ld, ar, c library, etc I don't think you can do that for android)

Regards,
Ted Park

_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".  
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

Moritz Barsnick
On Tue, Sep 01, 2020 at 10:57:33 +0000, Hyoung Kim via ffmpeg-user wrote:
>     Yes, older source works fine, but newer sources (4.1.6, 4.2.1, 4.3.1 and git head) has build problem. So I have compared the source of udp.c between 4.0.6 and 4.3.1. There is a difference, but even the 4.0.6 has same statements which caused syntax error. So there could be 3 possibilities.
> 1. Define difference between older source and newer source.2. The primitive type has been converted to struct or union in older source somewhere while newer source does not.3. The build environment could have been changed in newer source.
> Any idea about this?

As long as no one else can reproduce this issue, it's up to you to try.

To find out which specific change broke your build - yes, it could be
ffmpeg's build system config - you would use "git bisect".

You go to the git master branch, find a commit where it still works
(probably around 4.0.x time) and a commit when it no longer works
(probably around 4.1.x time, from your reports), and git will help you
iterate through commits to find the offending one, with least possible
iterations.

There are quite a few instructions around for this process. I would
need to look it up myself, as I have only seldomly used it.

Regards,
Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

FFmpeg-users mailing list
 Hi,
   Thanks for the tip.
Thanks again.

Sent from Yahoo Mail on Android
 
  On Tue, Sep 1, 2020 at 9:03 AM, Moritz Barsnick<[hidden email]> wrote:   On Tue, Sep 01, 2020 at 10:57:33 +0000, Hyoung Kim via ffmpeg-user wrote:
>     Yes, older source works fine, but newer sources (4.1.6, 4.2.1, 4.3.1 and git head) has build problem. So I have compared the source of udp.c between 4.0.6 and 4.3.1. There is a difference, but even the 4.0.6 has same statements which caused syntax error. So there could be 3 possibilities.
> 1. Define difference between older source and newer source.2. The primitive type has been converted to struct or union in older source somewhere while newer source does not.3. The build environment could have been changed in newer source.
> Any idea about this?

As long as no one else can reproduce this issue, it's up to you to try.

To find out which specific change broke your build - yes, it could be
ffmpeg's build system config - you would use "git bisect".

You go to the git master branch, find a commit where it still works
(probably around 4.0.x time) and a commit when it no longer works
(probably around 4.1.x time, from your reports), and git will help you
iterate through commits to find the offending one, with least possible
iterations.

There are quite a few instructions around for this process. I would
need to look it up myself, as I have only seldomly used it.

Regards,
Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".  
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

Carl Eugen Hoyos-2
In reply to this post by FFmpeg-users mailing list
Am Di., 1. Sept. 2020 um 01:45 Uhr schrieb Hyoung Kim via ffmpeg-user
<[hidden email]>:

>  d. Android NDK version : r16

The issue is (for example) not reproducible with r19b here.

If you need more support, don't forget to show us the configure
line you tested!

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

FFmpeg-users mailing list
Hi,
   Thanks for your response.   Even if I am not 100 percent sure, it looks to have something to do with newer nghttp2 library which I need for building Alexa AVS SDK. I mean same named structure has been defined in nghttp2 and it migh have caused to compile some part of ffmpeg which should not be compiled by c directive. I will keep checking it out.
Thanks again.

Sent from Yahoo Mail on Android
 
  On Tue, Sep 1, 2020 at 1:39 PM, Carl Eugen Hoyos<[hidden email]> wrote:   Am Di., 1. Sept. 2020 um 01:45 Uhr schrieb Hyoung Kim via ffmpeg-user
<[hidden email]>:

>  d. Android NDK version : r16

The issue is (for example) not reproducible with r19b here.

If you need more support, don't forget to show us the configure
line you tested!

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".  
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

FFmpeg-users mailing list
Hi,
   Regarding the above case, I think that I have found out where the problem came from.
1. In libavformat/udp.c, there is a fuction. udp_set_multicast_sources. 
2. Inside the function, there is c directive like #if HAVE_STRUCT_IP_MREQ_SOURCE && ....
3. In version 4.0.6, it used to be #elif, but the logic about it has been slightly changed. So, in 4.3.1, it became #if.
4. So, for my case, the control goes to first #if and it goes to  #if HAVE_STRUCT_IP_MREQ_SOURCE again. In case of older version, the control does not have to go to there.
5.With my compiler, it has caused the problem.
6. Even if this case could be rare and rare, I think that it has better be improved.
7. Any suggestion for good solution about this case would be appreciated.
Thanks.

Sent from Yahoo Mail on Android
 
  On Tue, Sep 1, 2020 at 1:56 PM, Hyoung Kim via ffmpeg-user<[hidden email]> wrote:   Hi,
   Thanks for your response.   Even if I am not 100 percent sure, it looks to have something to do with newer nghttp2 library which I need for building Alexa AVS SDK. I mean same named structure has been defined in nghttp2 and it migh have caused to compile some part of ffmpeg which should not be compiled by c directive. I will keep checking it out.
Thanks again.

Sent from Yahoo Mail on Android
 
  On Tue, Sep 1, 2020 at 1:39 PM, Carl Eugen Hoyos<[hidden email]> wrote:  Am Di., 1. Sept. 2020 um 01:45 Uhr schrieb Hyoung Kim via ffmpeg-user
<[hidden email]>:

>  d. Android NDK version : r16

The issue is (for example) not reproducible with r19b here.

If you need more support, don't forget to show us the configure
line you tested!

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe". 
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".  
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

kumowoon1025
Hi,

>>   d. Android NDK version : r16
>
> The issue is (for example) not reproducible with r19b here.


It turns out this is the crux of the problem, android idiosyncrasy in its c library. Actually the error was describing the exact problem, ip_mreq_source struct is defined differently.

https://issuetracker.google.com/issues/36987220

Regards,
Ted Park

_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: build error at libavformat/udp.o

FFmpeg-users mailing list
Hi,
   Thanks.    It was very informative.
Thanks again.


Sent from Yahoo Mail on Android
 
  On Tue, Sep 1, 2020 at 7:37 PM, Edward Park<[hidden email]> wrote:   Hi,

>>  d. Android NDK version : r16
>
> The issue is (for example) not reproducible with r19b here.


It turns out this is the crux of the problem, android idiosyncrasy in its c library. Actually the error was describing the exact problem, ip_mreq_source struct is defined differently.

https://issuetracker.google.com/issues/36987220

Regards,
Ted Park

_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".  
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".