Quantcast

audio to video with image?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

audio to video with image?

Justin Scott
Hi,

I am trying to take an existing  mp3 file and covert it to mp4 file that uses an image that will display during the entire video while the audio is playing. I tried the following command and am getting an "option loop not found" error. When I take out the loop parameter, I get a video with no sound and no image.

ffmpeg -loop 1 -i img.gif -i source.mp3 -c:v libx264 -c:a aac -strict experimental -b:a 192k -shortest output.mp4"

I am using the latest ffmpeg 2.2.2 release (specifics below) on Win 2010 x64.

  libavutil      52. 66.100 / 52. 66.100
  libavcodec     55. 52.102 / 55. 52.102
  libavformat    55. 33.100 / 55. 33.100
  libavdevice    55. 10.100 / 55. 10.100
  libavfilter     4.  2.100 /  4.  2.100
  libswscale      2.  5.102 /  2.  5.102
  libswresample   0. 18.100 /  0. 18.100
  libpostproc    52.  3.100 / 52.  3.100

Thank you in advance,

Justin
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: audio to video with image?

Paul B Mahol
On 4/13/17, Justin Scott <[hidden email]> wrote:

> Hi,
>
> I am trying to take an existing  mp3 file and covert it to mp4 file that
> uses an image that will display during the entire video while the audio is
> playing. I tried the following command and am getting an "option loop not
> found" error. When I take out the loop parameter, I get a video with no
> sound and no image.
>
> ffmpeg -loop 1 -i img.gif -i source.mp3 -c:v libx264 -c:a aac -strict
> experimental -b:a 192k -shortest output.mp4"

try with -stream_loop -1

>
> I am using the latest ffmpeg 2.2.2 release (specifics below) on Win 2010
> x64.
>
>   libavutil      52. 66.100 / 52. 66.100
>   libavcodec     55. 52.102 / 55. 52.102
>   libavformat    55. 33.100 / 55. 33.100
>   libavdevice    55. 10.100 / 55. 10.100
>   libavfilter     4.  2.100 /  4.  2.100
>   libswscale      2.  5.102 /  2.  5.102
>   libswresample   0. 18.100 /  0. 18.100
>   libpostproc    52.  3.100 / 52.  3.100
>
> Thank you in advance,
>
> Justin
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: audio to video with image?

Lou-2
In reply to this post by Justin Scott
On Thu, Apr 13, 2017, at 05:58 AM, Justin Scott wrote:
>
> I am using the latest ffmpeg 2.2.2 release

Probably too old. Always use a recent build. Windows binaries are
available at:
https://ffmpeg.zeranoe.com/builds/
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Loading...