Using ffmpeg with HD video broadcasts

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Using ffmpeg with HD video broadcasts

Martin Goose-2
I use ffmpeg to tidy up UK digital satellite TV recordings using a
command such as:
ffmpeg -i mm.ts -vcodec copy -acodec copy -ss 00:07:01 -t 00:51:28 -y
mm.mp4

This works very well with standard definition recordings but fails with
high definition recordings. Example uncut output is below. I can transcode
these videos using Handbrake which I think uses ffmpeg so I guess the
error is mine and not something that ffmpeg cannot do.

Can someone please advise me where I am going wrong?

--------- start output --------
ffmpeg version 0.7.15, Copyright (c) 2000-2013 the FFmpeg developers
  built on Jul 25 2013 06:16:13 with gcc 4.7.2
  configuration: --prefix=/usr --enable-shared --libdir=/usr/lib64 --
shlibdir=/usr/lib64 --incdir=/usr/include --disable-stripping --enable-
postproc --enable-gpl --enable-pthreads --enable-libtheora --enable-
libvorbis --disable-encoder=vorbis --enable-libvpx --enable-x11grab --
enable-runtime-cpudetect --enable-libdc1394 --enable-libschroedinger --
enable-librtmp --enable-libmp3lame --enable-libopencore-amrnb --enable-
libopencore-amrwb --enable-version3 --enable-libx264 --enable-nonfree --
enable-libfaac --enable-libxvid
  libavutil    50. 43. 0 / 50. 43. 0
  libavcodec   52.123. 0 / 52.123. 0
  libavformat  52.111. 0 / 52.111. 0
  libavdevice  52.  5. 0 / 52.  5. 0
  libavfilter   1. 80. 0 /  1. 80. 0
  libswscale    0. 14. 1 /  0. 14. 1
  libpostproc  51.  2. 0 / 51.  2. 0
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS referenced
[h264 @ 0x1505300] non-existing SPS 0 referenced in buffering period
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] non-existing PPS 0 referenced
[h264 @ 0x1505300] decode_slice_header error
[h264 @ 0x1505300] no frame!
[h264 @ 0x1505300] mmco: unref short failure
    Last message repeated 1 times
[mpegts @ 0x14fd0e0] max_analyze_duration 5000000 reached at 5024000
[NULL @ 0x1522c80] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x1524d80] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x1526e80] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x1528f80] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x152d180] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x152f280] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x1531380] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x1533480] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x1535580] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x1537680] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x1539780] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x153b880] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x153fa80] start time is not set in
av_estimate_timings_from_pts                  
[NULL @ 0x1541b80] start time is not set in
av_estimate_timings_from_pts                  
Input #0, mpegts, from 'bam.ts':
  Duration: 01:09:52.33, start: 92096.160644, bitrate: 6758 kb/s
  Program 6940
  Program 6941
    Stream #0.0[0x1518]: Video: h264 (High), yuv420p, 1920x1080 [PAR 1:1
DAR 16:9], 30.05 fps, 25 tbr, 90k tbn, 50 tbc
    Stream #0.1[0x151a](NAR): Audio: mp2, 48000 Hz, stereo, s16, 256 kb/s
    Stream #0.2[0x151b](eng): Subtitle: [6][0][0][0] / 0x0006
    Stream #0.3[0xf06]: Data: [11][0][0][0] / 0x000B
    Stream #0.4[0xf07]: Data: [11][0][0][0] / 0x000B
    Stream #0.5[0xf09]: Data: [11][0][0][0] / 0x000B
    Stream #0.6[0x151c](eng): Subtitle: dvbsub
    Stream #0.7[0xf00]: Data: [5][0][0][0] / 0x0005
    Stream #0.8[0xf01]: Data: [5][0][0][0] / 0x0005
    Stream #0.9[0xf02]: Data: [5][0][0][0] / 0x0005
    Stream #0.10[0xf03]: Data: [5][0][0][0] / 0x0005
    Stream #0.11[0xf04]: Data: [5][0][0][0] / 0x0005
    Stream #0.12[0x911]: Data: [5][0][0][0] / 0x0005
    Stream #0.13[0x912]: Data: [5][0][0][0] / 0x0005
    Stream #0.14[0x913]: Data: [5][0][0][0] / 0x0005
    Stream #0.15[0x1519](eng): Audio: ac3, 48000 Hz, stereo, s16, 192 kb/s
    Stream #0.16[0x919]: Data: [5][0][0][0] / 0x0005
    Stream #0.17[0x91a]: Data: [5][0][0][0] / 0x0005
  Program 6943
  Program 6945
Output #0, mp4, to 'bam.mp4':
  Metadata:
    encoder         : Lavf52.111.0
    Stream #0.0: Video: libx264, yuv420p, 1920x1080 [PAR 1:1 DAR 16:9],
q=2-31, 25 tbn, 25 tbc
    Stream #0.1(NAR): Audio: mp2, 48000 Hz, stereo, 256 kb/s
Stream mapping:
  Stream #0.0 -> #0.0
  Stream #0.1 -> #0.1
Press [q] to stop, [?] for help
[mp4 @ 0x14fbb80] Application provided invalid, non monotonically
increasing dts to muxer in stream 0: 1475 >= 1475
av_interleaved_write_frame(): Invalid data found when processing input
---------  end output  --------

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Using ffmpeg with HD video broadcasts

littlebat
On Mon, 7 Oct 2013 10:15:25 +0000 (UTC)
Martin Goose <[hidden email]> wrote:

> I use ffmpeg to tidy up UK digital satellite TV recordings using a
> command such as:
> ffmpeg -i mm.ts -vcodec copy -acodec copy -ss 00:07:01 -t 00:51:28 -y
> mm.mp4
>
> This works very well with standard definition recordings but fails
> with high definition recordings. Example uncut output is below. I can
> transcode these videos using Handbrake which I think uses ffmpeg so I
> guess the error is mine and not something that ffmpeg cannot do.
>
> Can someone please advise me where I am going wrong?
>
> --------- start output --------
> ffmpeg version 0.7.15, Copyright (c) 2000-2013 the FFmpeg developers
>   built on Jul 25 2013 06:16:13 with gcc 4.7.2
>

Too old version, try the lastest:
https://ffmpeg.org/trac/ffmpeg/wiki/CompilationGuide
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Using ffmpeg with HD video broadcasts

Martin Goose-2
On Mon, 07 Oct 2013 18:54:50 +0800, littlebat wrote:

> Too old version, try the lastest:
> https://ffmpeg.org/trac/ffmpeg/wiki/CompilationGuide

Thanks. That is the version that comes with my Linux distro PCLinuxOS. I
will ask for the latest version of ffmpeg and/or try another distro.

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Using ffmpeg with HD video broadcasts

littlebat
On Mon, 7 Oct 2013 11:59:21 +0000 (UTC)
Martin Goose <[hidden email]> wrote:

> On Mon, 07 Oct 2013 18:54:50 +0800, littlebat wrote:
>
> > Too old version, try the lastest:
> > https://ffmpeg.org/trac/ffmpeg/wiki/CompilationGuide
>
> Thanks. That is the version that comes with my Linux distro
> PCLinuxOS. I will ask for the latest version of ffmpeg and/or try
> another distro.
>

Try static binary for test: http://ffmpeg.gusari.org/static/ 
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Using ffmpeg with HD video broadcasts

Martin Goose-2
On Mon, 07 Oct 2013 21:23:50 +0800, littlebat wrote:

> On Mon, 7 Oct 2013 11:59:21 +0000 (UTC)
> Martin Goose <[hidden email]> wrote:
>
>> On Mon, 07 Oct 2013 18:54:50 +0800, littlebat wrote:
>>
>> > Too old version, try the lastest:
>> > https://ffmpeg.org/trac/ffmpeg/wiki/CompilationGuide
>>
>> Thanks. That is the version that comes with my Linux distro PCLinuxOS.
>> I will ask for the latest version of ffmpeg and/or try another distro.
>>
>>
> Try static binary for test: http://ffmpeg.gusari.org/static/

I had a quick look at Ubuntu and ran the ffmpeg version there. It gave a
warning that ffmpeg is deprecated and 'avconv' should be used instead.
The version of 'libav' that contains 'avconv' in the PCLinuxOS repos does
the job!

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Using ffmpeg with HD video broadcasts

Carl Eugen Hoyos
Martin Goose <news2013 <at> thegoosefamily.plus.com> writes:

> > Try static binary for test: http://ffmpeg.gusari.org/static/
>
> I had a quick look at Ubuntu and ran the ffmpeg version there.
> It gave a warning that ffmpeg is deprecated

This is an intentional lie, see
http://blog.pkh.me/p/13-the-ffmpeg-libav-situation.html for
more information.

> and 'avconv' should be used instead.

avconv contains several hundred bugs that are not reproducible
with FFmpeg, some of them are possibly security-relevant,
please understand that we therefore cannot support avconv here.

Carl Eugen

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Using ffmpeg with HD video broadcasts

Martin Goose-2
On Tue, 08 Oct 2013 10:24:01 +0000, Carl Eugen Hoyos wrote:

> This is an intentional lie, see
> http://blog.pkh.me/p/13-the-ffmpeg-libav-situation.html for more
> information.

Thank you for the link to this information. I was unaware of this.
PCLinuxOS currently has ffmpeg 2.0.1 in the testing repo. The current
position is "This package is in testing since there are many apps that
need patching since they do not build with this version."

I will await its release from testing and resume using it then.

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Using ffmpeg with HD video broadcasts

Phil Rhodes
In reply to this post by Carl Eugen Hoyos


> > It gave a warning that ffmpeg is deprecated

> This is an intentional lie


No, it isn't. The people who distribute ffmpeg as part of a linux distribution are free to deprecate it.

Please do not accuse people of lying on this list. It is considered very rude.

P
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Using ffmpeg with HD video broadcasts

Paul B Mahol
On 10/8/13, Phil Rhodes <[hidden email]> wrote:
>
>
>> > It gave a warning that ffmpeg is deprecated
>
>> This is an intentional lie
>
>
> No, it isn't. The people who distribute ffmpeg as part of a linux
> distribution are free to deprecate it.

But not in the way how it was done.

>
> Please do not accuse people of lying on this list. It is considered very
> rude.

You are troll and nobody takes you seriously.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user