Unable to enable libaom-av1 encoder

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to enable libaom-av1 encoder

Ashish Jha
I want to try av1 codec so I tried to enable libaom encoder. However, I am not able to do so.
I tried various commands from google, but whenever I tried to encode, it says: Codec 'libaom-av1' is not recognized by FFmpeg.

Please let me know, how can I enable this encoder.

Regards,
Ashish
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Unable to enable libaom-av1 encoder

Carl Eugen Hoyos-2


> Am 27.12.2019 um 08:26 schrieb Ashish Jha <[hidden email]>:
>
> I want to try av1 codec so I tried to enable libaom encoder. However, I am not able to do so.
> I tried various commands from google, but whenever I tried to encode, it says: Codec 'libaom-av1' is not recognized by FFmpeg.
>
> Please let me know, how can I enable this encoder.

When building FFmpeg, you have to run configure with the option --enable-libaom to get the aom encoder.

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Unable to enable libaom-av1 encoder

Venkateswaran.S
In reply to this post by Ashish Jha
What's your operating system.?

You have to install aom library and compile ffmpeg with --enable-libaom flah
https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu#libaom

Regards,
Venkateswaran.S
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Unable to enable libaom-av1 encoder

Ashish Jha
Thanks !!
________________________________
From: ffmpeg-user <[hidden email]> on behalf of Venkateswaran.S <[hidden email]>
Sent: Friday, December 27, 2019 3:38 PM
To: FFmpeg user questions <[hidden email]>
Subject: Re: [FFmpeg-user] Unable to enable libaom-av1 encoder

What's your operating system.?

You have to install aom library and compile ffmpeg with --enable-libaom flah
https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu#libaom

Regards,
Venkateswaran.S
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".