TV won't play file :

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

TV won't play file :

Sophie Loewenthal
Hi,

I have a video encoded like this ( that was sent to me ).

ffprobe gave me the details:
Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709/bt709/unknown), 1920x800, 2091 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc (default)

It won’t play on my TV ( Philip 24PFS5303/12) which has played every x264 file I’ve thrown at it until it met this one. However this film plays fine on VLC and MacOS’ preview option (by pressing spacebar on a file )

I wonder if the problem is related to the colorspace that is written "unknown"  in "tv, bt709/bt709/unknown".
If som can I just encode this into something else.  Or perhaps the TV doesn’t like bt709.  


e.g this file will play on the TV:
Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], 811 kb/s, 23.98 fps, 23.98 tbr, 96k tbn, 47.95 tbc (default)


Best,
Sophie





_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: TV won't play file :

Carl Eugen Hoyos-2
2019-01-15 18:36 GMT+01:00, Sophie Loewenthal <[hidden email]>:

> I have a video encoded like this ( that was sent to me ).
>
> ffprobe gave me the details:
> Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709/bt709/unknown),
> 1920x800, 2091 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc (default)
>
> It won’t play on my TV ( Philip 24PFS5303/12)

Shouldn't you ask Philip?

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: TV won't play file :

Kieran O Leary
In reply to this post by Sophie Loewenthal
On Tue, 15 Jan 2019, 17:36 Sophie Loewenthal <[hidden email] wrote:

> Hi,
>
> I have a video encoded like this ( that was sent to me ).
>
> ffprobe gave me the details:
> Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709/bt709/unknown),
> 1920x800, 2091 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc (default)
>
> It won’t play on my TV ( Philip 24PFS5303/12) which has played every x264
> file I’ve thrown at it until it met this one. However this film plays fine
> on VLC and MacOS’ preview option (by pressing spacebar on a file )
>
> I wonder if the problem is related to the colorspace that is written
> "unknown"  in "tv, bt709/bt709/unknown".
> If som can I just encode this into something else.  Or perhaps the TV
> doesn’t like bt709.
>

Just out of curiosity,could you try
ffmpeg -i input -c copy -map 0 output.mp4
 And see if that works with the TV?
I doubt that the lack of colour information would cause the TV to not play
it.
I'm assuming that it is MP4 as you haven't shown the full console output so
I don't know the container, but perhaps just rewrapping it in a new MP4 or
mkv container will do the trick.

Best,

Kieran



>
> e.g this file will play on the TV:
> Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1280x720 [SAR 1:1 DAR
> 16:9], 811 kb/s, 23.98 fps, 23.98 tbr, 96k tbn, 47.95 tbc (default)
>
>
> Best,
> Sophie
>
>
>
>
>
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: TV won't play file :

Sophie Loewenthal
Dear Kieran,

This solved the problem and the video plays.  
Thank you lots.

Regards,
Sophie





> On 16 Jan 2019, at 09:03, Kieran O Leary <[hidden email]> wrote:
>
> On Tue, 15 Jan 2019, 17:36 Sophie Loewenthal <[hidden email] wrote:
>
>> Hi,
>>
>> I have a video encoded like this ( that was sent to me ).
>>
>> ffprobe gave me the details:
>> Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709/bt709/unknown),
>> 1920x800, 2091 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc (default)
>>
>> It won’t play on my TV ( Philip 24PFS5303/12) which has played every x264
>> file I’ve thrown at it until it met this one. However this film plays fine
>> on VLC and MacOS’ preview option (by pressing spacebar on a file )
>>
>> I wonder if the problem is related to the colorspace that is written
>> "unknown"  in "tv, bt709/bt709/unknown".
>> If som can I just encode this into something else.  Or perhaps the TV
>> doesn’t like bt709.
>>
>
> Just out of curiosity,could you try
> ffmpeg -i input -c copy -map 0 output.mp4
> And see if that works with the TV?
> I doubt that the lack of colour information would cause the TV to not play
> it.
> I'm assuming that it is MP4 as you haven't shown the full console output so
> I don't know the container, but perhaps just rewrapping it in a new MP4 or
> mkv container will do the trick.
>
> Best,
>
> Kieran
>
>
>
>>
>> e.g this file will play on the TV:
>> Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1280x720 [SAR 1:1 DAR
>> 16:9], 811 kb/s, 23.98 fps, 23.98 tbr, 96k tbn, 47.95 tbc (default)
>>
>>
>> Best,
>> Sophie
>>
>>
>>
>>
>>
>> _______________________________________________
>> ffmpeg-user mailing list
>> [hidden email]
>> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>>
>> To unsubscribe, visit link above, or email
>> [hidden email] with subject "unsubscribe".
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".