Quiet ffmpeg while starting up

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Quiet ffmpeg while starting up

Haris Zukanovic
Hi everyone,

Is it possible to silence the ffmpeg errors and warnings while it is trying
to catch the first keyframe of a live input stream so it can begin the
decode the input?

In lack of (knowing about) a better solution of automatic monitoring of
ffmpeg errors, I am trying to setup a system which monitors ffmpeg error
output and records the different error lines through time. I would like to
eliminate the errors while the ffmpeg is starting up...

Example:

ffmpeg -y -hide_banner -threads auto -nostdin -loglevel warning
-analyzeduration 10000000 -probesize 10000000 -timeout 5000000 -i "udp://
239.2.1.1:1234?buffer_size=16777216" -c:v h264_qsv -c:a aac -f
mpegts "udp://239.100.100.30:6030?pkt_size=1316&buffer_size=16777216"

console output:
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:21 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:21 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:21 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:21 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:21 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:21 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:21 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:21 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:21 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:21 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:21 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:21 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:22 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:22 [mp2 @ 0x391c8c0] Header missing
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:22 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:22 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:22 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:22 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:22 [h264 @ 0x391b700] no frame!
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] SPS unavailable in
decode_picture_timing
2017/02/09 09:47:22 [h264 @ 0x391b700] non-existing PPS 0 referenced
2017/02/09 09:47:22 [h264 @ 0x391b700] decode_slice_header error
2017/02/09 09:47:22 [h264 @ 0x391b700] no frame!
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
2017/02/09 09:47:31 [h264 @ 0x393a0c0] co located POCs unavailable
2017/02/09 09:47:31 [h264 @ 0x39cfbe0] co located POCs unavailable
2017/02/09 09:47:31 [mp2 @ 0x39abf40] Header missing
2017/02/09 09:47:31 Error while decoding stream #0:1: Invalid data found
when processing input


From here ffmpeg transcodes without any more errors written out...
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Quiet ffmpeg while starting up

Carl Eugen Hoyos-2
2017-02-09 9:51 GMT+01:00 Haris Zukanovic <[hidden email]>:

> Is it possible to silence the ffmpeg errors and warnings while it is trying
> to catch the first keyframe of a live input stream so it can begin the
> decode the input?

No, patch probably welcome.

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".