No opencl header in fresh build install dir

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

No opencl header in fresh build install dir

Erwan Douaille
Hey everyone,

I Just subscribe to this mailing list because I would like to use ffmpeg
with opencl.  I´m working on windows 10 with mingw64. Build everything but
I don´t see any opencl related headers in my install dir. I don´t have any
opencl issue while configuring of compiling.

Steps :
 - downloaded ffmpeg 4.1 source and convert cuda opencl.lib to opencl.a for
mingw.
 - run ./configure --arch=x86_64 --enable-opencl --prefix=/mydir and
everything looks good.
 - Then mingw32-make.exe, I had some errors related to ar fixed by
modifying library.mak
 - Then make install.

Do you know if it´s normal ? How to ensure my build is "opencl ready" ?

Here is a pastebin with the full result of configure, make and make install
: https://pastebin.com/CkSqsEtM

Thanks for help :)
--
Best regards,

Douaille Erwan <[hidden email]>
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: No opencl header in fresh build install dir

Moritz Barsnick
On Thu, Nov 15, 2018 at 17:21:48 +0100, Erwan Douaille wrote:
> Do you know if it´s normal ? How to ensure my build is "opencl ready" ?

I would say that your output of ./configure already says so. You have
the hwaccell opencl, and various *_opencl filters.

You could also try:
$ /e/Downloads/ffmpeg/bin/ffmpeg -hwaccells | grep opencl
$ /e/Downloads/ffmpeg/bin/ffmpeg -filters | grep opencl
to see the actual result.

Cheers,
Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: No opencl header in fresh build install dir

Erwan Douaille
Thanks for your reply.

Indeed, opencl has been compiled and ffmpeg is "opencl ready" :

> erwand@MUSTAFAR MINGW64 /e/Downloads/ffmpeg/bin
> $ ./ffmpeg.exe -hwaccels | grep opencl
> ffmpeg version 4.1 Copyright (c) 2000-2018 the FFmpeg developers
>   built with gcc 7.3.0 (Rev2, Built by MSYS2 project)
>   configuration: --arch=x86_64 --enable-opencl
> --prefix=/e/Downloads/ffmpeg/
>   libavutil      56. 22.100 / 56. 22.100
>   libavcodec     58. 35.100 / 58. 35.100
>   libavformat    58. 20.100 / 58. 20.100
>   libavdevice    58.  5.100 / 58.  5.100
>   libavfilter     7. 40.101 /  7. 40.101
>   libswscale      5.  3.100 /  5.  3.100
>   libswresample   3.  3.100 /  3.  3.100
> opencl
> erwand@MUSTAFAR MINGW64 /e/Downloads/ffmpeg/bin
> $ ./ffmpeg.exe -filters | grep opencl
> ffmpeg version 4.1 Copyright (c) 2000-2018 the FFmpeg developers
>   built with gcc 7.3.0 (Rev2, Built by MSYS2 project)
>   configuration: --arch=x86_64 --enable-opencl
> --prefix=/e/Downloads/ffmpeg/
>   libavutil      56. 22.100 / 56. 22.100
>   libavcodec     58. 35.100 / 58. 35.100
>   libavformat    58. 20.100 / 58. 20.100
>   libavdevice    58.  5.100 / 58.  5.100
>   libavfilter     7. 40.101 /  7. 40.101
>   libswscale      5.  3.100 /  5.  3.100
>   libswresample   3.  3.100 /  3.  3.100
>  ... avgblur_opencl    V->V       Apply average blur filter
>  ... convolution_opencl V->V       Apply convolution mask to input video
>  ... dilation_opencl   V->V       Apply dilation effect
>  ... erosion_opencl    V->V       Apply erosion effect
>  ... overlay_opencl    VV->V      Overlay one video on top of another
>  ... prewitt_opencl    V->V       Apply prewitt operator
>  ... program_opencl    |->V       Filter video using an OpenCL program
>  ... roberts_opencl    V->V       Apply roberts operator
>  ... sobel_opencl      V->V       Apply sobel operator
>  ... tonemap_opencl    V->V       perform HDR to SDR conversion with
> tonemapping
>  ... unsharp_opencl    V->V       Apply unsharp mask to input video
>  ... openclsrc         |->V       Generate video using an OpenCL program


But I don´t understand why I don´t have any opencl headers in my include
dir using make install.
By example in include/libavutil I might have hwcontext_opencl.h but it
doesn´t exist. Is it normal ?


Le sam. 17 nov. 2018 à 10:47, Moritz Barsnick <[hidden email]> a écrit :

> On Thu, Nov 15, 2018 at 17:21:48 +0100, Erwan Douaille wrote:
> > Do you know if it´s normal ? How to ensure my build is "opencl ready" ?
>
> I would say that your output of ./configure already says so. You have
> the hwaccell opencl, and various *_opencl filters.
>
> You could also try:
> $ /e/Downloads/ffmpeg/bin/ffmpeg -hwaccells | grep opencl
> $ /e/Downloads/ffmpeg/bin/ffmpeg -filters | grep opencl
> to see the actual result.
>
> Cheers,
> Moritz
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".



--
Best regards,

Douaille Erwan <[hidden email]>
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: No opencl header in fresh build install dir

Carl Eugen Hoyos-2
2018-11-19 10:22 GMT+01:00, Erwan Douaille <[hidden email]>:

> Thanks for your reply.
>
> Indeed, opencl has been compiled and ffmpeg is "opencl ready" :
>
>> erwand@MUSTAFAR MINGW64 /e/Downloads/ffmpeg/bin
>> $ ./ffmpeg.exe -hwaccels | grep opencl
>> ffmpeg version 4.1 Copyright (c) 2000-2018 the FFmpeg developers
>>   built with gcc 7.3.0 (Rev2, Built by MSYS2 project)
>>   configuration: --arch=x86_64 --enable-opencl
>> --prefix=/e/Downloads/ffmpeg/
>>   libavutil      56. 22.100 / 56. 22.100
>>   libavcodec     58. 35.100 / 58. 35.100
>>   libavformat    58. 20.100 / 58. 20.100
>>   libavdevice    58.  5.100 / 58.  5.100
>>   libavfilter     7. 40.101 /  7. 40.101
>>   libswscale      5.  3.100 /  5.  3.100
>>   libswresample   3.  3.100 /  3.  3.100
>> opencl
>> erwand@MUSTAFAR MINGW64 /e/Downloads/ffmpeg/bin
>> $ ./ffmpeg.exe -filters | grep opencl
>> ffmpeg version 4.1 Copyright (c) 2000-2018 the FFmpeg developers
>>   built with gcc 7.3.0 (Rev2, Built by MSYS2 project)
>>   configuration: --arch=x86_64 --enable-opencl
>> --prefix=/e/Downloads/ffmpeg/
>>   libavutil      56. 22.100 / 56. 22.100
>>   libavcodec     58. 35.100 / 58. 35.100
>>   libavformat    58. 20.100 / 58. 20.100
>>   libavdevice    58.  5.100 / 58.  5.100
>>   libavfilter     7. 40.101 /  7. 40.101
>>   libswscale      5.  3.100 /  5.  3.100
>>   libswresample   3.  3.100 /  3.  3.100
>>  ... avgblur_opencl    V->V       Apply average blur filter
>>  ... convolution_opencl V->V       Apply convolution mask to input video
>>  ... dilation_opencl   V->V       Apply dilation effect
>>  ... erosion_opencl    V->V       Apply erosion effect
>>  ... overlay_opencl    VV->V      Overlay one video on top of another
>>  ... prewitt_opencl    V->V       Apply prewitt operator
>>  ... program_opencl    |->V       Filter video using an OpenCL program
>>  ... roberts_opencl    V->V       Apply roberts operator
>>  ... sobel_opencl      V->V       Apply sobel operator
>>  ... tonemap_opencl    V->V       perform HDR to SDR conversion with
>> tonemapping
>>  ... unsharp_opencl    V->V       Apply unsharp mask to input video
>>  ... openclsrc         |->V       Generate video using an OpenCL program
>
>
> But I don´t understand why I don´t have any opencl headers in my include
> dir using make install.
> By example in include/libavutil I might have hwcontext_opencl.h but it
> doesn´t exist. Is it normal ?

This header is supposed to be installed if you type "make install".

Please avoid top-posting here, Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: No opencl header in fresh build install dir

Erwan Douaille
Le lun. 19 nov. 2018 à 15:36, Carl Eugen Hoyos <[hidden email]> a
écrit :

> 2018-11-19 10:22 GMT+01:00, Erwan Douaille <[hidden email]>:
> > Thanks for your reply.
> >
> > Indeed, opencl has been compiled and ffmpeg is "opencl ready" :
> >
> >> erwand@MUSTAFAR MINGW64 /e/Downloads/ffmpeg/bin
> >> $ ./ffmpeg.exe -hwaccels | grep opencl
> >> ffmpeg version 4.1 Copyright (c) 2000-2018 the FFmpeg developers
> >>   built with gcc 7.3.0 (Rev2, Built by MSYS2 project)
> >>   configuration: --arch=x86_64 --enable-opencl
> >> --prefix=/e/Downloads/ffmpeg/
> >>   libavutil      56. 22.100 / 56. 22.100
> >>   libavcodec     58. 35.100 / 58. 35.100
> >>   libavformat    58. 20.100 / 58. 20.100
> >>   libavdevice    58.  5.100 / 58.  5.100
> >>   libavfilter     7. 40.101 /  7. 40.101
> >>   libswscale      5.  3.100 /  5.  3.100
> >>   libswresample   3.  3.100 /  3.  3.100
> >> opencl
> >> erwand@MUSTAFAR MINGW64 /e/Downloads/ffmpeg/bin
> >> $ ./ffmpeg.exe -filters | grep opencl
> >> ffmpeg version 4.1 Copyright (c) 2000-2018 the FFmpeg developers
> >>   built with gcc 7.3.0 (Rev2, Built by MSYS2 project)
> >>   configuration: --arch=x86_64 --enable-opencl
> >> --prefix=/e/Downloads/ffmpeg/
> >>   libavutil      56. 22.100 / 56. 22.100
> >>   libavcodec     58. 35.100 / 58. 35.100
> >>   libavformat    58. 20.100 / 58. 20.100
> >>   libavdevice    58.  5.100 / 58.  5.100
> >>   libavfilter     7. 40.101 /  7. 40.101
> >>   libswscale      5.  3.100 /  5.  3.100
> >>   libswresample   3.  3.100 /  3.  3.100
> >>  ... avgblur_opencl    V->V       Apply average blur filter
> >>  ... convolution_opencl V->V       Apply convolution mask to input video
> >>  ... dilation_opencl   V->V       Apply dilation effect
> >>  ... erosion_opencl    V->V       Apply erosion effect
> >>  ... overlay_opencl    VV->V      Overlay one video on top of another
> >>  ... prewitt_opencl    V->V       Apply prewitt operator
> >>  ... program_opencl    |->V       Filter video using an OpenCL program
> >>  ... roberts_opencl    V->V       Apply roberts operator
> >>  ... sobel_opencl      V->V       Apply sobel operator
> >>  ... tonemap_opencl    V->V       perform HDR to SDR conversion with
> >> tonemapping
> >>  ... unsharp_opencl    V->V       Apply unsharp mask to input video
> >>  ... openclsrc         |->V       Generate video using an OpenCL program
> >
> >
> > But I don´t understand why I don´t have any opencl headers in my include
> > dir using make install.
> > By example in include/libavutil I might have hwcontext_opencl.h but it
> > doesn´t exist. Is it normal ?
>
> This header is supposed to be installed if you type "make install".
>
> Please avoid top-posting here, Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".


Sorry for top-posting.
I agree, this header is supposed to be install when I type "make install",
but it´s not.

--
Best regards,

Douaille Erwan <[hidden email]>
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: No opencl header in fresh build install dir

Carl Eugen Hoyos-2
2018-11-19 15:40 GMT+01:00, Erwan Douaille <[hidden email]>:

> Le lun. 19 nov. 2018 à 15:36, Carl Eugen Hoyos <[hidden email]> a
> écrit :
>
>> 2018-11-19 10:22 GMT+01:00, Erwan Douaille <[hidden email]>:
>> > Thanks for your reply.
>> >
>> > Indeed, opencl has been compiled and ffmpeg is "opencl ready" :
>> >
>> >> erwand@MUSTAFAR MINGW64 /e/Downloads/ffmpeg/bin
>> >> $ ./ffmpeg.exe -hwaccels | grep opencl
>> >> ffmpeg version 4.1 Copyright (c) 2000-2018 the FFmpeg developers
>> >>   built with gcc 7.3.0 (Rev2, Built by MSYS2 project)
>> >>   configuration: --arch=x86_64 --enable-opencl
>> >> --prefix=/e/Downloads/ffmpeg/
>> >>   libavutil      56. 22.100 / 56. 22.100
>> >>   libavcodec     58. 35.100 / 58. 35.100
>> >>   libavformat    58. 20.100 / 58. 20.100
>> >>   libavdevice    58.  5.100 / 58.  5.100
>> >>   libavfilter     7. 40.101 /  7. 40.101
>> >>   libswscale      5.  3.100 /  5.  3.100
>> >>   libswresample   3.  3.100 /  3.  3.100
>> >> opencl
>> >> erwand@MUSTAFAR MINGW64 /e/Downloads/ffmpeg/bin
>> >> $ ./ffmpeg.exe -filters | grep opencl
>> >> ffmpeg version 4.1 Copyright (c) 2000-2018 the FFmpeg developers
>> >>   built with gcc 7.3.0 (Rev2, Built by MSYS2 project)
>> >>   configuration: --arch=x86_64 --enable-opencl
>> >> --prefix=/e/Downloads/ffmpeg/
>> >>   libavutil      56. 22.100 / 56. 22.100
>> >>   libavcodec     58. 35.100 / 58. 35.100
>> >>   libavformat    58. 20.100 / 58. 20.100
>> >>   libavdevice    58.  5.100 / 58.  5.100
>> >>   libavfilter     7. 40.101 /  7. 40.101
>> >>   libswscale      5.  3.100 /  5.  3.100
>> >>   libswresample   3.  3.100 /  3.  3.100
>> >>  ... avgblur_opencl    V->V       Apply average blur filter
>> >>  ... convolution_opencl V->V       Apply convolution mask to input
>> >> video
>> >>  ... dilation_opencl   V->V       Apply dilation effect
>> >>  ... erosion_opencl    V->V       Apply erosion effect
>> >>  ... overlay_opencl    VV->V      Overlay one video on top of another
>> >>  ... prewitt_opencl    V->V       Apply prewitt operator
>> >>  ... program_opencl    |->V       Filter video using an OpenCL program
>> >>  ... roberts_opencl    V->V       Apply roberts operator
>> >>  ... sobel_opencl      V->V       Apply sobel operator
>> >>  ... tonemap_opencl    V->V       perform HDR to SDR conversion with
>> >> tonemapping
>> >>  ... unsharp_opencl    V->V       Apply unsharp mask to input video
>> >>  ... openclsrc         |->V       Generate video using an OpenCL
>> >> program
>> >
>> >
>> > But I don´t understand why I don´t have any opencl headers in my include
>> > dir using make install.
>> > By example in include/libavutil I might have hwcontext_opencl.h but it
>> > doesn´t exist. Is it normal ?
>>
>> This header is supposed to be installed if you type "make install".

> I agree, this header is supposed to be install when I type "make install",
> but it´s not.

Sorry, you are right, the header is not installed, it seems to be missing
from HEADERS in libavutil/Makefile where the other hwaccel headers
are listed.

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: No opencl header in fresh build install dir

Erwan Douaille
Le lun. 19 nov. 2018 à 16:07, Carl Eugen Hoyos <[hidden email]> a
écrit :

> 2018-11-19 15:40 GMT+01:00, Erwan Douaille <[hidden email]>:
> > Le lun. 19 nov. 2018 à 15:36, Carl Eugen Hoyos <[hidden email]> a
> > écrit :
> >
> >> 2018-11-19 10:22 GMT+01:00, Erwan Douaille <[hidden email]>:
> >> > Thanks for your reply.
> >> >
> >> > Indeed, opencl has been compiled and ffmpeg is "opencl ready" :
> >> >
> >> >> erwand@MUSTAFAR MINGW64 /e/Downloads/ffmpeg/bin
> >> >> $ ./ffmpeg.exe -hwaccels | grep opencl
> >> >> ffmpeg version 4.1 Copyright (c) 2000-2018 the FFmpeg developers
> >> >>   built with gcc 7.3.0 (Rev2, Built by MSYS2 project)
> >> >>   configuration: --arch=x86_64 --enable-opencl
> >> >> --prefix=/e/Downloads/ffmpeg/
> >> >>   libavutil      56. 22.100 / 56. 22.100
> >> >>   libavcodec     58. 35.100 / 58. 35.100
> >> >>   libavformat    58. 20.100 / 58. 20.100
> >> >>   libavdevice    58.  5.100 / 58.  5.100
> >> >>   libavfilter     7. 40.101 /  7. 40.101
> >> >>   libswscale      5.  3.100 /  5.  3.100
> >> >>   libswresample   3.  3.100 /  3.  3.100
> >> >> opencl
> >> >> erwand@MUSTAFAR MINGW64 /e/Downloads/ffmpeg/bin
> >> >> $ ./ffmpeg.exe -filters | grep opencl
> >> >> ffmpeg version 4.1 Copyright (c) 2000-2018 the FFmpeg developers
> >> >>   built with gcc 7.3.0 (Rev2, Built by MSYS2 project)
> >> >>   configuration: --arch=x86_64 --enable-opencl
> >> >> --prefix=/e/Downloads/ffmpeg/
> >> >>   libavutil      56. 22.100 / 56. 22.100
> >> >>   libavcodec     58. 35.100 / 58. 35.100
> >> >>   libavformat    58. 20.100 / 58. 20.100
> >> >>   libavdevice    58.  5.100 / 58.  5.100
> >> >>   libavfilter     7. 40.101 /  7. 40.101
> >> >>   libswscale      5.  3.100 /  5.  3.100
> >> >>   libswresample   3.  3.100 /  3.  3.100
> >> >>  ... avgblur_opencl    V->V       Apply average blur filter
> >> >>  ... convolution_opencl V->V       Apply convolution mask to input
> >> >> video
> >> >>  ... dilation_opencl   V->V       Apply dilation effect
> >> >>  ... erosion_opencl    V->V       Apply erosion effect
> >> >>  ... overlay_opencl    VV->V      Overlay one video on top of another
> >> >>  ... prewitt_opencl    V->V       Apply prewitt operator
> >> >>  ... program_opencl    |->V       Filter video using an OpenCL
> program
> >> >>  ... roberts_opencl    V->V       Apply roberts operator
> >> >>  ... sobel_opencl      V->V       Apply sobel operator
> >> >>  ... tonemap_opencl    V->V       perform HDR to SDR conversion with
> >> >> tonemapping
> >> >>  ... unsharp_opencl    V->V       Apply unsharp mask to input video
> >> >>  ... openclsrc         |->V       Generate video using an OpenCL
> >> >> program
> >> >
> >> >
> >> > But I don´t understand why I don´t have any opencl headers in my
> include
> >> > dir using make install.
> >> > By example in include/libavutil I might have hwcontext_opencl.h but it
> >> > doesn´t exist. Is it normal ?
> >>
> >> This header is supposed to be installed if you type "make install".
>
> > I agree, this header is supposed to be install when I type "make
> install",
> > but it´s not.
>
> Sorry, you are right, the header is not installed, it seems to be missing
> from HEADERS in libavutil/Makefile where the other hwaccel headers
> are listed.
>
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".


Is it a known issue ? Am I doing something wrong ?
I quickly check the makefile but I don´t see why install-headers command is
wrong ...

--
Best regards,

Douaille Erwan <[hidden email]>
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".