Merging apad and overlay filters in complex filter

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Merging apad and overlay filters in complex filter

C Colutions
Hi.

I was trying to attach audio to a video which adding an overlay image to
it. Im using the following command:

[/data/user/0/com.photovideomaker.videoslideshowmaker.videoeditor/files/ffmpeg,
-y, -r, 11.0, -f, image2, -i,
/storage/emulated/0/TestDirectory/TempImages/img%03d.jpg, -i,
/storage/emulated/0/TestDirectory/introSound.mp3, -i,
/storage/emulated/0/TestDirectory/TempImagesNatural.png, -filter_complex,
[audio]apad[audio];overlay=0:0, -shortest, -crf, 20, -map, [audio], -c:v,
libx264, -preset, ultrafast, -pix_fmt, yuv420p, -ac, 2,
/storage/emulated/0/TestDirectory/finalOutPut.mp4]

but its not working. Im getting the error

Output with label 'audio' does not exist in any defined filter graph, or
was already used.

Thank you for the help.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Merging apad and overlay filters in complex filter

C Colutions
while*


On Mon, Mar 5, 2018 at 3:44 PM, C Colutions <[hidden email]> wrote:

> Hi.
>
> I was trying to attach audio to a video which adding an overlay image to
> it. Im using the following command:
>
> [/data/user/0/com.photovideomaker.videoslideshowmaker.videoeditor/files/ffmpeg,
> -y, -r, 11.0, -f, image2, -i, /storage/emulated/0/
> TestDirectory/TempImages/img%03d.jpg, -i, /storage/emulated/0/TestDirectory/introSound.mp3,
> -i, /storage/emulated/0/TestDirectory/TempImagesNatural.png,
> -filter_complex, [audio]apad[audio];overlay=0:0, -shortest, -crf, 20,
> -map, [audio], -c:v, libx264, -preset, ultrafast, -pix_fmt, yuv420p, -ac,
> 2, /storage/emulated/0/TestDirectory/finalOutPut.mp4]
>
> but its not working. Im getting the error
>
> Output with label 'audio' does not exist in any defined filter graph, or
> was already used.
>
> Thank you for the help.
>
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Merging apad and overlay filters in complex filter

Gyan Doshi
In reply to this post by C Colutions


On 3/5/2018 4:14 PM, C Colutions wrote:

> [audio]apad[audio];

should be

     [1:a]apad[audio];

You're sending an input file, specifically the (first) audio stream of
the 2nd input file, to the filter, so 1:a is the designation to identify it.


Regards,
Gyan
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".