Input Buffer ovverun with Decklink 8K Pro and Nvenc

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Input Buffer ovverun with Decklink 8K Pro and Nvenc

FFmpeg-users mailing list
Hi

I'm trying to encode a live 8K footage from a decklink 8k p ro card using
nvenc hevc codec but i get  Decklink input buffer overrun! always. I have
tested outputting to -f null /dev/null but i get the same
I tried with the -thread_queue_size option too without luck.
My 2 pci ports are 16X each on a 32 lines pci express 3.0 mother board.

My test command :

ffmpeg -thread_queue_size 5096 -f decklink -r 30000/1001 -rtbufsize 200M -i
'SDI1' -vsync 1 -c:a aac -b:a 128k -c:v hevc_nvenc -b:v 50M -preset fast
-profile main -level auto -f null /dev/null

Any ideas on how to troubleshoot this ?



--
Sent from: http://www.ffmpeg-archive.org/
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Input Buffer ovverun with Decklink 8K Pro and Nvenc

Carl Zwanzig
On 8/5/2020 10:10 AM, jroch via ffmpeg-user wrote:
> Any ideas on how to troubleshoot this ?

First- post the complete command output.

Second- check to see that your system has enough resources (cpu/mem/etc), in
general, to make this work. (Try using the BMD MediaExpress program to capture.)

Third- try capture w/o encoding and send that to /dev/null. Does it fail?

(and last- remember not to top-post on this list)

Later,

z!
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Input Buffer ovverun with Decklink 8K Pro and Nvenc

FFmpeg-users mailing list
Hi,

Thanks for answer

I figured out i was not setting pixel format. This helped and i'm now
encoding at real time.

It was failing in every mode without that param

About top post, sorry for that, i don't even think i know what this is
about.

J



--
Sent from: http://www.ffmpeg-archive.org/
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Input Buffer ovverun with Decklink 8K Pro and Nvenc

Carl Zwanzig
On 8/5/2020 12:23 PM, jroch via ffmpeg-user wrote:
> I figured out i was not setting pixel format.

And I should have noticed that- BMD boards are famously finicky about the
parameters.

> About top post, sorry for that, i don't even think i know what this is
> about.

Use google?

z!
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Input Buffer ovverun with Decklink 8K Pro and Nvenc

FFmpeg-users mailing list
Seems more complicate than just BMD board.

Coz BMD supports stuff but nvenc supports other...




--
Sent from: http://www.ffmpeg-archive.org/
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".