Immediate crash on windows.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Immediate crash on windows.

Sam Holder
Hi.

I have downloaded the static build for windows 64 (and 32 to test that as well) ffmpeg-20200628-4cfcfb3-win64-static and extracted ffmpeg.exe. If I start a powershell window and try and run ffmpeg.exe with no params it immediately crashes producing no output. Same for 32bit version.

I get a windows error reporting report which contains the following (not sure if this is from 64 bit or 32 bit run):

Version=1
EventType=APPCRASH
EventTime=132381670300552616
ReportType=2
Consent=1
ReportIdentifier=be62a75d-bc60-11ea-8264-005056b56903
IntegratorReportIdentifier=be62a75c-bc60-11ea-8264-005056b56903
WOW64=1
NsAppName=ffmpeg.exe
Response.type=4
Sig[0].Name=Application Name
Sig[0].Value=ffmpeg.exe
Sig[1].Name=Application Version
Sig[1].Value=0.0.0.0
Sig[2].Name=Application Timestamp
Sig[2].Value=00000000
Sig[3].Name=Fault Module Name
Sig[3].Value=MFPlat.DLL
Sig[4].Name=Fault Module Version
Sig[4].Value=6.3.9600.19678
Sig[5].Name=Fault Module Timestamp
Sig[5].Value=5e82c0f7
Sig[6].Name=Exception Code
Sig[6].Value=c0000135
Sig[7].Name=Exception Offset
Sig[7].Value=0009d452
DynamicSig[1].Name=OS Version
DynamicSig[1].Value=6.3.9600.2.0.0.272.7
DynamicSig[2].Name=Locale ID
DynamicSig[2].Value=1033
DynamicSig[22].Name=Additional Information 1
DynamicSig[22].Value=1abe
DynamicSig[23].Name=Additional Information 2
DynamicSig[23].Value=1abee00edb3fc1158f9ad6f44f0f6be8
DynamicSig[24].Name=Additional Information 3
DynamicSig[24].Value=1abe
DynamicSig[25].Name=Additional Information 4
DynamicSig[25].Value=1abee00edb3fc1158f9ad6f44f0f6be8
UI[2]=C:\FFMPEG\ffmpeg.exe
UI[3]=ffmpeg.exe has stopped working
UI[4]=Windows can check online for a solution to the problem.
UI[5]=Check online for a solution and close the program
UI[6]=Check online for a solution later and close the program
UI[7]=Close the program
LoadedModule[0]=C:\FFMPEG\ffmpeg.exe
LoadedModule[1]=C:\Windows\SYSTEM32\ntdll.dll
LoadedModule[2]=C:\Windows\SYSTEM32\KERNEL32.DLL
LoadedModule[3]=C:\Windows\SYSTEM32\KERNELBASE.dll
LoadedModule[4]=C:\Windows\SYSTEM32\ADVAPI32.dll
LoadedModule[5]=C:\Windows\SYSTEM32\bcrypt.dll
LoadedModule[6]=C:\Windows\SYSTEM32\CRYPT32.dll
LoadedModule[7]=C:\Windows\SYSTEM32\GDI32.dll
LoadedModule[8]=C:\Windows\SYSTEM32\IMM32.DLL
FriendlyEventName=Stopped working
ConsentKey=APPCRASH
AppName=ffmpeg.exe
AppPath=C:\FFMPEG\ffmpeg.exe
NsPartner=windows
NsGroup=windows8
ApplicationIdentity=AF2C11C258579EB1F0D6179D3393D5EB

The files work perfectly on my dev machine. This is running on a VM.

Any ideas what might cause this behavior, or how best to proceed with troubleshooting?

Thanks

Sam
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Immediate crash on windows.

Carl Zwanzig
On 7/2/2020 6:41 AM, Sam Holder wrote:
> Any ideas ... how best to proceed with troubleshooting?

It's _always_ best to include the entire command line and output when asking
for help here, even it there's almost no output.

Have you tried that build on another version of windoze?
It works correctly outside of a VM? (that's not entirely clear)
..which VM system?
..tried some other static builds?

Need more information about the environment and what you've tried.

Later,

z!
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Immediate crash on windows.

Sam Holder
Thanks. I’ll try some other builds. I did include the entire command line and output. I used:

.\ffmpeg.exe

at the command line.

and there was no output, just an immediate crash and a WER popup saying the ffmpeg.exe had crashed.

I’ve tried same build on my local machine and it works fine.

I’ve just tried 4.2.1 and that seems to work ok (at least it doesn’t immediately die and shows the expected output), so I’ll just use that.

From: ffmpeg-user <[hidden email]> On Behalf Of Carl Zwanzig
Sent: 02 July 2020 17:26
To: [hidden email]
Subject: Re: [FFmpeg-user] Immediate crash on windows.

This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

On 7/2/2020 6:41 AM, Sam Holder wrote:
> Any ideas ... how best to proceed with troubleshooting?

It's _always_ best to include the entire command line and output when asking
for help here, even it there's almost no output.

Have you tried that build on another version of windoze?
It works correctly outside of a VM? (that's not entirely clear)
..which VM system?
..tried some other static builds?

Need more information about the environment and what you've tried.

Later,

z!
_______________________________________________
ffmpeg-user mailing list
[hidden email]<mailto:[hidden email]>
https://ffmpeg.org/mailman/listinfo/ffmpeg-user<https://ffmpeg.org/mailman/listinfo/ffmpeg-user>

To unsubscribe, visit link above, or email
[hidden email]<mailto:[hidden email]> with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".