Fwd: i am having a technical problem, please help

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: i am having a technical problem, please help

Antonio Hanna
---------- Forwarded message ----------
From: Antonio Hanna <[hidden email]>
Date: Thu, Apr 5, 2018 at 6:57 PM
Subject: i am having a technical problem, please help
To: FFVCL Support <[hidden email]>


hello, i am writing a multichannel iptv for a company using your component,
i have 6 ffencoders on a form ... totally seperated one from another

when i run 4 of them together loading a 720P and something a 1080p videos
the last encoder starts affecting others.. i noticed on fflogger these
error messages

what is going on ??????????
please help.

command used in the encoders is somthing basic like this :
ffmpeg -re -i input.mp4 -filter_complex "[0:v]scale=1280:720[scaled]"  -map
"[scaled]" -map 0:a -b:v 1200k -codec:v libx264 -codec:a copy -f mpegts
udp://127.0.0.1:1234?pkt_size=1316

i am using the filter complex because sometimes i have to add an overlay
also.
but it is a simple command .. please help

2324:16:47:53.807 [00000914] [h264 @ 070BC580] [Error] thread_get_buffer()
failed
2324:16:47:53.807 [00000914] [h264 @ 070BC580] [Error] get_buffer() failed
7216:16:47:53.237 [00001C30] [TFFEncoder.encoder1] [Error] Error
initializing output stream 0:0 -- Error while opening encoder for output
stream #0:0 (Video) - maybe incorrect parameters such as bit_rate, rate,
width or height. Please check error log message(reported by FFLogger) to
find out more detail information.
8052:16:47:52.543 [00001F74] [TFFEncoder.encoder1] [Error] Error
initializing output stream 0:0 -- Error while opening encoder for output
stream #0:0 (Video) - maybe incorrect parameters such as bit_rate, rate,
width or height. Please check error log message(reported by FFLogger) to
find out more detail information.
6852:16:47:52.371 [00001AC4] [TFFEncoder.encoder4] [Error] Error while
decoding stream #0:0: Invalid data found when processing input
6852:16:47:52.369 [00001AC4] [TFFEncoder.encoder4] [Error] Error while
decoding stream #0:0: Invalid data found when processing input
7660:16:47:51.784 [00001DEC] [h264 @ 3AC18A20] [Error] no frame!
7660:16:47:51.784 [00001DEC] [h264 @ 3AC18A20] [Error] decode_slice_header
error
7660:16:47:51.784 [00001DEC] [h264 @ 3AC18A20] [Error] thread_get_buffer()
failed
7660:16:47:51.784 [00001DEC] [h264 @ 3AC18A20] [Error] get_buffer() failed
7656:16:47:51.726 [00001DE8] [h264 @ 3AC185E0] [Error] no frame!
7656:16:47:51.726 [00001DE8] [h264 @ 3AC185E0] [Error] decode_slice_header
error
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: i am having a technical problem, please help

Brainiarc7
This is not the place to post such emails.

For one, you're launching FFmpeg through a wrapper, and two, how FFmpeg was
built on your platform is not known.

Run the same directly via FFmpeg, and post your results here, including the
build configuration of the FFmpeg binary you're using.

On Fri, Apr 6, 2018, 16:31 Antonio Hanna <[hidden email]> wrote:

> ---------- Forwarded message ----------
> From: Antonio Hanna <[hidden email]>
> Date: Thu, Apr 5, 2018 at 6:57 PM
> Subject: i am having a technical problem, please help
> To: FFVCL Support <[hidden email]>
>
>
> hello, i am writing a multichannel iptv for a company using your component,
> i have 6 ffencoders on a form ... totally seperated one from another
>
> when i run 4 of them together loading a 720P and something a 1080p videos
> the last encoder starts affecting others.. i noticed on fflogger these
> error messages
>
> what is going on ??????????
> please help.
>
> command used in the encoders is somthing basic like this :
> ffmpeg -re -i input.mp4 -filter_complex "[0:v]scale=1280:720[scaled]"  -map
> "[scaled]" -map 0:a -b:v 1200k -codec:v libx264 -codec:a copy -f mpegts
> udp://127.0.0.1:1234?pkt_size=1316
>
> i am using the filter complex because sometimes i have to add an overlay
> also.
> but it is a simple command .. please help
>
> 2324:16:47:53.807 [00000914] [h264 @ 070BC580] [Error] thread_get_buffer()
> failed
> 2324:16:47:53.807 [00000914] [h264 @ 070BC580] [Error] get_buffer() failed
> 7216:16:47:53.237 [00001C30] [TFFEncoder.encoder1] [Error] Error
> initializing output stream 0:0 -- Error while opening encoder for output
> stream #0:0 (Video) - maybe incorrect parameters such as bit_rate, rate,
> width or height. Please check error log message(reported by FFLogger) to
> find out more detail information.
> 8052:16:47:52.543 [00001F74] [TFFEncoder.encoder1] [Error] Error
> initializing output stream 0:0 -- Error while opening encoder for output
> stream #0:0 (Video) - maybe incorrect parameters such as bit_rate, rate,
> width or height. Please check error log message(reported by FFLogger) to
> find out more detail information.
> 6852:16:47:52.371 [00001AC4] [TFFEncoder.encoder4] [Error] Error while
> decoding stream #0:0: Invalid data found when processing input
> 6852:16:47:52.369 [00001AC4] [TFFEncoder.encoder4] [Error] Error while
> decoding stream #0:0: Invalid data found when processing input
> 7660:16:47:51.784 [00001DEC] [h264 @ 3AC18A20] [Error] no frame!
> 7660:16:47:51.784 [00001DEC] [h264 @ 3AC18A20] [Error] decode_slice_header
> error
> 7660:16:47:51.784 [00001DEC] [h264 @ 3AC18A20] [Error] thread_get_buffer()
> failed
> 7660:16:47:51.784 [00001DEC] [h264 @ 3AC18A20] [Error] get_buffer() failed
> 7656:16:47:51.726 [00001DE8] [h264 @ 3AC185E0] [Error] no frame!
> 7656:16:47:51.726 [00001DE8] [h264 @ 3AC185E0] [Error] decode_slice_header
> error
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".