Ffplay Option pixel_format not found

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Ffplay Option pixel_format not found

kgbook kgbook
Hi all,
    I play RTSP stream with ffplay, then complain that
> [swscaler @ 0x7f94a834e400] deprecated pixel format used, make sure you did set range correctly

   After that, I try with the command `ffplay rtsp://a:a@10.10.1.142/stream <rtsp://a:a@10.10.1.142/stream> -pix_fmt yuvj422p`, error log:
> Option -pix_fmt is deprecated, use -pixel_format.

   Following the tips, it’s still not ok.
> Option pixel_format not found.

  What should I do to solve the issue?
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Ffplay Option pixel_format not found

Moritz Barsnick
On Thu, Feb 28, 2019 at 20:58:01 +0800, kgbook kgbook wrote:
>     I play RTSP stream with ffplay, then complain that
> > [swscaler @ 0x7f94a834e400] deprecated pixel format used, make sure you did set range correctly

To understand the circumstances, we need to see the *complete* console
output.

Actually, it's just a warning, and there's nothing you need to do, as
far as I understand.

>    After that, I try with the command `ffplay rtsp://a:a@10.10.1.142/stream <rtsp://a:a@10.10.1.142/stream> -pix_fmt yuvj422p`, error log:
> > Option -pix_fmt is deprecated, use -pixel_format.

Peculiar, considering the replacement doesn't work.

Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Ffplay Option pixel_format not found

kgbook kgbook
Hi Moritz,
        I run ffplay on macOS,  4.1.1 version.

    Log:
> kang:~ kang$ ffplay rtsp://a:a@10.10.1.145/stream
ffplay version 4.1.1 Copyright (c) 2003-2019 the FFmpeg developers
  built with Apple LLVM version 10.0.0 (clang-1000.11.45.5)
  configuration: --prefix=/usr/local/Cellar/ffmpeg/4.1.1 --enable-shared --enable-pthreads --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags='-I/Library/Java/JavaVirtualMachines/openjdk-11.0.2.jdk/Contents/Home/include -I/Library/Java/JavaVirtualMachines/openjdk-11.0.2.jdk/Contents/Home/include/darwin' --host-ldflags= --enable-ffplay --enable-gnutls --enable-gpl --enable-libaom --enable-libbluray --enable-libmp3lame --enable-libopus --enable-librubberband --enable-libsnappy --enable-libtesseract --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libxvid --enable-lzma --enable-libfontconfig --enable-libfreetype --enable-frei0r --enable-libass --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librtmp --enable-libspeex --enable-videotoolbox --disable-libjack --disable-indev=jack --enable-libaom --enable-libsoxr
  libavutil      56. 22.100 / 56. 22.100
  libavcodec     58. 35.100 / 58. 35.100
  libavformat    58. 20.100 / 58. 20.100
  libavdevice    58.  5.100 / 58.  5.100
  libavfilter     7. 40.101 /  7. 40.101
  libavresample   4.  0.  0 /  4.  0.  0
  libswscale      5.  3.100 /  5.  3.100
  libswresample   3.  3.100 /  3.  3.100
  libpostproc    55.  3.100 / 55.  3.100
[hevc @ 0x7ff771037600] PPS id out of range: 00KB sq=    0B f=0/0  
    Last message repeated 1 times
[hevc @ 0x7ff771037600] Error parsing NAL unit #0.
[hevc @ 0x7ff771037600] PPS id out of range: 0
    Last message repeated 1 times
[hevc @ 0x7ff771037600] Error parsing NAL unit #0.
Input #0, rtsp, from 'rtsp://a:a@10.10.1.145/stream':    0B f=0/0  
  Metadata:
    title           : Session streamed by "RTSPServer"
    comment         : stream
  Duration: N/A, start: 47721.892200, bitrate: N/A
    Stream #0:0: Video: hevc (Main), yuvj420p(pc, bt709), 1920x1080, 29.97 tbr, 90k tbn, 90k tbc
[hevc @ 0x7ff771053200] Could not find ref with POC 4
[swscaler @ 0x7ff7719ad600] deprecated pixel format used, make sure you did set range correctly

> 在 2019年2月28日,22:06,Moritz Barsnick <[hidden email]> 写道:
>
> On Thu, Feb 28, 2019 at 20:58:01 +0800, kgbook kgbook wrote:
>>    I play RTSP stream with ffplay, then complain that
>>> [swscaler @ 0x7f94a834e400] deprecated pixel format used, make sure you did set range correctly
>
> To understand the circumstances, we need to see the *complete* console
> output.
>
> Actually, it's just a warning, and there's nothing you need to do, as
> far as I understand.
>
>>   After that, I try with the command `ffplay rtsp://a:a@10.10.1.142/stream <rtsp://a:a@10.10.1.142/stream> -pix_fmt yuvj422p`, error log:
>>> Option -pix_fmt is deprecated, use -pixel_format.
>
> Peculiar, considering the replacement doesn't work.
>
> Moritz
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> https://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".

_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".