FPS drop when transcode 3 Full HD channel to SD

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

FPS drop when transcode 3 Full HD channel to SD

Hendrik Karsimin
Hi,
I've been trying to transcode the Full HD Channel (1920x1080) to SD
(720x576).

When I transcode 1 channel, the resulting video is no problem. So are when
transcode 2 channel.
But when the 3rd channel I tried to transcode start. the FPS start to drop
on all the channel I transcoding.

I'm not sure if it's a computer hardware limitation or the software
limitation.
But I have tried to change some parameter of ffmpeg, and settle on the last
ffmpeg configuration I use now.

Attached is the information I collect on the PC I use to transcode.

The Ubuntu Version I use is Ubuntu 14.04.5

#lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.5 LTS
Release:        14.04
Codename:       trusty

#uname -a
Linux Compaq 3.13.0-119-generic #166-Ubuntu SMP Wed May 3 12:18:55 UTC 2017
x86_64 x86_64 x86_64 GNU/Linux

Need advice to resolve this problem.



*Thanks & regards,*
Hendrik

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".

cpuinfo.txt (2K) Download Attachment
ffmpeg command.txt (1K) Download Attachment
top command.txt (14K) Download Attachment
when 1 ffmpeg running.zip (10K) Download Attachment
when 2 ffmpeg running.zip (17K) Download Attachment
when 3 ffmpeg running.zip (30K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FPS drop when transcode 3 Full HD channel to SD

alexdjca
How many CPUs / cores are you using?
Transcoding FullHD in SD, without using any hardware accelleration for more than two channels seems a quite huge load.
It can be simply your CPU cannot go fast enough

-----Original Message-----
From: ffmpeg-user [mailto:[hidden email]] On Behalf Of Hendrik Karsimin
Sent: 13 June 2017 14:03
To: [hidden email]
Subject: [FFmpeg-user] FPS drop when transcode 3 Full HD channel to SD

Warning: This message has had one or more attachments removed
Warning: (encode_cna.out.log, encode_okto.out.log, when 3 ffmpeg running.zip, encode_suria.out.log).
Warning: Please read the "vision247.com-Attachment-Warning.txt" attachment(s) for more information.

Hi,
I've been trying to transcode the Full HD Channel (1920x1080) to SD (720x576).

When I transcode 1 channel, the resulting video is no problem. So are when transcode 2 channel.
But when the 3rd channel I tried to transcode start. the FPS start to drop on all the channel I transcoding.

I'm not sure if it's a computer hardware limitation or the software limitation.
But I have tried to change some parameter of ffmpeg, and settle on the last ffmpeg configuration I use now.

Attached is the information I collect on the PC I use to transcode.

The Ubuntu Version I use is Ubuntu 14.04.5

#lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.5 LTS
Release:        14.04
Codename:       trusty

#uname -a
Linux Compaq 3.13.0-119-generic #166-Ubuntu SMP Wed May 3 12:18:55 UTC 2017
x86_64 x86_64 x86_64 GNU/Linux

Need advice to resolve this problem.



*Thanks & regards,*
Hendrik
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FPS drop when transcode 3 Full HD channel to SD

chronek
In reply to this post by Hendrik Karsimin
Hi,

You have dual core cpu, you show that with 1 ffmpeg it use 77% of one
core (so like ~40% of cpu), with 2 ffmpeg it use 90% of first and second
core (so like 90% of cpu), with 2 ffmpeg it uses almost all cpu, so no
wonder that with 3 ffmpeg it slowing down because it need 1,5 more cpu,  
you would need have at least 40% better cpu to run all 3 ffmpeg... With
3 ffmpeg it using all cpu, some slowed to take 50% of core when it
needed 77-90%...

Did you compile ffmpeg by self? Some good gcc flags can speed up ffmpeg...


chronek

W dniu 2017-06-13 o 15:03, Hendrik Karsimin pisze:

> Hi,
> I've been trying to transcode the Full HD Channel (1920x1080) to SD
> (720x576).
>
> When I transcode 1 channel, the resulting video is no problem. So are when
> transcode 2 channel.
> But when the 3rd channel I tried to transcode start. the FPS start to drop
> on all the channel I transcoding.
>
> I'm not sure if it's a computer hardware limitation or the software
> limitation.
> But I have tried to change some parameter of ffmpeg, and settle on the last
> ffmpeg configuration I use now.
>
> Attached is the information I collect on the PC I use to transcode.
>
> The Ubuntu Version I use is Ubuntu 14.04.5
>
> #lsb_release -a
> No LSB modules are available.
> Distributor ID: Ubuntu
> Description:    Ubuntu 14.04.5 LTS
> Release:        14.04
> Codename:       trusty
>
> #uname -a
> Linux Compaq 3.13.0-119-generic #166-Ubuntu SMP Wed May 3 12:18:55 UTC 2017
> x86_64 x86_64 x86_64 GNU/Linux
>
> Need advice to resolve this problem.
>
>
>
> *Thanks & regards,*
> Hendrik
>
>
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Loading...