FFmpeg: Video gets corrupted.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

FFmpeg: Video gets corrupted.

Ranga Rajan
Hello,

Any suggestion will be a great help for the below detailed problem:

I am using ffmpeg to record an ip camera stream.
The camera produces variable frame rate stream.
I am using an SDP file to capture the stream, and save it in files
containing data of of 5 mins.
OS used is centOS 6.6
FFmpeg version used: 4.0.2
Video stream: h264
Audio: AAC

Following is the command used:

/usr/bin/ffmpeg -protocol_whitelist file,udp,rtp -y -loglevel quiet -vsync
vfr -i <path_to_SDPfile> -fflags +genpts+igndts+discardcorrupt
-reorder_queue_size
100 -c copy -bsf:a aac_adtstoasc -f ssegment segment_format_options
movflags=+frag_keyframe+empty_moov+separate_moof+disable_chpl+default_base_moof
-reference_stream
v:0 -segment_time 00:05:00  -segment_time_delta 0.1
-segment_atclocktime 1 -reset_timestamps
1 -strftime 1 Stream_%y%m%d_%H%M.mp4


It produces videos with name "Stream_YYMMdd_HHMM.mp4" of each with duration
5 minutes.

But sometimes the videos becomes more than an hour duration and also when
played with ffplay show fast forward behavior and ends in few minutes.


Thanks and Regards,

Rangarajan
_______________________________________________
ffmpeg-user mailing list
[hidden email]
https://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".