FFMPEG libx264 not found error

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

FFMPEG libx264 not found error

Niket Joshi
Hi Team,



I am trying to setup ffmpeg enabling libx264 support but I get following
error.



./configure --disable-x86asm --enable-libx264 --enable-gpl

*ERROR: libx264 not found*



If you think configure made a mistake, make sure you are using the latest

version from Git.  If the latest version fails, report the problem to the

[hidden email] mailing list or IRC #ffmpeg on irc.freenode.net.

Include the log file "ffbuild/config.log" produced by configure as this
will help

solve the problem.

[root@ip-172-31-8-120 ffmpeg]# pwd

/usr/local/bin/ffmpeg

[root@ip-172-31-8-120 ffmpeg]# !env

env | grep PATH

PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin



I have cloned latest ffmpeg using https://www.ffmpeg.org/download.html.



I have /usr/local/bin in ENV PATH and libx264.c in
/usr/local/bin/ffmpeg/libavcodec directory.



Can you suggest what could be wrong here?



Regards,

Niket
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: FFMPEG libx264 not found error

Victor Carneiro Fardim
Hello, Niket.

This message means that the libx264 binaries and headers are not installed or were not found.

FFmpeg itself does not come with libx264 - the libx264.c file is just a wrapper for libavcodec to interact with libx264.

The solution is to install libx264-dev from your distribution's repositories, or get its source, build it and install it before building FFmpeg.

Hope this can help you and good encodes for everybody,

Victor Carneiro
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: FFMPEG libx264 not found error

Carl Eugen Hoyos-2
In reply to this post by Niket Joshi
2018-04-05 14:09 GMT+02:00, Niket Joshi <[hidden email]>:

> ./configure --disable-x86asm

(This is usually not a good idea.)

[...]

> Include the log file "ffbuild/config.log" produced by configure
> as this will help solve the problem.

Did you read this?

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".