ERROR: libwebp not found using pkg-config

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ERROR: libwebp not found using pkg-config

Edward Shi
Hi, FFMPEG professor:


I tried to enable webp for ffmpeg, and got below error:


configure:

./configure --cc=/usr/bin/clang --prefix=/opt/ffmpeg --extra-version=tessus --enable-avisynth --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame  --enable-libopus --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvidstab  --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libx265 --enable-libxvid --enable-libzmq --enable-version3 --disable-ffplay --disable-indev=qtkit --enable-libopenjpeg  --enable-libopenh264  --enable-libkvazaar --enable-libilbc  --enable-libfdk-aac --enable-nonfree --enable-encoder=aac --enable-libwebp


ERROR: libwebp not found using pkg-config


************************

actually, I have install libwebp.a

    both under

       /usr/local/lib

   and

    /usr/local/Cellar/webp/0.6.0_2/lib/


could someone help?


thanks!



Best regards

Edward Shi

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: ERROR: libwebp not found using pkg-config

Carl Eugen Hoyos-2
2017-10-11 15:15 GMT+02:00 Edward Shi <[hidden email]>:

> I tried to enable webp for ffmpeg, and got below error:
>
>
> configure:
>
> ./configure --cc=/usr/bin/clang --prefix=/opt/ffmpeg --extra-version=tessus --enable-avisynth --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame  --enable-libopus --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvidstab  --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libx265 --enable-libxvid --enable-libzmq --enable-version3 --disable-ffplay --disable-indev=qtkit --enable-libopenjpeg  --enable-libopenh264  --enable-libkvazaar --enable-libilbc  --enable-libfdk-aac --enable-nonfree --enable-encoder=aac --enable-libwebp

Imo, it is a very bad idea to copy somebody else's extra-version name for your
binaries.

> ERROR: libwebp not found using pkg-config

What does the following show?
$ pkg-config --libs libwebp
If you don't have pkg-config, you can use the configure option
--pkg-config=true but
you will have to provide the library yourself (--extra-libs=-lwebp or similar).

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".