ERROR: libmp3lame >= 3.98.3 not found

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ERROR: libmp3lame >= 3.98.3 not found

geet fm
hello
        i try all methods but it still show error

ERROR: libmp3lame >= 3.98.3 not found

PATH="$HOME/bin:$PATH"
PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure \
  --prefix="$HOME/ffmpeg_build" \
  --pkg-config-flags="--static" \
  --extra-cflags="-I$HOME/ffmpeg_build/include" \
  --extra-ldflags="-L$HOME/ffmpeg_build/lib" \
  --extra-libs=-lpthread \
  --bindir="$HOME/bin" \
  --enable-gpl \
  --enable-libmp3lame \
  --enable-libx264 \
  --enable-nonfree
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: ERROR: libmp3lame >= 3.98.3 not found

Moritz Barsnick
On Fri, Dec 01, 2017 at 09:01:43 +0530, geet fm wrote:
> ERROR: libmp3lame >= 3.98.3 not found
[...]
>   --extra-libs=-lpthread \

This should be "-lpthreads" I believe. (It may not matter.)

If that doesn't help, please try "-lpthreads -lm":
http://ffmpeg.org/pipermail/ffmpeg-user/2017-October/037538.html

Moritz
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".