Quantcast

Driver does not support the required nvenc API version

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Driver does not support the required nvenc API version

Daniel
Hello everyone

I am new to ffmpeg and i am trying to encode some video to x265 with
following command :
ffmpeg -i video.mp4 -c:v hevc_nvenc -c:a aac -b:a 128k output.mp4 and
what i get is "Driver does not support the required nvenc API version.
Required: 8.0 Found: 7.1" .
If you can point me on which driver to update i would appreciate. Also
my OS is ubuntu 16.04  ffmpeg ->

ffmpeg version N-86038-ge312ed0 Copyright (c) 2000-2017 the FFmpeg
developers
   built with gcc 5.3.1 (Ubuntu 5.3.1-14ubuntu2.1) 20160413
   configuration: --prefix=/usr/src/ffmpeg/ffmpeg_build
--pkg-config-flags=--static
--extra-cflags=-I/usr/src/ffmpeg/ffmpeg_build/include
--extra-ldflags=-L/usr/src/ffmpeg/ffmpeg_build/lib
--bindir=/usr/src/ffmpeg/bin --enable-gpl --enable-libass
--enable-libfdk-aac --enable-libfreetype --enable-libmp3lame
--enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx
--enable-libx264 --enable-libx265 --enable-nonfree --enable-nvenc
--enable-opencl --enable-librtmp --enable-libv4l2 --enable-libvpx

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Driver does not support the required nvenc API version

Raymond Russell

> On May 12, 2017, at 4:37 PM, Daniel <[hidden email]> wrote:
>
> Hello everyone
>
> I am new to ffmpeg and i am trying to encode some video to x265 with following command :
> ffmpeg -i video.mp4 -c:v hevc_nvenc -c:a aac -b:a 128k output.mp4 and what i get is "Driver does not support the required nvenc API version. Required: 8.0 Found: 7.1" .
> If you can point me on which driver to update i would appreciate. Also my OS is ubuntu 16.04  ffmpeg ->
>

I believe it would be the video driver, you need one of the Nvidia cards that support hardware encoding.


Raymond



_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Driver does not support the required nvenc API version

Erik Dobberkau
Am Samstag, 13. Mai 2017 schrieb Raymond Russell :

>
> > On May 12, 2017, at 4:37 PM, Daniel <[hidden email] <javascript:;>>
> wrote:
> >
> > Hello everyone
> >
> > I am new to ffmpeg and i am trying to encode some video to x265 with
> following command :
> > ffmpeg -i video.mp4 -c:v hevc_nvenc -c:a aac -b:a 128k output.mp4 and
> what i get is "Driver does not support the required nvenc API version.
> Required: 8.0 Found: 7.1" .
> > If you can point me on which driver to update i would appreciate. Also
> my OS is ubuntu 16.04  ffmpeg ->
> >
>
> I believe it would be the video driver, you need one of the Nvidia cards
> that support hardware encoding.
>
>
It's the CUDA driver. Check out askubuntu for install directions.

Erik
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Driver does not support the required nvenc API version

Nicolas George
In reply to this post by Daniel
Le tridi 23 floréal, an CCXXV, Daniel a écrit :
> I am new to ffmpeg and i am trying to encode some video to x265 with
> following command :
> ffmpeg -i video.mp4 -c:v hevc_nvenc

Stop right there: hevc_nvenc and x264 are completely different.

Regards,

--
  Nicolas George

_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Driver does not support the required nvenc API version

Daniel
Hello
Thanks to everyone for your replies i have forgotten to mention following :

nvcc  --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2016 NVIDIA Corporation
Built on Tue_Jan_10_13:22:03_CST_2017
Cuda compilation tools, release 8.0, V8.0.61

./ffmpeg
ffmpeg version N-86038-ge312ed0 Copyright (c) 2000-2017 the FFmpeg
developers
  built with gcc 5.3.1 (Ubuntu 5.3.1-14ubuntu2.1) 20160413
  configuration: --prefix=/usr/src/ffmpeg/ffmpeg_build
--pkg-config-flags=--static
--extra-cflags=-I/usr/src/ffmpeg/ffmpeg_build/include
--extra-ldflags=-L/usr/src/ffmpeg/ffmpeg_build/lib
--bindir=/usr/src/ffmpeg/bin --enable-gpl --enable-libass
--enable-libfdk-aac --enable-libfreetype --enable-libmp3lame
--enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx
--enable-libx264 --enable-libx265 --enable-nonfree --enable-nvenc
--enable-opencl --enable-librtmp --enable-libv4l2 --enable-libvpx

and even though it gives me :  Driver does not support the required nvenc
API version. Required: 8.0 Found: 7.1
maybe it's more ubuntu related question but if anyone have any idea what
could be wrong i would appreciate. Also i have compiled
ffmpeg from source and i have installed cuda toolkit and nvidia driver by
download from the site cuda_8.0.61_375.26_linux.run file.

BR,
Daniel


On Sat, May 13, 2017 at 12:21 PM, Nicolas George <[hidden email]> wrote:

> Le tridi 23 floréal, an CCXXV, Daniel a écrit :
> > I am new to ffmpeg and i am trying to encode some video to x265 with
> > following command :
> > ffmpeg -i video.mp4 -c:v hevc_nvenc
>
> Stop right there: hevc_nvenc and x264 are completely different.
>
> Regards,
>
> --
>   Nicolas George
>
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
>
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Loading...