Compiling FFMPEG with ffplay support

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Compiling FFMPEG with ffplay support

SyRenity
Hi.

Did the compilation parameters changed in recent FFMPEG version?

Configuring the FFMPEG like this:
./configure --prefix=/usr --enable-pthreads

Does not produce ffplay anymore.

I tried to add --enable-ffplay, without any result.

Any idea what I'm missing?

Thanks.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Compiling FFMPEG with ffplay support

Tim Nicholson
On 29/03/11 09:13, Stas Oskin wrote:

> Hi.
>
> Did the compilation parameters changed in recent FFMPEG version?
>
> Configuring the FFMPEG like this:
> ./configure --prefix=/usr --enable-pthreads
>
> Does not produce ffplay anymore.
>
> I tried to add --enable-ffplay, without any result.
>
> Any idea what I'm missing?
>

./configure \
--prefix=/usr/local --shlibdir=/usr/local/lib64 --libdir=/usr/local/lib64 \
--mandir=/usr/local/man --incdir=/usr/local/include \
--enable-gpl --enable-nonfree --enable-version3 \
--enable-x11grab --enable-libdc1394 \
--enable-avfilter --enable-pthreads \
--enable-postproc --enable-libvpx \
--enable-libx264 --enable-libxvid \
--enable-libopencore-amrnb  --enable-libopencore-amrwb \
--enable-libdirac --enable-libschroedinger \
--enable-libmp3lame --enable-libfaac \
--enable-libtheora --enable-libvorbis \
--enable-libfreetype --enable-filter=drawtext \
--enable-static \
--disable-shared

Compiled ffplay along with ffmpeg ffserver & ffprobe yesterday with a
git pull.... so I don't think so.

--
Tim
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Compiling FFMPEG with ffplay support

Кирилл Гаврилов
>
> > I tried to add --enable-ffplay, without any result.
> > Any idea what I'm missing?
>
ffplay needs SDL. Many FFmpeg --enable-* options are silently self-disabled
if 3rd-party library not available.
So probably something happens with your SDL installation...
-----------------------------------------------
Kirill Gavrilov,
Software designer.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Compiling FFMPEG with ffplay support

SyRenity
Hi.

ffplay needs SDL. Many FFmpeg --enable-* options are silently self-disabled
> if 3rd-party library not available.
> So probably something happens with your SDL installation...
> -----------------------------------------------
>
>

Is there a way to see what was disabled and why?

Thanks.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Compiling FFMPEG with ffplay support

Lucien Pullen
Also sprach Stas Oskin at 3/29/11 7:10 AM:

> Hi.
>
> ffplay needs SDL. Many FFmpeg --enable-* options are silently self-disabled
>> if 3rd-party library not available.
>> So probably something happens with your SDL installation...
>> -----------------------------------------------
>>
>>
>
> Is there a way to see what was disabled and why?
You can check config.log to see what was disabled. If you are getting no
ffplay, then check the line ``USE_SDL='' to see if that has anything.

To make sure SDL gets enabled, you'll want to set the environment
variable ``USE_SDL'' to ``/path/to/sdl-config''. Passing the output of
that to configure is a nightmare you don't want.

I had the entire build process (from git pull to install) in a script
and noticed that ffplay hadn't been updated in a month, and that fixed it.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Compiling FFMPEG with ffplay support

SyRenity
Hi.

You can check config.log to see what was disabled. If you are getting no
> ffplay, then check the line ``USE_SDL='' to see if that has anything.
>
>
Originally there was no USE_SDL message at all.


> To make sure SDL gets enabled, you'll want to set the environment
> variable ``USE_SDL'' to ``/path/to/sdl-config''. Passing the output of
> that to configure is a nightmare you don't want.
>

Did this with no results - ffplay is still not being build.

Any idea what else I can check?

Thanks.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Compiling FFMPEG with ffplay support

SyRenity
By checking the configure output, I see the following:

SDL support               no

Any way to see why it was disabled?

Thanks.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Compiling FFMPEG with ffplay support

Reindl Harald

Am 05.04.2011 14:46, schrieb Stas Oskin:
> By checking the configure output, I see the following:
>
> SDL support               no
>
> Any way to see why it was disabled?
>
> Thanks.

Have you installed the devel-package?

[builduser@buildserver64:~]$ rpm -qa | grep SDL
SDL-devel-1.2.14-10.fc14.x86_64
SDL-1.2.14-10.fc14.x86_64



_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

signature.asc (269 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Compiling FFMPEG with ffplay support

SyRenity
Hi.


> Have you installed the devel-package?
>
> [builduser@buildserver64:~]$ rpm -qa | grep SDL
> SDL-devel-1.2.14-10.fc14.x86_64
> SDL-1.2.14-10.fc14.x86_64
>
>

Yes, I did:

[root@nctest ~]# rpm -qa | grep SDL
SDL_image-1.2.5-4.el5
SDL-1.2.10-8.el5
SDL-devel-1.2.10-8.el5

Anything else to check?

Thanks.
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|

Re: Compiling FFMPEG with ffplay support

michelel
This worked for me:

1. sudo apt-get install libsdl2-dev
2. ./configure --enable-ffplay
3. open FFmpeg/ffbuild/config.mak and check to make sure fflplay and SDL2 are enabled

     FFMPEG_CONFIGURATION= --enable-ffplay
     CFLAGS-ffplay=-D_REENTRANT -I/usr/include/SDL2
     EXTRALIBS-ffplay=-lSDL2
     CONFIG_FFPLAY=yes

4. make