Quantcast

Compile error building the newest ffmpeg from GIT

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Compile error building the newest ffmpeg from GIT

Adruna
Hi all,

I am regularly updating my FFMPEG build om my CentOS 5 machine. After my
new GIT update today building FFMPEG fails me with an error related to
an xvid part.

The previous version I successfully build was: N-54783-ga0b7e73 from
somewhere in June.

The new version I tried was from today.
It would be great if someone could point me in the right direction to
solve the issue.

I use the following configure command:

./configure --enable-shared --enable-nonfree --enable-gpl
--disable-ffserver --disable-ffplay --enable-pthreads --enable-libgsm
--enable-libmp3lame --enable-libx264 --enable-libxvid --enable-libtheora
--enable-libvorbis --enable-zlib --enable-bzlib --enable-libopenjpeg
--enable-libfaac --enable-libopencore-amrnb --enable-libopencore-amrwb
--enable-version3 --enable-libvpx

and configuring goes well.

The make command fails with the following error below.


CC      libavcodec/libvpxdec.o
CC      libavcodec/libvpxenc.o
CC      libavcodec/libx264.o
CC      libavcodec/libxvid.o
libavcodec/libxvid.c: In function ‘xvid_encode_init’:
libavcodec/libxvid.c:362: error: ‘xvid_plugin_lumimasking_t’ undeclared
(first use in this function)
libavcodec/libxvid.c:362: error: (Each undeclared identifier is reported
only once
libavcodec/libxvid.c:362: error: for each function it appears in.)
libavcodec/libxvid.c:362: error: expected ‘;’ before ‘masking_l’
libavcodec/libxvid.c:363: error: expected ‘;’ before ‘masking_v’
libavcodec/libxvid.c:364: warning: ISO C90 forbids mixed declarations
and code
libavcodec/libxvid.c:539: error: ‘masking_l’ undeclared (first use in
this function)
libavcodec/libxvid.c:550: error: ‘masking_v’ undeclared (first use in
this function)
make: *** [libavcodec/libxvid.o] Error 1


Any help will be apreciated, please let me know if more info is needed.

Kind regards,

Adruna
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Compile error building the newest ffmpeg from GIT

Adruna
On 23-9-2013 21:14, Adruna wrote:

> Hi all,
>
> I am regularly updating my FFMPEG build om my CentOS 5 machine. After my
> new GIT update today building FFMPEG fails me with an error related to
> an xvid part.
>
> Any help will be apreciated, please let me know if more info is needed.
>
> Kind regards,
>
> Adruna
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>

Argh, updating my xvid library to a more recent version seemed to help.

Sorry to bother you all!

Adruna
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user
Loading...