Cannot build ffmpeg 4.1 on Cygwin

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot build ffmpeg 4.1 on Cygwin

Eric Thomas
Hello,



I have been trying to build a set of shared libraries in Cygwin.

Here is some system info:



uname –a

     CYGWIN_NT-6.1-WOW64 tvmf2p4-ea00063 1.7.17(0.262/5/3) 2012-10-19 14:39
i686 Cygwin


gcc -v

    4.5.3 posix


make –-version    ***(no gmake)*

     GNU Make 3.82.90



sed –-version

    GNU sed 4.2.1



bash --version

    GNU bash 4.1.10(4)-release (i686-pc-cygwin)


nasm -v

    version 2.10.05



Configure cmd

     bash ./configure –prefix=/usr/tmp/FFmpeg-4.1 -–enable-shared

make

     CC     libavdevice/alldevices.o

     gcc: unrecognized option '-pthread'

     CC     libavdevice/avdevice.o

     gcc: unrecognized option '-pthread'

     libavdevice/avdevice.c: In function 'device_next':

     libavdevice/avdevice.c:88:13: warning: 'av_oformat_next' is
deprecated (declared at ./libavformat/avformat.h:2088)
     libavdevice/avdevice.c:88:13: warning: 'av_iformat_next' is
deprecated (declared at ./libavformat/avformat.h:2080)

     CC     libavdevice/dshow.o
     gcc: unrecognized option '-pthread'

     libavdevice/dshow.c: In function 'dshow_cycle_devices':

     libavdevice/dshow.c:264:12: error: 'VARIANT' has no member named 'vt'

     libavdevice/dshow.c:268:46: error: 'VARIANT' has no member named 'bstrVal'

     libavdevice/dshow.c: In function 'dshow_show_filter_properties':

     libavdevice/dshow.c:516:5: warning: missing braces around initializer

     libavdevice/dshow.c:516:5: warning: (near initialization for
'filter_info.achName')

     ffbuild/common.mak:60: recipe for target 'libavdevice/dshow.o' failed

     make: *** [libavdevice/dshow.o] Error 1

Can anyone help solve this problem?

Thanks,

Eric
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Cannot build ffmpeg 4.1 on Cygwin

Carl Eugen Hoyos-2
2018-12-27 19:27 GMT+01:00, Eric Thomas <[hidden email]>:

> libavdevice/dshow.c: In function 'dshow_cycle_devices':
> libavdevice/dshow.c:264:12: error: 'VARIANT' has no member named 'vt'

The line exists since 2011, so I would not assume an issue that can /
should be fixed in FFmpeg, is your Cygwin old?

Work-around should be "--disable-indev=dshow".

Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Cannot build ffmpeg 4.1 on Cygwin

Eric Thomas
My Cygwin is probably old - the machine I am developing on has version
1.7.17.

The "--disable-indev=dshow" flag allowed the build process to get further,
but it still fails with multiple errors.
Here are the first few...

In file included from libavutil/hwcontext_dxva2.c:31:0:
libavutil/hwcontext_dxva2.h:40:5: error: expected specifier-qualifier-list
before 'IDirect3DDeviceManager9'
libavutil/hwcontext_dxva2.h:72:5: error: expected specifier-qualifier-list
before 'IDirectXVideoDecoder'
libavutil/hwcontext_dxva2.c:40:54: error: expected declaration specifiers
or '...' before 'IDirect3DDeviceManager9'
libavutil/hwcontext_dxva2.c:64:5: error: expected specifier-qualifier-list
before 'IDirectXVideoAccelerationService'

There are several others, all occurring in hwcontext_dxva2.c

On Thu, Dec 27, 2018 at 2:25 PM Carl Eugen Hoyos <[hidden email]> wrote:

> 2018-12-27 19:27 GMT+01:00, Eric Thomas <[hidden email]>:
>
> > libavdevice/dshow.c: In function 'dshow_cycle_devices':
> > libavdevice/dshow.c:264:12: error: 'VARIANT' has no member named 'vt'
>
> The line exists since 2011, so I would not assume an issue that can /
> should be fixed in FFmpeg, is your Cygwin old?
>
> Work-around should be "--disable-indev=dshow".
>
> Carl Eugen
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Cannot build ffmpeg 4.1 on Cygwin

Reindl Harald


Am 28.12.18 um 13:54 schrieb Eric Thomas:
> My Cygwin is probably old - the machine I am developing on has version
> 1.7.17

seriously: cygiwn is at version 2.11.2

what is the point using horrible outdated base-software and then jump to
the latest ffmpeg? common sense says if i try to build the latest stuff
and it don't work i first try to get my environemnt up-to-date and after
that try again
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Cannot build ffmpeg 4.1 on Cygwin

Carl Eugen Hoyos-2
In reply to this post by Eric Thomas
2018-12-28 13:54 GMT+01:00, Eric Thomas <[hidden email]>:
> My Cygwin is probably old - the machine I am developing
> on has version 1.7.17.

Then I suggest an update.

> The "--disable-indev=dshow" flag allowed the build process to
> get further, but it still fails with multiple errors.
> Here are the first few...
>
> In file included from libavutil/hwcontext_dxva2.c:31:0:
> libavutil/hwcontext_dxva2.h:40:5: error: expected
> specifier-qualifier-list before 'IDirect3DDeviceManager9'

--disable-dxva2

Please do not top-post here, Carl Eugen
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Cannot build ffmpeg 4.1 on Cygwin

Eric Thomas
In reply to this post by Reindl Harald
Reindl,

Thanks for taking the time to comment.

I work in a "sensitive" environment, and am limited to what corporate
system administrators are willing to provide.
I'm looking into upgrading the Cygwin they provided.

On Fri, Dec 28, 2018 at 8:05 AM Reindl Harald <[hidden email]>
wrote:

>
>
> Am 28.12.18 um 13:54 schrieb Eric Thomas:
> > My Cygwin is probably old - the machine I am developing on has version
> > 1.7.17
>
> seriously: cygiwn is at version 2.11.2
>
> what is the point using horrible outdated base-software and then jump to
> the latest ffmpeg? common sense says if i try to build the latest stuff
> and it don't work i first try to get my environemnt up-to-date and after
> that try again
> _______________________________________________
> ffmpeg-user mailing list
> [hidden email]
> http://ffmpeg.org/mailman/listinfo/ffmpeg-user
>
> To unsubscribe, visit link above, or email
> [hidden email] with subject "unsubscribe".
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Cannot build ffmpeg 4.1 on Cygwin

Reindl Harald


Am 28.12.18 um 14:28 schrieb Eric Thomas:
> Reindl,
>
> Thanks for taking the time to comment.
>
> I work in a "sensitive" environment, and am limited to what corporate
> system administrators are willing to provide.
> I'm looking into upgrading the Cygwin they provided.

go and tell that "corporate system administrators" they should start
doing their damned job, all your cygwin libraries are outdated and full
of security holes fixed years ago for the rest of the world

they need to understand that cygwin is nothing else then bring the whole
unix stack to windows with all it's libraries and they need the same
patches as if they would run on Linux or a BSD system

> On Fri, Dec 28, 2018 at 8:05 AM Reindl Harald <[hidden email]>
> wrote:
>
>>
>>
>> Am 28.12.18 um 13:54 schrieb Eric Thomas:
>>> My Cygwin is probably old - the machine I am developing on has version
>>> 1.7.17
>>
>> seriously: cygiwn is at version 2.11.2
>>
>> what is the point using horrible outdated base-software and then jump to
>> the latest ffmpeg? common sense says if i try to build the latest stuff
>> and it don't work i first try to get my environemnt up-to-date and after
>> that try again
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".
Reply | Threaded
Open this post in threaded view
|

Re: Cannot build ffmpeg 4.1 on Cygwin

Eric Thomas
In reply to this post by Carl Eugen Hoyos-2
Carl,

Thanks for your help! I have successfully built a set of shared libraries
on Cygwin.

My working configure command:
    bash ./configure --prefix=/usr/tmp/ffmpeg-4.1 --enable-shared
--disable-indev=dshow --disable-dxva2
_______________________________________________
ffmpeg-user mailing list
[hidden email]
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
[hidden email] with subject "unsubscribe".